Can't fully publish website with new hosting company


(Charles Mitri) #1

I recently switched from Go Daddy to Little Oak because LO is cheaper and they advertise that they cater to RW users. When I published my site with LO it does not publish my gallery, home page, and one image on one page, and the text formatting is off. It’s a mess and LO tells me it’s a RW software problem. I know my site is all there because I checked the folders, it’s just not getting uploaded properly. Can anyone help me with this?

Thanks


(Rob Beattie) #2

Have you tried marking all pages and resources as changed and then re-publishing all files?

And have you got a URL for the site?

Rob


(Matthew Long) #3

I’ve been using Little Oak for 9 years with a fairly complex site and had no problems with RW compatibility at all (http://www.cdi.edu.au).

However, when I first started using Little Oak I did have some issues using RW’s built in publishing, and in desperation I turned to a third-party FTP application (Transmit). Since then, I’ve had no problems at all.


(Charles Mitri) #4

Hey Matthew,

Thanks for your reply. I did finally get my site up (with no help from Little Oak customer support) by using Cyber Duck, however, I’m still not receiving emails from my Contact page.

I had the same problem when I was with Go Daddy, but the problem got fixed by using a gmail account and making sure I had two settings in RW checked.

I’ve now tried those same configurations with Little Oak and RW but the problem still persists.

I’m beginning to think the issue is with the hosting company, Little Oak, because I’ve tried every setting and two separate email accounts, both gmail and yahoo, and I’m still not receiving emails from my site.


(Charles Mitri) #5

Hi Robbeattle,

Yes, I did try that but it didn’t work. I ended up using a third party FTP program called Cyber Duck which finally got my site up on Little Oak.

My only problem now is that I can’t receive emails from my Contact page on my site. I’m beginning to think the issue my be with my new hosting company Little Oak. I was with Go Daddy before and had problems with that as well, but got it fixed by using a gmail account instead of a yahoo account and by making sure two boxes were checked in RW that dealt with common email problems.


(Doobox Software) #6

Quite a lot of hosts have a security measure in place that will prevent you sending mail to any email address other than one tied to your domain, via a php script.

Eg:

Your domain = www.mycoolsite.com

email will fail to = anyone@anyotherdomain.com

email will work to = anyone@mycoolsite.com


(Matthew Long) #7

Hi Charles,

I do extensive emailing from my site on Little Oak and have no problems. Not only do I use contact forms, but I also generate emails whenever a student on our site completes an online quiz (it is an educational site). We send both plain text and HTML emails without problem.

However, I never use the built in contact form that comes with Rapidweaver. I either use my own PHP/HTML code, or I also use the Doobox ‘HTML Contact Form’ stack.

https://www.doobox.co.uk/stacks_store/demos/htmlcontact.html

This has always worked flawlessly.


(Matthew Long) #8

Actually, one further comment…

When I first started using Little Oak I was using RW’s built in FTP, and the main problem was that forms wouldn’t work. Everything else seemed OK, but forms wouldn’t work, so the Little Oak support told me to try a third party FTP program. This was actually the main reason I tried using Transmit to upload my site, and then everything started working.


(Pamm Monaghan) #9

Here it is a year later and still Little Oak is having issues. I uploaded my web site and had to use Filezilla to do so as Rapid Weaver would not do it. Claimed my sign in was not recognized. None of the linked documents will download and don’t seem to be there at all.

So far no response or suggestions from Little Oak . Any ideas other than go back where I was?


(scott williams) #10

Go to chillidog @barchard will take care of you


(Gregory Barchard) #11

I’m certainly happy to help. Unfortunately LO would be the best to advise you on the correct settings to use for publishing. There are, however, a few things to try/check:

  1. what does the ‘test’ button say in the Rw publishing dialog
  2. what version of RW are you using?
  3. are you using FTP or SFTP?
  4. is your publishing path correct?

I hope that helps. If you’d like to get started with Chillidog, just let me know. Migrations (email, web files, and databases) are, as always, free :slight_smile:

-Greg


(Lisa Sandler) #12

Ditto, Chillidog. @barchard


(Pamm Monaghan) #13

Greg

Thank you so much for the super fast reply.

I have a case for support in at LO.

In response to your questions:

  1. “Couldn’t sign in to your FTP server. Your sign-in details are
    incorrect, please reenter them and try again.”

  2. 7.5.1

  3. FTP.

  4. my web site is greatlakesrailcar.com. LO told me to use:
    /www/greatlakesrailcar.com

Questions: Do you have these problems? I didn’t know you were Rapid
Weaver savvy or I would have gone with your company. I did look at you,
but LO claims RW support. Took bad I hadn’t found the RW blog/support
area first or I would have re-thought that.

Many Thanks

Pamm


(Gregory Barchard) #14

the error would indicate that the username and password combination entered is incorrect. I would double check you don’t have a typo here. for instance, an extra space at the end of either will break it.

hope that helps.


(Rob Beattie) #15

Although all my newer sites are at Chillidog I have a number of older ones still with Little Oak and to be honest, I’ve only occasionally had any publishing problems. I’d suggest double checking the password/user name combo you’re using.

FWIW I just published updates to a site hosted with LO two mins ago and it worked fine, first time.

Maybe a shout out here to @LittleOakHosting will also attract their attention.

Good luck, I’m sure you’ll sort it.

Rob


(Matthew Long) #16

I continue to use Little Oak without any problems and upload to it every day. However, I long ago abandoned using RW’s own FTP and I only use a third-party solution.

Initially I was using application ‘Transmit’, but sometimes it can have problems with deleting folders from the server. So I then switched to ‘Forklift’, which works brilliantly. As such, my workflow is to (1) export my site to a local folder on my hard drive and then (2) upload to Little Oak using Forklift. It works for me without any hassles and is so much quicker than publishing via RW. I don’t intend any disrespect to RW, but the FTP issues just seem to keep rolling on, and I have no intention of revisiting the built in solution.

Just my two cents worth…