RW8 & little oak not uploading FTP

Hello, I hope someone can help. I’ve been using RW since RW5.
RW8 current
OSX 11.4
I have been trying for some time to FTP publish my site to Little Oak, but it keeps failing. Little Oak support said to get hold of Realmac for help, since it’s not on thier end. Parts of my site were uploaded off and on a few weeks ago, but since then it just won’t upload at all.
The connection always tests out ok.
I’ve tried changing my log in credentials and all the publishing setting a few different times, and still nothing has worked.
I watched Realmac’s video on FTP uploading issues and nothing there helped, but at the end it said if none of what was in the video works, to send them the support log. It’s been a week and I haven’t heard back and I didn’t even get a confirmation email showing it was received, yet the email with the log does show sent in my sent folder.
When it fails it also then freezes and I have to force close RW8.
The error messages usually are, “couldn’t upload xxxxxxxx”. With the xxxxxx being some different file every time. Never the same file.
I on occasion get the error “transfer failed”

http://tehachapiweddingdj.com

Thanks for your help,

Hi Russ, just a few things I would check:

  1. does the ‘test connection’ button work (sounds like it does)
  2. try lowering your publishing speed to 2 or 3
  3. check your disk usage via your hosting account to make sure there is space to upload the files
  4. check ftp is set to active and passive appropriately. the default mode typically works best (passive) unless otherwise instructed to do so
  5. SFTP may work as it’s a different application on the server. If LittleOak supports it, try SFTP

Hope that helps.

Cheers,
Greg

There was this reply to a publishing problem with a Little Oak account:

Of course not sure if that’s solution to your issue, but maybe worth a try?

OK great I’ll give those a try and check back

Thank you David, I’ll see if that can help. I didn’t change the password, but I did create a new one on little oak for that site.

1 Like

If you haven’t yet, switch to SFTP. If the test button works, your login credentials are probably fine.

Nope, the SFTP didn’t make a difference.
The FTP test always works.

Didn’t work but thanks for the input.
I changed my password and it didn’t make a difference.
Little oak tech varied that my credentials are right and that I have plenty of space.
He was able to make it work on his his side.

Yeah,

The Test button in publishing only test the login credentials and nothing else. So if the test works your login and password are fine.

Can you publish to a local folder without errors?

It’s really difficult to say what the issue might be without more information.

A screenshot of your publishing settings and of the error message you are getting.

You might want to go through the steps in this trouble shooting article. Specifically have a look at the logs.

If you can’t publish to a local folder then it might be something in resources that can’t publish.

I’d still keep it as SFTP as it’s much more stable and secure.

  1. Test always have worked with no problem.
  2. I have tried every speed some time back at least three different times and it didn’t help. I tried that some time back to with no positive result.
  3. I check on Little Oak and I have a huge amount os disc space left.
  4. I’ve tried all the passive, active and the other setting quit a few different times in the last three weeks, but none made a difference.

I was hopping realmac would look at my log to see if they can find out what is going on. I think I’ve tried all the basics. I can try sending it to them again. I checked in my sent box and it shows sent, but I never got a confirmation email back?

RW won’t be able to diagnosis and view the server logs. As a FTP client, you’ll only be able to provide client side logs. You can see these via the “View > Web Server Logs” in RW.

If you get no where with LittleOak, let me know. I may be able to help with Hosting :slight_smile:

-Greg

Little oak tested my ftp uploading with my credentials and setting and they said it’s working fine on their end. The reason I sent realmac my log was because thier tutorial video for diagnosing and fixing ftp issues specifically told me that if nothing in their ftp and publishing settings tutorial video helps, to send them the logs and they will help.

Did you try with a standalone FTP app like Transmit or FileZilla (Step 3)? If so, did it work?

Did you have a look at the log file (you can clear and copy them from the help menu)?

I have had no sites on Little Oak in several years, but they used to be pretty good.

I don’t know how active RealMac is in monitoring their support emails. So lets tag them here to get their attention @dan @tpbradley

I’ll have to to download a standalone ftp app like you suggest. I never used one, so I’ll have to look into it. I would expect paying for RW every time they make a major upgrade since many years back that it would just work or thier support would figure out what’s going on? I followed thier tutorial instructions to a t.

FileZilla project is open source (free) and works like a charm.
https://filezilla-project.org/

It will do what you need, the user interface is a bit confusing for many Mac users but once you get used to it, it’s easy. And the log file is displayed right in front of you.

1 Like