Can't upgrade from RW6.0.9 to 6.2.4


(Rob Beattie) #1

When I start RW6.0.9 I get a prompt inviting me to upgrade to 6.2.4. I’ve tried twice now and each time it crashes with the following error.

“A new version (14923) of RapidWeaver 6 is available - you have 14677. Please update to the latest version as your problem may have already been fixed.”

My options are to either send the report or send & relaunch application.

When I choose the latter I’m back at 6.0.9 and it’ll keep inviting me to upgrade.

What’s the way out of this loop?

Thanks


(Rob Beattie) #2

Part II

This time I chose ‘Send the Report’. Now I have a dialogue saying “Installing update” which has been sitting there for 10 minutes.

How long does the upgrade normally take?

Thanks

Rob


(Nik Fletcher) #3

As always, you can download the latest version here: http://realmacsoftware.com/rapidweaver/releasenotes

Remove 6.0.9 (just Trash the app) and place the new download into the same location.

Note: the issue you’re running into is a software update bug in 6.0.9 that was fixed in the next release.

—N


(Dan) #4

@robbeattie You can download the latest version from here (version 6.3): https://dl.devmate.com/com.realmacsoftware.rapidweaver6/14965/1438338651/RapidWeaver6-14965.zip

Just replace your old version. Simple :smile:


(Rob Beattie) #5

Thanks guys. It’s been tortuous but I’ve finally joined the 21st century and published my first RW 5.3.2 site using RW6, via 5.4.1.

Only another 30 sites to go!


(Robert Ziebol 🖖🏼) #6

Is RapidWeaver 6.3 out? I just checked for updates having 6.2.4 and I get no new updates. Or is it still in beta?


(Rob Beattie) #7

6.3 looks like a release. There is a beta but it’s got a different call sign.


(Nik Fletcher) #8

You might want to check the release date on 6.3:

To help get things rolling smoothly we tend to put release notes live the day before, so if we need to get a link to anyone via support between final beta and official launch it’s ready to go :slight_smile: