Update error on Rapid Weaver 5.3.2 going to RW6


(Dennis Fett) #1

Finally ready to move up to RW6 from 5.3.2. And I got this “an error occurred in retrieving updated information please try again later” well unfortunately later never did work. I do not want to have to re-create my website any hints or helps on how I can update or maybe download the new version and keep all the content without having to spend weeks on updating my website.

My Rapid Weaver 5.3.2 has been acting weird for a number of months. And that’s the reason why I decided to upgrade to our RW6.

He helps and tips would be greatly appreciated.


(Dennis Fett) #2

Isn’t there anyone who can help on this issue I was hoping to have new update going by now. Can’t without any help. How do I take my existing site and get it updated if it won’t let me.


(David) #3

Hi,

You have to update to RW 5.4.1, save your project(s), then they can be opened in RW 6. See the upgrade guide:

hope this helps.


(Dennis Fett) #4

I cannot update, so then you’re saying I just go to the link you provided… how will Rapid Weaver know I have 5.4.1. Will it automatically launch into it 5.4.1? Then do you think it’ll let me update from that point.


(David) #5

I don’t quite understand what you mean. I suggest per realmac’s instructions: downloading 5.4.1, opening your projects and saving them, then they should open fine in RW 6. RW 5.4.1 does not have to be registered to open and save the project file. You will have to make sure your 3rd party plug-ins and stacks (if you’re using any) are also updated for RW 6. RW 6 uses a different extension for the project file your_project_name.rw6 as opposed to the RW 5.X project file your_project_name.rwsw

.rw6 files can only be opened by RW6, i believe .rwsw files will not open in RW6.

Once you download 5.4.1, launch it directly, then you’ll know that version is running, and then open your projects from within 5.4.1 and save them.

see this post: Importing RW 5 Projects into RW6. Read here first


(Dennis Fett) #6

I’m very thankful for your kind help. I will do exactly as you posted and if I run into any issues I will post it here later on this evening. Perhaps the issues I’ve been experiencing for quite some time we’re due to the fact that I did not have 5.4.1.


(David) #7

no problem - hope it works out for you. there have been many post on this subject in the forum. A search in the forum will return many results that may help if you run into problems.


(Dennis Fett) #8

Bad news my files did not transferred can you help?

Posted another post a bit ago. In my haste I forgot to post it here. I have no idea what to do at this point. I can still launch my last rapid Weaver 5.4.1. Content is still there on 5.4.1 . RW6 produced another page that sort of purple that says project that must be RW6. Any ideas other than having to transfer all my information on to RW6 from scratch?


(Dennis Fett) #9

I just discovered. I cannot find our RW6 when I go to my applications folder. The only way I can access it is by clicking on the purple folder that’s on my desktop. So where did it get put?


(David) #10

Here are other relevant posts on this topic:

If you don’t find the solution there it would be helpful to understand the problem if you would post what theme you are using, and if you are using Yourhead Stacks (and which version) and if so what stacks you are using. Screen shots are also helpful.


All content is missing, upgrading from RW5 to 6
(David) #11

Not sure, but you should be able to use spotlight to find it. Do you mean a purple file or folder? What is the extension? I’m guessing it’s probably your project file for RW6. A screenshot might be helpful.


(Dennis Fett) #12


(David) #13

that’s your RW6 project file. It should have an .rw6 extension. I find it helpful to have the extension visible so then one can more easily tell what the file is for and what app is associated with. You can turn that on in Finder > Preferences > advanced: “Show All Filename Extensions”.


(Dennis Fett) #14

Using smart business with a few tweaks on the previous version.

I followed all the directions and nothing worked.

I still can open up my page in RW 5.4.1. Is there in someway to bring it in from there into our RW6?

The Only Plug-ins I use is PayLoom (needs to be upgraded and RapidCart And RapidLink (I will not be using them in RW6, just using PayLoom). My page is simple ( peafowl.com )


(Dennis Fett) #16

I did it but the folder on desktop looks the same…


(Dennis Fett) #17

It now has the .rw6 extension on that folder…


(David) #18

As mentioned in some of the forum links i posted above, it might be that you need to import your theme and/or plug-ins from RW5. On the main “RapidWeaver” menu in RW6, there’s an option to copy over all your add ons from RW5.

But first you need to open your RW5 project in RW 5.4.1, do a “save as” (or maybe just “save” - not sure) and then open that saved file in RW6, as instructed in the upgrade guide.

Please actually read through those linked posts - there is bound to be something relevant and helpful for you there. And if not in those links, do a search of the forum for posts relevant to the problems you are experiencing. Search is your friend!


(Dennis Fett) #19

I went to that folder that I originally had and rapid Weaver 5.3.2 which upgraded to 5.4.1 and created a save as folder. I’ll use that and follow your instructions to bring over my files.

I have not Upgraded to PayLoom yet. Should I wait to do that until this issue is resolved or should I do that immediately?

Search is my friend, but that is why I asked I posted here because the search was not helpful. You have cleared it more by my questions…


(David) #20

well glad to help, but the answers i supplied are just what i’ve read in the above linked posts and other posts found in the search.


(Dennis Fett) #21

Thank you, thank you, for all being so patient with me. Good news, everything work with opening the new information and it pulled it in as you all said. When I published my new updated page I will post it on here for all to see. Little confusing but in the end all is there saves me a lot of work and now I can work on my new theme HIVE which I got . Just love it