Contact form on Rapidweaver Classic not working as it used to


A few months ago, I paid to upgrade to Formloom 4 so I could use a more sophisticated contact page that could potentially filter out spam entries. I found that it was a bit overkill for what I needed and returned to the basic contact page provided by Rapidweaver Classic.
The problem I am having (sorry if this is repeated elsewhere) is that before today, I was receiving messages from my own email aaddress nd not from those of the people submitting the contact form.
I have tried troubleshooting this multiple times with no success, and now the contact form isn’t working at all and I am not receiving any messages through it when sending a test message. Instead, a message comes up: “I’m sorry, there seems to have been an error trying to send your email. Please try again.” and I simply can’t understand why.
The contact page shows as normal on the website. I have also deleted the contact page a couple of times and rewritten it, republished it in the aim of getting rid of any bugs, and and tried it on different web browsers
I’m not trained in website design but have been designing my own websites (WISYWIG) for years without issue.
In the Contact Form settings ‘Send to’ is my email address - see screenshot…
Please can anyone help?
Thank you

The problem I am having (sorry if this is repeated elsewhere) is that before today, I was receiving messages from my own email aaddress nd not from those of the people submitting the contact form.

Hi @rapidweaveruser. The highlighted setting in your screenshot is what controls if the contact form message is submitted using your email address, or your web visitor’s email address that they enter on your contact form.

Are you wanting that “From” email address to be yours, or that of your web visitor who is submitting the form?

Quick follow-up, it looks like Ionos updated their mail sending policy a few weeks ago, which means you will need to check that Advanced setting box “Send email using your email address” from your posted screenshot.

Try checking that box under Advanced: “Send email using your email address” in RapidWeaver, then republishing your site. Afterwards, try submitting the contact form again to see if it sends.

Let us know how it goes.

Thanks for this. I have ticked the box suggested and now receiving test emails again. The only problem now is that they are from my email address. I want the “From” email address to be that of the web visitor who is submitting the form. Can you help with that please?

Follow up… Thanks for the info on Ionos. I’m guessing this means I no longer have the option to receive emails from the web visitor email addresses. If this is true it explains the change and why it has been impossible to resolve the problem.
Thanks again for your help.

Hi @rapidweaveruser,

More and more hosters around the world are changing their policies on this. I run a (small) hosting company myself, and I changed my policy on this last year too.

The reason is that if a visitor enters their corporate email address in your webform, and if that corporation has a half decent IT department, the email will never arrive. Corporations are steadfast rolling out anti spoofing and phishing mechanisms like DKIM and SPF to make sure only their mailservers can send out mails with their mail addresses.

This effectively means that a function like you’re used to using will become extinct in the near future, but it will help prevent phishing and spam thankfully.

So there’s hoping that a person who contacts you enters the right email address on your form, without any typos :disappointed_relieved:


1 Like

Thanks for the clarification Erwin. I was thinking this practice would probably be rolled out over time across all providers.

Small nuisance for a larger gain and hopefully less time spent sorting through spam emails…

All best,


@rapidweaveruser Did you happen to send in a support ticket ? That is best way to receive fast support from @yabdab

Not for the formloom problem, but I will in future if I have an issue with it thanks. Just setting up a contact page to try out again…

1 Like