Continual "Document Could Not Be Saved" in RW7 Publish to local folder also doesn't work


(Jody Joy) #1

Working on a RW7 project and saving frequently. After 3-4 saves I continually get the message that the document could not be saved. Only solution is to duplicate the project with a new name and trash the old one. This is happening frequently and is a problem.

Additionally, neither Export Site, nor Publish to local folder which I have set up in Publishing Settings works. Basically nothing happens.


(Robert Ziebol 🖖🏼) #2

Have you sent an email with the project file to Realmac? support(at)realmacsoftware(dot)com if you do not have the email.


(Ben) #3

I often have the same problem.


(Greg) #4

Regarding the saving issue only I had the same problem in rw6. I would have to do a “save as” then rename. The problem appeared to be associated with auto save. I had turned it on to try it. After turning it off again the issue went away.


(Greg Schneck) #5

As info only… I have many many publishing issues also with RW7. Sent an email to support last Monday noon and have no response yet.

I save a LOT too on six different project files but have never experienced you file problem.


(Greg Schneck) #6

If you are running your project from a Dropbox folder try moving the project outside of Dropbox. I had to do that. I then manually drop the projects into a “backup” dropbox folder.


(Jody Joy) #7

Thanks for suggestions everyone. I’m not using Dropbox, and this time a complete shut down and restart helped with the “publish to local folder” issue. The only way around the frequent “document can’t be saved” BUG (yes, I’m using that word), is to duplicate the project then rename it. I have experienced the issue with Auto Save on as well as off (to the best of my knowledge/memory).

I am assuming RW is aware of this and hopefully working on a solution.


(Robert Ziebol 🖖🏼) #8

Hi Jody,
Assuming Realmac is aware of the situation and actually INFORMING them of your situation are TWO DIFFERENT things.

Also, your issue could be caused by having the item on Dropbox. Especially if you are saving it constantly and the previous save has not synced yet, or if you have versions or autosave turned on and again, the save that RapidWeaver made 5 minutes ago is not synced and not RapidWeaver is trying to save again. I would save on your desktop and then copy it over to Dropbox when done. Use it as a BACKUP of your project file. Or turn off autosave and be sure it is synced before saving.


(Matthew Long) #9

Hi Jody,

Well I haven’t upgraded to RW 7 yet, but I have had ongoing issues with being unable to save projects in RW 6. After a lot of troubleshooting using the same project file on two different Macs (one crashed upon saving quite often, the other never), I found out one useful piece of information that solved the problem for me…

Initially RW used to crash once in a while upon saving, but it would then be fine after a restart. However, it then started happening more and more often, until one day I simply could not save my project, no matter whether I restarted, changed the file name, or even used an older version of the project that had worked a few days before. I was completely frustrated and could not use the project. However, I could open the very same project on a different Mac and save without difficulty. So I went hunting for differences between the two installations of RW to see what was different.

Basically I found that after a crash on saving, RW would generate a problem log file in the following location:

User-> Library-> Containers-> com.realmacsoftware.rapidweaver6-> Data-> Library-> Logs-> com.realmacsoftware.rapidweaver6-> Problem reports->

If I then deleted the ‘Problem Reports’ folder, and the ‘com.realmacsoftware.rapidweaver6’ folder immediately above that (but NOT the folder of the same name that sits further up the hierarchy in the ‘Containers’ folder), then everything worked fine again.

Now I can use RW for many days before I might run into a crash on save. If this happens, I check the file path described above and voila, the problem reports folder is back. If I delete it, everything works again.

I did let Realmac Software support know about this, and I did get a very limited reply that basically said “Don’t muck around with things”. However, this solution works for me, and the folder is not present on my Mac that works perfectly well. As such, I don’t feel worried about deleting it.

As I said, this works for me in RW 6, but I don’t know about RW 7.


Unable to save a file