RW 7.5.5 stopped saving, exporting, or publishing


(Richard Widman) #1

RW has always had some crashes, but as of a couple of days ago, it crashes whenever I try to save the file, even with no changes.

It just goes to the spinning ball until I kill it.


(Doug Bennett) #2

Does it do this with a single project file? Did you try opening a new project and saving? If the new project file saves okay then it’s probably something wrong with the current project that won’t save. Could have gotten corrupted somehow. Might try to restore a TimeMachine backup from when you know it last worked.

If the new project won’t save then something probably has gone wrong with the RW7 app. You could try to reinstall RapidWeaver.


(Richard Widman) #3

I have tried with three or four projects. All the same. Even tried save as, export, re-publish, etc.


(mark Scott) #4

I used new update for one page,
upon exporting site, an additional new file folder appeared [page-2] not seen within the structure of the rapidweaver program
also, the menu was fouled on the newly updated page


(Richard Widman) #5

I have gotten it to work by going through a very simple page, republishing, then saving, then it went ok to one of the bigger (still not big) projects and it worked, but there must be something behind it, as I’ve spent the whole day getting it to do this, rebooting many times.


(Richard Widman) #6

One more update.
I had 19 small projects to update. Each has 12 stacks pages and about 20 offsite pages for the menu.

After getting it to work on a small one, I found that I could keep going, not with “save”, but with re-publish, for about 6 to 8 projects. Then it crashed again. restarting allowed me to go for about 5 or 6 more, then crash. Another crash after 3 or 4, and then was able to finish.

The question is why? Does it leave things somewhere that build up and crash?

I’m working on a 2016 Mac Book Pro, 2.9 GHz, Intel Core i7, with 16 GB of memory and a 1 TB SSD.