Document Can't Be Saved Bug + Publish Local Folder Bug


(Jody Joy) #1

Mac OS 10.11.5
RW 7.0.2
Foundation & Stacks all current.

After working on a project sometimes 3-4 times a day others after a couple of days, when I go to "Save - Command S) I get the error that the document could not be saved. There are times I can save throughout the day, then the error will pop up. Only recourse is to duplicate the project.

This brings up the second bug which is after duplicating the project and trying to publish to the local folder so I can Transmit FTP, the Local Folder field will be blank, but the “Publish Site To” field will have the local folder checked. Trying to Choose Folder in the settings does not result in the field being filled after selecting the folder. Basically nothing happens. The only solution is to restart my Mac.


(Mark Sealey) #2

Have you tried looking at the logs (in /Applications/Utilities/Console) which RW produces?


(Jody Joy) #3

Sorry Mark, I wouldn’t know what to look for. If you let me know, I will copy and paste the details. At the moment it is still happening even with the latest update.


(Mark Sealey) #4

Jody,

In the Console program (which you can find in /Applications/Utilities), enter ‘RapidWeaver’ in the search box top right.

That will produce one or more page(s) of logs including the errors only from RapidWeaver for the fault you’re experiencing. Good luck!


(Simon Maddox) #5

@Jody this sounds like an issue in OS X (macOS?) that we’ve been tracking. Basically, sometimes Apple doesn’t “release” its hold on files when accessed in a certain way. Once the number of files they fail to release gets to 255, the only solution is a reboot.

We’ve managed to reproduce this outside of RapidWeaver too, and we’ve sent all the information we have over to Apple. Fingers crossed they’ll fix it for Sierra!


(Jody Joy) #6

@simon would it help if I gave you the info that Mark is telling me about from the Console log? If so, please let me know. Indeed, I do hope if this is an Apple issue that Sierra fixes it. Most annoying because it happens frequently, then I have to duplicate the project and restart because RW will not set the local publishing folder path. It just stays blank. Only a restart fixes that.


(Jody Joy) #7

@simon while the saving issue could be an OS one, the real time-waster is the fact that once the project gets duplicated, there is NO WAY to get Publishing Settings to set the Local Folder. It simply stays blank. You cannot update the Publishing Settings if you have to duplicate the project. A restart is necessary, which is a major PTA.


(Jody Joy) #8

This bug is still happening under El Capitan. I’m running RW 7.0.4 and just tried to save a project. It could not be saved. Had to duplicate it, then restart my Mac in order for the publishing settings to the local folder to be recognized (not kept blank).