Continuing FTP hell (Solved w 8.1.7!)


(Kevin Atkins) #21

Yes, it’s an odd one. I’ve sent logs, and had followed some instructions to reset local permissions, but no joy. I’ve resent new logs, and keeping my fingers crossed.


(Jan Fuellemann) #22

Try removing the / from the beginning of your publishing path and see if that makes a difference


(Kevin Atkins) #23

No difference, sadly.


(Jon Snell) #24

I would check to see if there is enough free space on your site to upload your updates to your site. I had a similar experience to find I only had 654Mb of space free and my new site upload was 671Mb in size! There was no specifics given and found out by pure accident as I check my site size.


(Kevin Atkins) #25

Good call, but space is plentiful. It connects, but it won’t accept data, which made me thinks it could be permissions, but they’ve been reset on both server and Mac, and no joy. Such a shame, as crunch time is looming, so I may have to go for another solution.


(Kevin Atkins) #26

The problem has gotten worse; now I can’t publish any projects to my server in Rapidweaver. Other apps work fine. Just Rapidweaver.

Never mind my clients: I think I’d better look for another solution, as I’m losing hours over this!


(Jan Fuellemann) #27

Could you export locally and use an ftp app to upload?


(Kevin Atkins) #28

Yes, that’s what I’m doing as a stop-gap. But it adds another process and other admin/access requirements to what should be a single-point process. With RW selling itself as a one-stop solution, having to resort to a separate FTP client, and a separate file repository for RW exports, is hardly slick.

I would say that a modular FTP system may be useful, enabling a different client/engine to be use should one not work – but if RW is the issue, all or any FTP engine that’s chosen could be affected, so that’s not necessarily a solution.

I read another post that this exact issue happened to another user after the lates update (8.1.4), but this issue started for me on 8.1.3, so it may not be the same problem.

Interestingly, this is only occurring with a specific host (Krystal), but they’ve found nothing amiss.


(Doug Bennett) #29

I think without more specific information it’s going to be difficult to get help on the forum.
Perhaps some screenshots of the publishing settings, a link to the hosting companies help area and a screenshot of the error message your getting when you publish would be a starting point.

You’ve indicated that it’s a single host company, is it a single site? If so what’s different about that site? Does it use a different “plugin” that other sites don’t use?


(Kevin Atkins) #30

Yes, you’re right. There are so many variable, but only a few have changed, but to post all these here would be too lengthy. It may well be something on my iMac, so I may try from another Mac (although I’ve tried that previously, without success). I’ve contacted Realmac support again, with a few updates, and the hoster is almost permanently on call! As they can’t find anything at their end, and other apps work, it may have to be chalked-up to ‘one of those things’, sadly.

I can workaround for now (for myself); my clients won’t be so keen to do this, going forward.


(Jan Fuellemann) #31

You are not using any software which can influence traffic like LittleSnitch by any chance?


(David Freels) #32

For all those having 8.1 issues, what OS X are you using?


(Doug Bennett) #33

At this point everyone trying to help you are throwing out guesses.

  1. A screenshot of publishing settings
  2. A screenshot of the error message
  3. A link to the hosting company

Not that many things to ask for if you want help.

You also indicated above that you produced log files and sent them to Realmac Software Support @Aaron. Did you have a look at them? I know they may look difficult to interpret but perhaps you can post at least a parcel of what they have logged.


(Kevin Atkins) #34

I’m on 10.14.3. It was also an issue on 10.14.2.


(Kevin Atkins) #35

Nothing specific, but pretty much every web-enabled app will influence traffic in some way, and with a full CC suite too, I’d have no way of telling!


(Kevin Atkins) #36

Good advice: here’s what I have.

First, my publishing settings:

Second; error message:

Uploading: Screenshot 2019-02-15 at 13.50.25.png…

Third, hosting company is:

https://krystal.co.uk

I’ve read a few of the log files, and there is an error that (I believe) triggered RW Support’s idea that there was a local permission issue:

2019-02-15 13:46:00.367 RapidWeaver 8[2491:30101] Starting Project Save
2019-02-15 13:46:00.368 RapidWeaver 8[2491:349237] Saving project file to 'file:///var/folders/z1/w41t0kld17g_ps46ry6t3t1w0000gn/T/com.realmacsoftware.rapidweaver8/TemporaryItems/(A%20Document%20Being%20Saved%20By%20RapidWeaver%208)/%20Drive%20Guide%20Guru%202019.rw8' original contents url 'file:///Users/KevinAtkins/Documents/K@s%20Garage/%20Web/DriveGuide.Guru/%20Drive%20Guide%20Guru%202019.rw8/'
2019-02-15 13:46:00.522 RapidWeaver 8[2491:349237] Error saving sandwich, Error Domain=NSCocoaErrorDomain Code=256 "Item URL disallowed by security policy" UserInfo={NSDebugDescription=Item URL disallowed by security policy}
2019-02-15 13:46:01.552 RapidWeaver 8[2491:30101] Finished Project Save error:(null)
2019-02-15 13:46:01.552 RapidWeaver 8[2491:30101] Continuing Site Publish

I’m just discussing a potential SSL issue with my host, so I’ll see if something comes from that.


(Kevin Atkins) #37

Missing screenshot:


(Doug Bennett) #38

Is there any reason you using FTPS? That’s a much more difficult setup than using SFTP and really doesn’t provide any additional advantages.

From realmac’s kb article on ftp

FTPS Connection Settings
When publishing using FTPS, there are several different modes that web hosts can use to authenticate you. As apps cannot reliably detect the necessary FTPS settings when publishing, you may need to try the Use SSL for menu options before you can successfully publish.

I would try

  1. changing your publishing to SFTP
  2. On the ftp server add a colon :722 to the end of the server name(that adds the port number required by the hosting company
  3. Keep the connection the same
  4. Try a test connection first
  5. Clear the path and select browse choose the directory (this ensures the proper path with needed /'s)
  6. Then try a publishing

Server name should look something like

ares.krystal.co.uk:722

(Kevin Atkins) #39

No particular reason: I’ve tried them all in desperation.

The error I get with the above is as follows when testing:

… and this, when trying to browse directory:


(Doug Bennett) #40

Yes,
You need to get the credentials squared away first. Browse will or anything else won’t work if you can’t do a “test” connect first.

Make sure the login information (user name and password) are correct first. Also make sure the host didn’t suspend your login due to to many failed attempts.