Enable to publish

Hello,

suddenly there is a huge publishing problem. All the publishing settings have been checked trough my server. The publishing test shows


But the real publishing ends without logfile or explanation with

That is unreal, after I worked for days on the reviewing of the site with a lot ob publishings.

Have you tried lowering the connection speed? If you have the publishing setting ‘Lightning Fast!’, the server might not be able to keep up.

1 Like

Setting is 1 - slowest. Thank you anyway …

What is nasty about that message, that there is no explanation hint at all, why RapidWeaver isn’t able to publish.

Have a look at this knowledge base article; it includes how to get the publishing log.

You should also maybe try publishing to a local folder.

Thank you - I will give it a try.

Even the considerations of the mentioned “fool-proof guide” of great Dan Counsell were not successfull. All the settings proofed by the host, one hour of TeamViewer insight of a highly ranked programmer, who checked all the files, and Rapid Weaver 8.7.shows nothing more (the test publishing is always o.k.) than the harsh message: “UNABLE TO EXPORT” without any details, which could help. - I don’t know what to do to get my site in the shape which would be urgent to be.

You can export to a local folder and then use an ftp application to upload the files on your server.

1 Like

Hello, I cannot publish aswell.
I did publish two times earlier today. But now, and I tried several times already,
the proces stops with the message 0 of 0 files published.
I can only push ‘Cancel Publishing’
and when I do that the creen freezes
and all I can do is a Forced Stop!

the export to a local folder provokes the same message as publishing directly:
Bildschirmfoto 2020-11-10 um 12.42.31

Sorry that I post this here again, but I didn´t get any ideas in the other thread…

Hi from germany. Updated to Big Sur last night, since then I have problems with publishing an existing page (just made a simple change) --> RW crushes. Starting over again --> crushes.
Next I started a simple new project, entered all publishing details, tested the entered details and the publishing worked superfine!
So I got back to my main and important project, entered a second destination (“Add new destination”), deleted the first one - saved - and of course it crushes immediately when trying to publish.
What can I do? Thank you in advance and sorry for my english…cheers, elch26 (BIG SUR & RW 8.7)

I just tried to publish/export my project to a local folder --> RW crushes and shuts down. Asks for restart or sending an report to Apple.
What else can I do? Where do I find something like an “crush report” to send this to RW?
I am really lost :o(
Thanks for any suggestions in advance

@rasavol and @elch26,

Since both of you are unable to publish to a local folder, my best guess is that your project file has gotten corrupted.

It’s probably time to pull an older backup copy of the project file from TimeMachine(or whatever you use for backups).

Ilja, you kind of proved your problem is related to the single project file.

1 Like

Hello teefers,
I did what you advised, went to time machine and reinstalled the project. But it is the same result :o(
On the other hand: I tried to publish another project - and it worked. Have no idea, why this (most important project for me) cannot be published…

You can make a new project and then copy and paste the pages from the old project to the new one. Then add the publishing settings manually to the new project and try again.

2 Likes

I used the last backup version from TimeMachine to publish my Site. The result is the same: Unable to export. Although the support logs are marked in the settings, they cannot be retrieved. Therefore the following message appears.

I can’t upload either DevMate, a outdated program, which will be taken off the net soon. I also tried the suggestion to start a new project. I have copied the home page and tried to upload: Publishingtest succesfull as usual, only publishing is impossible here too. What a mess! The support team Dan and Aaron are quiet. I understand that they have more important things to do. For me it means losing a website that has been maintained for years.

The test button on publishing settings only test the very basic server credentials. Once you have “passed” the test it means you can login to the ftp sever with the user name and password provided.

If the only thing in this new project is that single page and it’s still not able to export, then there’s either something about that page or something about your Macs setup that’s causing the issue.

So let’s start a process of elimination.

  1. Start a new project
  2. Select one of the delivered themes for RW8 (maybe mountain)
  3. Put a single page on it (maybe styled text
  4. Try to publish to a local folder.

Post back what happens.

Above I gave you a link to a knowledge base article on fixing ftp problems. If you followed the entire article it explains how to get RealMac support involved and what information you’ll need to provide them.

From the message that you are getting, it looks like devmate is creating issues with getting the log files. Since it’s outdated why don’t you uninstall it?

I find most of those type utilities that hook into other software to create a lot more problems then they solve.

1 Like

thank you for your reply. I followed the advices in “How to fix ftp problems”. Without success. DevMate was never on my Macbook. I wonder why Mac provides the abouve message after trying to get the support Logs, which Aaron asked in trying to help.

What versions of RapidWeaver and are you using stacks and if so what version?

Did you try this? It should only take a couple minutes. What exactly happened when you did?

I did your 4 steps mentioned. The publishing to a local folder was successful.


I went back to my main project, controlled everything (website-name …) once again. No chance to become able to publish. The connection test successful as usual. Bildschirmfoto 2020-11-19 um 19.06.24
Then publishing starts for some seconds, than the messageBildschirmfoto 2020-11-19 um 19.06.41
Then I go for the support logs and I get this (I have never installed DevMate on my laptop, I don’t know what this program is and why its name appears in a RapidWeaver-Message):


I managed today to use a htaccess file, so my customers aren’t confronted with a halffinished chaotic site. They are linked to the Siteshop, which is a Ecwid-Add, which has no need for change at the moment. https://das-seminar.ch

What shall I do? It is now 2 weeks since I published the last time a modivication of the project. I am using RW for about 10 years.