Resolved / Sudden SFTP uploading troubles

Hello fellow RWeavers. I have been struggling recently with some SFTP uploading troubles happening suddenly, out of the blue, and my web hosting company (A2 Hosting) advises me that the problem lies with RapidWeaver. I have not been able to publish for weeks now, and am getting worried and desperate for some guidance. Can you help?

I am using RapidWeaver v.8.7 for overall publishing of my site (and the Transmit app for minor updates). I am operating on Mac OS10.15.7 (Catalina).

The problem these days comes whenever I routinely try to publish via SFTP, which I’ve been doing mostly trouble-free for the past few years. RapidWeaver now goes through the motions of preparing the files for export, and just at the final moment when the files look like they will be uploaded, the process stops and a series of error messages appear: “Couldn’t sign in to your SFTP server” or “Couldn’t upload to your SFTP server”.

The two most common error messages in the error info panes are: “Operation was aborted by an application callback. URL: s” and “Remote file not found. [same URL info].”

I consulted with my web-hosting company, A2 Hosting, and their (excellent) tech support staff inspected the logs and found everything functioning normally on their side; no firewall or other blocking detected on their end. What they did find in their logs was a sudden disconnect on my side during website publishing, just a few seconds after the publishing process started. A2 Hosting points the finger at RapidWeaver as the source of the trouble. And so, I come to you for help.

I’ve searched past postings here at the forum and have seen similar SFTP problems come up in recent months by other fellow RWeavers — but no lasting solutions shared, unfortunately.

Once again, this trouble arose just out of the blue, unexpectedly, and I am at a total loss as to how to resolve it. Can you help me out with your advice and suggestions? What does this problem look like to you, and what success (if any) have you had in dealing with this?

Many thanks in advance.

A quick follow-up to my posting above regarding the SFTP uploading issues…

• I tried switching over to public key authentication, thinking that may be a factor in this SFTP issue. Result — same as before, no change: The RW test button shows a successful connection. The files are prepared for exporting as usual and are moving quite quickly, and then at the very moment of uploading, maybe six or seven files (at most) make it through before the exporting process suddenly shuts down completely. Public key authentication didn’t seem to have made any difference with this SFTP problem.

• Please see the attached files for the two kinds of errors I am consistently receiving:

(1) Screen Shot 2020-11-29 (2) Screen Shot 2020-11-29

I’ve continued going back through this forum a few years and and am finding quite a few posts with exactly the same kind of website-exporting issue I am having now with RapidWeaver. As far as I can see, there have been no lasting solutions among us for this specific type of problem.

Fellow RWeavers, do have any suggestions at all to share regarding your own past experiences with this type of trouble in RW — and how you eventually overcame it? It would be very helpful not only to me, but others as well who may suddenly encounter this kind of crippling issue in the future. It’s bound to keep coming up again and again for us.

Some of us are having similar problems:

1 Like

A quick update on the desperate measures I’ve been taking to resolve the above SFTP uploading issue:

• “Verify file transfers” — Some fellow RWeavers have had luck by unchecking this button in the RW Preferences pane. I tried that, and my website export process shut down instantly, before even one file got uploaded.

• Health Check — I ran health check on RW, found a few possible issues, fixed them. Tried to upload, but still no go.

• Deleted stack — I deleted an audio stack that appeared to cause some kind of conflict on the page it was on. Tried uploading again, but still the same negative results.

• Backup project file — I have made a point of always backing up each one of my RW projects after they have successfully published. The last one was several weeks ago, and I reopened and tried uploading from that one. It didn’t solve the problem at all.

So…still no luck at all in getting my website uploaded, and it has been weeks now since I’ve last published. Any other ideas, fellow RWeavers, on what I could do from here? The web exporting process shuts down suddenly after about 5-7 files being uploaded. Any idea what this recurring pattern might mean as far as the number of files are concerned?

Some have reported in past forum posts of publishing to local folder, and then successfully uploading via a separate FTP client. I’ve never done that before with RW. How would you upload RW via an FTP client, say, like Forklift or Transmit? Please advise.

Since RealMac recommends - and uses - A2 for its hosting (Hosting reccomendations?) this is the time to bring in @dan to get some help direct from the source! :sunglasses:

1 Like

Pretty simple really, under publishing settings set up a new location and choose local folder.

Important select a new empty folder.

Once the publishing to the folder is completed then setup the same publishing credentials with the FTP app.

Once you have connected to the host with the FTP app simply copy all the files from the folder you created and published to above to the appropriate path on the server.

1 Like

I publish the Realmac site using the “FTP” protocol in RapidWeaver and it works great. Here’s our settings on A2.

Have you managed to connect using something like Transmit? I always double check my settings in other FTP apps if I’m having issues connecting.

Hope that helps.

1 Like

I have the same setup, and I’m having trouble left and right. I have a old file on my other Mac that I’m going to Tyron the old versions and see if I have the same issue.

@dan — Many thanks for checking in. Let me attach here my own shot of my publishing info on RapidWeaver. (The path is almost the same as yours.)

I too use Transmit (mostly for minor updates to my website) and find it to be an exceptional app. I am able to log into my web server via Transmit with no problem at all, so that connection is confirmed. I’ve never needed to use Transmit to upload my entire website in the past — usually RapidWeaver took care of that job.

I should mention that it was on the recommendation of Realmac that I decided to go with A2 Hosting as my web provider in the first place. I’ve never regretted the move; they are fantastic to work with and I will probably stay with A2 until the end.

But just to reiterate what the A2 support staff told me about this problem I’m having: Their logs show that seconds after the SFTP website uploading process starts, it suddenly cuts off and the connection is lost. They show no internal firewall or other blocking on their side taking place — that the source of the problem appears to be RapidWeaver, and they advised me to look deeper into that on my side. Which I am doing, though with no luck at all so far.

I will continue posting updates on this page, just to let folks what is working and what’s not working. I want other folks to benefit here from any solutions we might find to this persistent SFTP uploading trouble.

Just as a test, I would try using FTP as opposed to SFTP.

I would also login via SFTP with Transmit and upload some files. You can export RW to a local folder and then upload the files from that folder to your webserver. I recall someone ran into an issue with disk space quotas and when they were out of room, the test would work, but uploading would fail.

1 Like

@kishaman1 Have you tried adding a new connection in Transmit and uploading your exposed site? Let me know if that works. If yes, then try adding a new connection in RapidWeaver, and Re-Publishing all files.

I would recommend checking that the server has enough room for your new files (like @DLH suggests). Also, has anything changed locally with your Mac or Network? Could be a local firewall or an app blocking RW’s publishing…

1 Like

Another quick update on the trouble I’m still having with SFTP and uploading my website on RapidWeaver. Does anybody here have any advice or guidance to share on this? I’m still desperately trying to get this solved…

• Connection speeds — I have now tried uploading via SFTP at each of the six speeds (Slowest to Lightning Fast!) available on RW. The result: Same problem as above, with no success in publishing my website.

But a clear pattern emerged here that may or may not mean something. As you can see in the two attached screenshots, the files abruptly stop uploading when the seventh file (out of more than 2,000 files) comes up. This happened exactly the same way at each of the six connection speeds I tried.

What does this indicate to you? Does it mean that a corrupt file or resource somewhere in RW may be the cause of this? It hits that seventh file and suddenly shuts down the uploading, every time. I have no idea what to make of this. What do you see happening here?

• Same error messages — At each of the six uploading speeds, the two main error messages still come up: “Remote file not found” and “Operation was aborted by an application callback”. What do these two error messages tell you? What do you make of these errors, and what do think are causing them?

rw_speed1 rw_speed2

Not seen this type of issues before (with it stopping on the same file every time). Perhaps RapidWeaver doesn’t have permission to access that file.

Are you able to export your site locally? Does that work?

Also my questions from the last post are below again:

Have you tried adding a new connection in Transmit and uploading your exposed site? Let me know if that works. If yes, then try adding a new connection in RapidWeaver, and Re-Publishing all files.

I would recommend checking that the server has enough room for your new files (like @DLH suggests). Also, has anything changed locally with your Mac or Network? Could be a local firewall or an app blocking RW’s publishing…

1 Like

@dan — Many thanks for the advice. I will certainly give the suggestions by you and @DLH a try. But a quick question: I’m not really sure what you mean by setting up a “new connection” in both Transmit and RapidWeaver. Does that mean just opening a new set-up pane for FTP/SFTP, then inputting all the existing settings info and republishing from there? Thanks for clarifying; I’m still learning here.

I’m pretty sure that’s what Dan means.

Yes, exactly!

I was also chatting to @tpbradley and we were wondering if it was possibly an issue with a file name, perhaps it’s stopping on a certain file because it has an odd character in it RW doesn’t like, for example a “~”. Did you recently added any new files/resources to RW?

One other thing you could try is starting a new test project and seeing if that publishes okay, if it does then it must be an issue with a certain file in the project you’re having issues with.

Let me know how you get on.


1 Like

Thanks Dan for your response.
With Catalina, Mojave and Sierra I have had no problems with the same settings. Only after updating to Big Sur the upload problems started.

@teefers — A quick question: You mentioned copying all the files from the folder and into the FTP app (which, in my case, is Transmit). So, I copy them all together as a batch — rather than keeping them in the saved folder and just dropping the folder in the app??

This is a bit new to me, since I have only used Transmit to make minor updates to my site here and there, not to upload my entire website. Thanks for letting me know.

If you look inside the saved folder and select everything in the folder (including sub-folders) and copy that to the Directory on the server where you are to publish to. You don’t want the folder itself, just the content of the folder.

Let me update everybody here on the various actions I’ve taken so far to try to resolve this SFTP issue with RapidWeaver, as per suggestions offered above by @dan, @tpbradley, @DLH, @teefers and others:

• Disk space quota — I double-checked with the A2 Hosting tech support staff and they confirm that my disk space used so far is well within the limits. So, lack of space would not seem to be a factor here. A2 Hosting also reconfirmed that my SFTP settings are correctly set.

• Uploading by FTP — I also tried opening new connection panes on the RW publishing page, and tried publishing by both FTP and SFTP settings. The FTP route did not work at all, with the connection timing out before even connecting. A connection was made only by SFTP. This may or may not be due to the fact that I have already set a public authentication key on RW and with A2 Hosting.

(Just as a quick aside: The reason I went with SFTP over FTP sometime ago was because publishing by FTP on RW was quite unstable; sometimes it worked and sometimes it didn’t. SFTP, at least up until now, has proven to be a much more stable route of publishing on RW.)

• Local network changes — A question was asked about any recent changes to my Mac or network (firewall or apps) that might be a possible cause of RW publishing problems. Yes, I did recently start using a new VPN service (ProtonVPN), but even when VPN is turned off, RW still does not publish by SFTP. My other apps or network connections are not showing any signs of problems. But I will continue looking into this area for any other possible causes or conflicts with RW.

• Upload files to Transmit app — The connection to A2 Hosting via the Transmit app has been solid and I can still upload individual files this way with no problem.

• Publish to local folder — I’ve just tried publishing my RW project to a local folder on my Mac, and after one failed try, it seems to have worked. So, it appears that I can at least export from RW to a local folder. The next step would be to try to upload my whole website via the Transmit app, which I am saving as a last resort. I will let you know what happens with this. I’ve never needed to publish my entire website using Transmit before, but at this point, I have to try it.

I note that for some others on this forum who have had the same kinds of problems over the past few years with FTP on RapidWeaver, publishing to a local folder and then uploading via an FTP client is the only thing that seems to work for them.

• Other possible cause — This may have something to do with this FTP problem, or not, but I’ve found that one of my website pages is built with stacks (Photo and Velvet) from developer Nick Cates that have recently been taken over and remade by Joe Workman. So, I do have some outdated stacks that definitely need to be changed over, and I will remake that page with the new Joe Workman stacks and see what happens. This may or may not have something to do with the publishing problems I’m still having with RW.

Which, in summary, are these: At this point, I’m still not able to publish my website using the native SFTP client in RapidWeaver. The uploading process seems to go smoothly right up to the point of exporting, and when the seventh file is reached, the process shuts down and the SFTP connection is lost. A2 Hosting confirms with me that everything looks fine on their end, and they say it must be a problem with RapidWeaver.

I’m continuing to explore all possible solutions to this SFTP trouble on my side, and am still open to suggestions, advice and guidance from you, fellow Weavers. Please keep them coming!