FTP Publishing Problems


(Graham OHare ) #1

Currently running RW 7.5 on a OS 10.13 I have three websites all of them will not publish to the FTP server. I have contacted the Hosting service and they have confirmed that I am connecting to the FTP server with all of the correct settings but say the application RW7 is disconnecting after variable files have uploaded. followed by the app disconnecting halfway through I am therefore not able to upload the entirety of the sites, particularly on a republish of the site. Notice this seems to be a common issue reading a number of threads here. Even pinged a email to support here but no reply ( pretty shameful ) Any one has a solution as I now have three businesses waiting for sites to be updated.


(Dave Farrants) #2

Easy answer is to publish local then use an FTP program to upload, once the business sites are updated, uploaded and working then try to sort the problem.


(Doug Bennett) #3

Other than what @DaveFox said, if you have gone through the other threads and tried the suggestions than without more details it’s going to be difficult to get help. Things like hosting company name, screen shots of the publishing settings would help.


(Mathew Mitchell) #4

@graz1701 Ditto what @teeefers wrote. Especially important to see your publishing settings. Stuff like speed you’ve chosen and other publishing details within RW are important in these cases. Go to Settings > Publishing and capture that window. I’m attaching what mine shows (with some things blurred). This additional info will help us to help you.


(Graham OHare ) #5

Thanks for your help Matthew these are my settings and have tried various connection speeds from 1 to 6 all of them are failing. I have also run a connection test and its says that the credentials are valid


(Graham OHare ) #6

No Idea how you publish Local, as I have done over the last four years of using RW I just connect to my hosting service


(Graham OHare ) #7

Screen shot of the error, which happens with every attempted publishing


(Dave Farrants) #8

File > Export > Make a new folder on your hard drive > Select & Export. THEN Open folder > Select All > upload using an FTP program (FileZilla is free) to your host using the same settings as in RW.


(Barrie McDermid) #9

For some reason, my password has stopped saving in the FTP settings. Have you checked this?


(Graham OHare ) #10

Yes I had the same, it got lost on two of my sites, I dropped the password in again and did a test to ensure connection. I close the RW down and open the App again and it remembered the password and I did another test which confirmed the connection


(Graham OHare ) #11

Thanks I tried this, and it seem really over complicated to have to export to my local drive a copy of the folders every time I need to make an amendment, ( which I do a lot ) then do a Filezilla upload which I’m having problems implementing, it would be far easier if RW publishing would connect. I have to keep republishing the complete site ( over 1200 files ) every time and it times out, the only success Ive had is when minor amendments are made ( like a word ) and it will pass the change.


(Dave Farrants) #12

I only advocated this workaround to get your business sites published and updated - you asked for an immediate solution and this method would do that.

This forum has many posts the same as yours, the problem could have any number of reasons - an updated Stack, an updated OS, a corrupt prefs file, an OS keychain problem, a file error in OS or RW, a change or update at your host, the list goes on…

I have 12 sites (3 with over 1200 pages) and in the last 5 years using RW I’ve never had this problem (currently using RW 7.5.5, & OS 10.13.5) although I know many have, on occasions users have reported problems uploading only for it to disappear again and never finding out what the problem was.

I hope you find your problem and that you’ll post back here so others who do experience an uploading problem can try your solution.


(Graham OHare ) #13

Than you Dave. I appreciate all of your comments, and its really good to know others have had the same or similar issues and thanks for the workaround.


(Don H) #14

The website address looks incorrect to me. The website address should be the url that people will enter into their browser to get to your website.

My guess is that it should be “http://pennyblossoms.co.uk/” or “http://www.pennyblossoms.co.uk/

I’m not sure if this could cause upload problems, but you may want to fix the website address and see if it’s the issue.


(Doug Bennett) #15

You didn’t say what problem you’re having with FileZilla. Another good reason other than a temporary work around to try an FTP client is it came help narrow down what’s causing the publishing issue. If you can’t connect and get a directory listing with FileZilla and you’re using the same credentials, than that would lead me to think the problem is outside of RapidWeaver. Could be at the host, a firewall, a router or something else.

Not true, most FTP clients including FileZilla have a Synchronize folder function or something similar to keep a directory and sub directories on the server in sync with folders on your local machine. This will only upload what has changed. There’s lots of RapidWeaver users, for a various reasons, that don’t use the built in FTP part of RapidWeaver. They don’t need to publish all every time.

Who is your hosting company?
There’s a good chance that someone here may have experience with them. Plus it will give the folks trying to help a chance to look at online knowledge base.


(LJ) #16

Aside from the publishing issues, why such a convoluted web address? http://69.28.199.60/~gluef518/webassets/pennyblossoms/pennyblossomsnew/ is not normal protocol for a business address. Yet you have this URL indexed along with over 300 pages from the URL www.pennyblossoms.co.uk - none of which have any proper file / folder names.

To elaborate If you do a site: search for the long URL, 5 pages come up - all duplicates (albeit possibly updated) of pages found on the regular URL but in a different place. If you do a site: search for the standard URL, around 320 pages are shown including duplicate page names and some with 2 page numbers

Honestly and not meaning to rude, it is quite a mess and I would have to suspect that there may be duplicate page names or something like this going on which is playing havoc with the publishing engine.

In your shoes, I would spend a day tidying up your entire folder structure, give every URL a proper name (not just the default RW 'page 11, Page 12" etc).

Then ensure you are publishing ONLY to http://www.pennyblossoms.co.uk with the path being public_html - don’t publish other URLs to subfolders; they should each have their own account.

Despite some glitches, RW publishing is pretty rock solid. We have 80 RW sites and publishing has only ever been an issue once - temporarily after upgrade to RW6.


(glenn seller) #17

Just to pinch in … i Had this too with a site where i had to republish all pages (it always stopped around 550 files) with an connection error (2 weeks ago). After some experimenting i put all but the first page in draft and then i got under the 550 limit and then i could publish the rest…

Not sure if the problem has been solved (didn’t need it after that).

WaveX


(LJ) #18

There is no magical 550 limit however. Most of ours are fairly small but we have a number in the 700-900 bracket and they always publish fine


(Graham OHare ) #19

manofdogz
LJ
Thank you for your relatively rude reply,


(shen) #20

I’ve also been struggling with this issue over the last couple of weeks, with hours spent collecting 'failed to publish to your FTP server upload logs & contacting support. (This was after a long time of publishing with no problems with no settings changed). Just as I was about to tear my hair out, it mysteriously fixed itself (for now). So just to say, I know what you’re going through!
But also, a workaround someone suggested to me last time I had this problem, which was a huge help, was to just publish one page (you could obviously do this one at a time with several pages). You may well know about this; it was a revelation to me. Click on the page in RW, CTRL click, & ‘publish page’ is the last option. Good luck!