Couldn’t sign in to FTP server

I have been having issues with connecting to my FTP server since upgrading to RW8. I can FTP with other FTP-specific apps but RW has been giving me trouble. I contacted my ISP (Knownhost) and they said the ports that RW uses are not within the range that cPanel uses for FTP. Once the ports were relaxed, I was able to FTP. Every time cPanel updates on my server I have the same problem with RW but not the other FTP apps.
I searched the forum and see that this has been happening to other people as well.
While I am trying to get my ports opened up again on my server, may I suggest that RW gives us a field in FTP Publishing area to specify the Port to use if we want to overrule the default port being used? This should be easy to implement and would solve this recurring problem.

Not sure what port your Web hosting company is using?
I looked at KnownHost KBase and they state to set up Filezilla for FTP to use the default port 21. That’s what Rapidweaver uses for FTP.

It looks as though the also support SFTP. You really should switch to SFTP as FTP is insecure and sends the login credentials in the clear including password.

You can specify a port number with most web addresses by abending a : and the port number to the address.
So under publishing settings > Server add a :8080 to the server name or IP address would use port 8080.


Hi Doug,

I was using SFTP and the port that Knownhost was using is 2200. I had no idea I could append it to the server name in RW. I just tried it and it works now. Thanks!!!


Edit: Adding the :2200 allows me to connect with SFTP but it won’t upload the files. Very strange. I’ll post back once I figure out what’s going on.

Edit #2: SUCCESS! I can now connect with FTP and FTPS, not SFTP. For those of you that use cPanel, here is what happened as told to me by my ISP.

It appears that there was a .cache file that still retained the original port specifications and when the configuration was rebuilt last, it pulled from the cache. I moved all cache files aside, edited both the “local” file and the main pure-ftpd.conf files to match and I then confirmed that the value that I put in the “local” file is what gets used when building the pure-ftpd.conf.

They have changed the port in the main configuration file as well.

[root@host ~]# grep ^PassiveP /etc/pure-ftpd.conf
PassivePortRange 30000 30100
[root@host ~]#


Basically, the default ports were too tight so he opened them up to allow RW to connect. Upon updating, the original tighter port constraints were being used again. Hope this helps

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.