CSS in RapidWeaver 8


(Michael Flood) #1

Since upgrading to RW8, CSS is not working. I have tried it in the sitewide CSS area, page CSS area, and, since I use Foundation, have tried adding it to the Site Styles, to no avail. It all worked perfectly in RW7, what changed? Am I missing something in settings somewhere? … or? I am at wit’s end as I am unable to get my site built. Any help would be a lifesaver!

Thanks!


(Doug Bennett) #2

Works fine for me.

Would need to see the “CSS” you are trying to use. Chances are there is an error like a missing { or } or some other syntax error.


(Michael Flood) #3

as an example–as I am just trying to figure it out, I am testing code:

.title {
font-family:Raleway;
font-size: 80px;
color: #8B0000;
}

Also, have tried spaces,/no spaces, etc., as well as the !Important tag with no success.


(Doug Bennett) #4

Would need to see a URL to the site where the class title is being used. Raleway is a downloaded font, are you sure it’s downloading ok? Did you check the browser console?


(Michael Flood) #5

Sadly, site is not up at this time. I have also tried with many different class titles to ensure that was not issue. Also, I have tried it with many fonts (native to machine and net). I have tried it without a font callout to see if that was issue and it still did not work.

Results run the gambit from nothing working to only color working to text lines being spaced as though callout size but text showing as default size (12 px or so). Nearly, if not every time, the font-family does not work.

This is maddening. I need to get my site back up.


(Doug Bennett) #6

Yeah,
Lots of things can cause CSS not to work.
Since some of the rules you are applying work (color working, text lines spacing), I doubt its RW8 related, as well as may folks are using it without a problem.

Without a URL to at least a test page, it is difficult for anyone to debug the issue for you. Something as simple as !important being specified on a previous CSS instruction, or the CSS Specificity rules being applied differently than you anticipated will make CSS changes not work.

My suggestion would be to publish at least a test page with the problem, and post a URL here on the forum, someone should be able to help you out.


(Lisa Sandler) #7

Assuming you have the Google font code in your header in global code settings? Is this what you mean by “call out”?


(Isaiah Carew) #8

With code – any sort of code – the devil is in the details. Small things in seemingly unrelated places can make all the carefully crafted code you’ve typed get ignored.

I don’t think the problem is in the small snippet of code that you posted here – it’s probably elsewhere on the page that something has gone wrong and is preventing that code from working, or overriding it.

Like @teefers I think the best way forward is to post a test page somewhere out of the way. The problem will probably be pretty easy for some of the smart people here on the forum to find once they can see the whole page.

Isaiah


(system) #9

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.