Error message "Your page filename...must be index.php"

I am adding pages to a published blog on my website and keep getting the error message “Your page filename is 2009test.php but must be index.php. Please rename the page in the page inspector.”

Why would it be saying that every page has to have the index name? All my prior pages have specific names.

(I have also been getting a warning that says I have more than one index file on my site, which may cause problems.)

Using RW 8.9.1, Stacks 4, Poster 2, Corp theme - prior pages did not have stacks on them.

Hi Cynthia,

Follow the advice and change your pages for the blog to index.php. It is considered best practice to use index as the filename these days.

Look in to setting up redirects for your old page file names to the “new” stacks pages. So any SEO for your old site will be transferred to the new/updated site.

You are likely getting a multiple “index” file names because you have an index.html file and a index.php file in the same directory.

With using some stacks they need to be of the php file type, this allows them to do more compared to static html pages. RW does not delete the older files, it just adds new ones. So your old index.html file will be there as well as your new index.php file, you will need to delete the old one manually. If you don’t then most web browsers will load the older html version first, ignoring the new php version. So things will not look as expected when you publish your site.

3 Likes

Thanks, Paul. So every page should be named “index.php”? That doesn’t make a lot of sense (to me!) but if that’s what is needed, I will do it with the new pages. I assume that a folder can still be specified per usual, though?

My original pages are all .html (including the main page, which is indeed index.html) but I can change any that aren’t being completely replaced.

The reason I am rebuilding the site is that the videos embedded on each page no longer appear. But I had each one open on its own html page rather than having them download to the viewer’s computer, and now nothing appears.

Read more about this topic here:

Thanks, Jannis! The PDF article is very informative, but I do not see the cruftless option anywhere in RW8. Is it built-in now?

And the third link on that list is dead. :frowning:

It’s called clean URLs I think.

“Tide Website links” in advanced settings:

1 Like

Aha! Thank you!

Fixed and uploading now.