Exception while exporting site 2


(Ulises Escorihuela) #1

Just after having updated to the latest version of RW 6.3.5 I’ve lost the Clean Accordion stacks and once I’ve fixed it, I cannot export the new pages getting this error warning. What can I do? Help, please.

Error: Could not copy /var/folders/hz/mwklf88d705d50bhysq8h3pw0000gn/T/com.realmacsoftware.rapidweaver6/stacks-22D12B9B-9A57-42F4-8252-EC7517F7F95B-r0Na6c/fullpath_1556.jpg to /var/folders/hz/mwklf88d705d50bhysq8h3pw0000gn/T/com.realmacsoftware.rapidweaver6/RapidWeaver/1252/document-140680054798544/RWPublishing/index_files/fullpath_1556.jpg.


(Isaiah Carew) #2

It looks like there is some trouble in copying a jpg image from one temporary area to another.

Things that might cause something like this (with solutions in parens):

  • disk is full (remove stuff or get a bigger disk)
  • computer has bad permissions on the temporary folders (fix permissions)
  • image was corrupted
  • a utility like Clean My Mac has “cleaned”, a.k.a.:deleted, your temporary files (stop using “cleaning” utilities)

(Ulises Escorihuela) #3

Thanks Isaiah, it seems it was an issue with the permissions. Now it is working again!!!


(Isaiah Carew) #4

Nice! That must mean you’re not yet running Mac OS X 10.11 (because fixing permissions is gone now) – maybe time for an upgrade!? Anecdotal, I know, – but even for me – a person who seems to be a magnet for technology failures – Mac OS X 10.11 has been super stable for me – best OS update that I’ve seen in years.


(Roger Broechler) #5

Hello ulises and isaiah, I found your discussion here, and I will say, I found the same problem in my actual files. But I’m working with 10.11.1 an the »all systems are running well…« Disk is ok, I change the image and I never used a cleaner at my iMac. I noticed a other problem starting at the same time, I placed here in the forum > Rapidweaver creating an extra folder every time a file is being saved
I think, that this issues has something to do with permission - in el captain…!
In the moment there is no other way for me than closing RAW and saving/uploading and at the other hand to delete the additional temporary files after every saving from RAW:-(
I will watch it…
Roger > RW 6.3.5 / Stacks 3.0.2 / IMac 10.11.1


(Asbjørn Sjøvoll) #6

Hi,
Looks like I have run into the same problem after changing disk in my MacBook. What permission did you set to the /var catalog. Open it up totally with use of chmod 777 ?

Thanks in advance and best regards
Asbjørn


(Bob Cates) #7

I’m having a similar error.
“Exception while exporting site.
Error: Could not copy /Users/FragTagger512/Library/Containers/com.realmacsoftware.rapidweaver6/Data/Library/Application Support/RapidWeaver/Themes/Exposition.rwtheme/Contents/images/blank.gif to /var/folders/9p/w2wwqw2s3s91qxxg8jmt356c0000gn/T/com.realmacsoftware.rapidweaver6/RapidWeaver/23986/document-0x7fced839e450/RWDocumentPagePreview-20/images/blank.gif.”

Any ideas on what this might be. I have the latest Rapidweaver 6 , El Capitan. I did use a disk cleaner like clean my mac, but did not delete Rapidweaver cache.
Thanks


(Isaiah Carew) #8

@FragTagger:

This looks to be a file missing from a particular theme.

  • if this is a 3rd party theme, i’d contact the developer and let them know.

  • if this is a theme you’ve customized, then you should double check your work. i think a gif has gone missing.

  • if this is a built-in theme without modifications, let RealMac know in a support email about this message.


(Bob Cates) #9

Hi There,
I NOTICED it did NOT give me the error while using original “classic” Rapid Weaver 5 themes, or the 5 themes iNCLUDED in Rapidweaver 6.
However, I’m getting this error on many if not most of other developers more modern themes.

I’ve included various errors below from different themes.
Note: I went looking on those folders, and the gifs and png files DO seem to exist at both locations in the error (?)

Thanks.
Bob

EXCEPTION WHILE EXPORTING SITE
Error: Could not copy /Users/FragTagger512/Library/Containers/com.realmacsoftware.rapidweaver6/Data/Library/Application Support/RapidWeaver/Themes/Serenade.rwtheme/Contents/images/blank.gif to /var/folders/9p/w2wwqw2s3s91qxxg8jmt356c0000gn/T/com.realmacsoftware.rapidweaver6/RapidWeaver/39935/document-0x7fcadfec9740/RWDocumentPagePreview-4/images/blank.gif.


Error: Could not copy /Users/FragTagger512/Library/Containers/com.realmacsoftware.rapidweaver6/Data/Library/Application Support/RapidWeaver/Themes/Allegro Pro.rwtheme/Contents/images/accent.png to /var/folders/9p/w2wwqw2s3s91qxxg8jmt356c0000gn/T/com.realmacsoftware.rapidweaver6/RapidWeaver/42220/document-0x7fb6ff9608a0/RWDocumentPagePreview-2/images/accent.png.


Error: Could not copy /Users/FragTagger512/Library/Containers/com.realmacsoftware.rapidweaver6/Data/Library/Application Support/RapidWeaver/Themes/Serenade.rwtheme/Contents/images/blank.gif to /var/folders/9p/w2wwqw2s3s91qxxg8jmt356c0000gn/T/com.realmacsoftware.rapidweaver6/RapidWeaver/42220/document-0x7fb6ff9608a0/RWDocumentPagePreview-3/images/blank.gif.


(Bob Cates) #10

Oh, I should ad that I found this in the data base but the solution only works for 1 time, ex; 1 export.
Then on the 2nd try it gives the same error once again. I can’t keep closing and opening the project every time I want to preview.
Help!
Bob

Exception While Exporting Site

If you get the following error when trying to export your site, it usually means the theme has been updated while RW is running.

Exception While Exporting Site
Must provide a launch path

Closing the open project and reopening will fix the issue (No restart of RW required.).