Exporting problems


(Tim Proctor) #1

This is now happening to more and more sites. Started before the last upgrade and continued after upgrading. I can save the work, reopen the project, then export but that’s a poor non-solution.
See error message below…
Any advice please?

Thanks,

Tim

Could not copy /var/folders/7s/h8mxj_z92lz2szml4sgz9gy00000gn/T/com.realmacsoftware.rapidweaver/stacks-51009B55-2AD6-410C-A963-88DBC5871FB7-p9oUTT/stacks-image-90759da.png to /var/folders/7s/h8mxj_z92lz2szml4sgz9gy00000gn/T/com.realmacsoftware.rapidweaver/RapidWeaver/2369/document-0x6000005e1500/RWDocumentPagePreview/files/stacks-image-90759da.png.


(Rob Beattie) #2

I’m no great understander of error messages but it looks as though the Export is having problems with a particular PNG file. If you can find that file in your project, remove it and try exporting, that might work. Then you can always put it back in and try again. It could be that it’s become corrupted or is somehow not being referenced correctly.

Rob


(Isaiah Carew) #3

This error message indicates that Stacks is having trouble copying an image. This can happen for a variety of reasons:

  • disk is full
  • disk is having trouble copying
  • the RapidWeaver file is damaged
  • the image file is damaged
  • the file is unavailable for some reason (like it’s on a network disk that can’t be found – or some other app is locking the file – DropBox and iCloud do this sometimes)

What I’d recommend:

  • make sure your backups are in order. triple check. when file corruption is possible, backups become really really essential. having TimeMachine working means you can backup an hour, a day, or a week and get back to before things went wrong.
  • make sure your disk isn’t full.
  • if this file is kept on any sort of networked/shared folder (like DropBox or iCloud or anything similar) then i’d recommend removing it from that place and keeping it just on your local hard drive. preferably your startup hard-drive (if you have more than one).
  • look through your RapidWeaver project. make sure nothing looks out of the ordinary. pay special attention to images.

if you do find that you’ve suffered some type of file corruption, then i’d recommend trying to go back a few days – or as far as you need to – with a back to see if you can find a copy of the file prior to the corruption.

if you find that your file is corrupted and you do not have a backup then things get a bit more interesting. if you contact our support folks and send them the best copy of the file you have.
with some luck, if the corruptions are not severe sometimes i can save the rest of the file.

  • if you don’t find anything corrupted – then it’s time to pay a bit more attention to some of the other details of your system. is everything else working well? are your running the latest OS update? the latest RapidWeaver, the latest Stacks? any other older plugins installed that can be removed?

to be of more specific help, i’ll probably need to see the file and get some more specific details from you, so unless you find something obvious (like a full disk) then i’d recommend contacting http://yourhead.com/support

Isaiah


(Tim Proctor) #4

Thank you Isaiah,

I had pretty much looked into your suggestions earlier with no luck. As soon as I changed out one image file, the error message would jump to the next one.

I just tried placing and accessing the images from the resource option in RW and that seems to work. But only with stacks offering the warehouse option.

I usually pull images from the same file folder for the sites.

So far this seems limited to stacks that offer some type of motion feature, like Hero Banner by 1LD, Eternity by Blueprint and the new Parallaxer by Shaking the habitual. All stacks that I love.

I’m far from being a RW expert so I won’t rule out errors on my part but have created several nice sites over the years.

Tim


(Tim Proctor) #5

Hi Rob,

That was actually the first thing I did and it would jump to the next image file.

Just had some success with placing and calling the images from the resource file in RW but had never had issues before.

But that’s only working in stacks that offer a warehousing option.

Having had no problems with this for years of using RW, this has just popped up over the last month, so far limited to stacks that offer “motion”.

Tim


(Tim Proctor) #6

While looking more closely at this problem, I found at least a dozen backups of the troublesome site on my computer, I guess one for every time I tried to export it. Got rid of them, after a backup elsewhere, hoping that would do it, but no luck. It’s a very simple site, but does use 2 instances of Hero Banner and 1 of Eternity 2.


(system) #7

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.