"FindPlus" crashes RW

This is for whoever it concerns at RW…

If you try to use the FindPlus feature RW crashes. Tested on a lot of projects, same result.

No idea if this is a new issue as today is the first time I’ve ever used it. Or not :wink:

The regular find feature works.

I’ll have a look, thanks for the report. Until then I think disabling PlusKit (Find Plus is part of PlusKit) is probably for the best.

Isaiah

Aha! Didn’t realise it was a Pluskit thing.

I was actually planning on removing PK anyway. Great in its day, but for me of minimal use now and not on any of that sites I presently maintain.

And for those others that are reading this – here is a very good example of why you should keep plugins that you’re not actively using disabled.

PlusKit – EVEN WHEN IT’S NOT IN YOUR PROJECT – still loads FindPlus into the menu, so long as it’s enabled in the Addon preferences (Cmd-Comma – rightmost tab).

PlusKit is running (a tiny bit) all the time.

Now, FindPlus is pretty simple and I think this is only the 2nd bug I’ve had to fix since it was handed off to my by @loghound years ago – so it’s probably not the biggest deal. But other plugins might be doing worse things.

You just never can tell with plugin developers, they’re crafty and sneaky :smirk:

OK, not really :stuck_out_tongue_closed_eyes::upside_down_face: – I’m a terrible liar. We’re just really big nerds that like to write fun stuff for RapidWeaver :nerd_face:

But you should treat us like we are sneaky and enable plugins when you need them in your project and disable them at the first sign of trouble.

It’s 1:30am, I can’t sleep (as usual) and I’m working on a fix right now.

Isaiah

3 Likes