Footer links to privacy policy page not working


(Lydia) #1

Hi, Can someone please help me. I have been trying to make an active link in the footer to see a hidden Privacy Policy page. The link doesn’t seem to go anywhere now. When I was testing it kept initially defaulting to my home page. Does anyone have any ideas please? I’m using RW Version 8.1.7 with Lunar theme and foundry elements. I have tried the 2 codes below in the general settings for the footer.
Please help me figure this out.
Thank you in advance. My site is https://www/imlistening.ca
Lydia

© 2019 Lydia J. Charak – RP, MA (EXAT), BSc, BAA – <a href="https://www.imlistening.ca/Privacy Policy">Privacy Policy</a> This website is not a part of Facebook or Facebook Inc. Additionally, this site is NOT endorsed by Facebook in any way. FACEBOOK is a trademark of FACEBOOK Inc.

© 2019 Lydia J. Charak – RP, MA (EXAT), BSc, BAA. <a href=" https://www.imlistening.ca ">Privacy Policy</a>. This website is not a part of Facebook or Facebook Inc. Additionally, this site is NOT endorsed by Facebook in any way. FACEBOOK is a trademark of FACEBOOK Inc.


(Lydia) #2

Ive managed to get the link working but it keeps defaulting in the browser as http (insecure) when I have stipulated in the code to be https.
New wrinkle… Any suggestions please?
Thank you all
Lydia


(scott williams) #3

I can’t get to your page to have a look see


(Lydia) #4

Hi Scott, I have been onto the godaddy tech support and they suggested that I add in a redirect from the http site to the https by creating code. They sent instructions but I would like to know what RW users do in such a case. Does instacks redirect stack do the same job? if not do you have any suggestions? I’d love some help with this.
Thank you.
Lydia


(scott williams) #5

Once I get to your site (the link above is incorrect) the footer link works.

A couple points. You should not use spaces in folder or file names, use a - or _

Redirects to https are done in your .htaccess file on the server (same goes for redirecting to or from www or no www.)


(Lydia) #6

Thank you i will fix the spaces. Great suggestion. As for redirects, I will have to figure out what code to use and where to put the redirects on the server. Im not sure about that part of it or how to do it. Im new at that bit. If you could help me with that I would appreciate it.
Thank you.
Lydia


(scott williams) #7

There are several threads on the forum about moving to https, give search a try :wink:


(Doug Bennett) #8

This post will give you an htaccess rule to move from HTTP to HTTPS.

This is a video from Ben at RealMac on how to use the new (RW8) htaccess editor built in.


Redirecting old blog posts
Forcing the use of https
(Lydia) #9

This video is brilliant and you’ve been super helpful. I’m going to take a stab at it. I’m wondering if this will override the Godaddy settings which although are set up for https they are not redirecting. In other words I was told that I have to update the cpanel settings in Godaddy BUT 3rd party settings (RW) might disregard them so I have to go in and do the RW settings on the server as well. At least that I show I understand them. I find it challenging to say the least.
I will follow this video and step by step test.
Thank again
Lydia


(Guy Woodland) #10

Hi @LCharak

I use GoDaddy but set up the redirect using Rapidweaver which is much easier.


(Lydia) #11

Thank you for this, I have the redirect sorted - apparently I have to wait 24hr or so for the redirect to take effect.
Lydia


(scott williams) #12

Hmmm

.htaccess changes should be instant


(Lydia) #13

Thats what I thought but that’s not what GoDaddy says… Anyway I should clear my cache as I keep bouncing to the old site.
L