Force quit after every publish!

Every time I publish a page or pages and click the “Done” button I get the lovely spinning wheel and it doesn’t go away. I have to use force quit on the non-responding RW and then start RW again.
Pretty annoying feature I think!!

I’ve tried all different connections speeds from slowest to lightning fast and it doesn’t make any difference.

Here is the first bit of the report:

Date/Time:       2019-04-16 20:08:41 +1000
OS Version:      Mac OS X 10.13.6 (Build 17G6030)
Architecture:    x86_64
Report Version:  26

Data Source:     Stackshots

Command:         RapidWeaver 8
Path:            /Applications/RapidWeaver 8
Identifier:      com.realmacsoftware.rapidweaver8
Version:         8.1.7 (20674)
Parent:          launchd [1]
PID:             686

Event:           hang
Duration:        2.40s (process was unresponsive for 19 seconds before sampling)
Steps:           24 (100ms sampling interval)

Hardware model:  iMac12,2
Active cpus:     4

Time Awake Since Boot: 4600s

Fan speed:       1149 rpm

Tagging @tpbradley

Don’t know if this is related, but might checkout this post

Seems to be an issue with publishing password.

Thanks Doug but my issue is post upload.
Passwords are all set and upload goes through.
The issue is after the upload.
I didn’t have this problem with the last version of RW so I’m thinking it’s something new in RW8.

Hey @Lance,

Can you post the rest of the report captured when RW hangs, the first part doesn’t say too much about what the cause is.


Hi @tpbradley ,

Had to load to google drive as it’s pretty big…


Oh well… if anyone has any thoughts it would be appreciated.
As of 8 days after my post it’s still doing it.
Every time I publish a page and hit the “Done” button I get the spinning colour wheel and have to force quit.

Guess it must be a secret RW feature to stop memory overload!!
Or maybe my site is getting to complex for RW?

Have you heard of this before @dan

Hey @Lance,

Sorry for not getting back to you about this, we’re still investigating the cause. I have a few more questions for you.

  1. How large is this project?
  2. Does this happen with any other project you have?
  3. Where is the project file stored?
  4. Any chance you could send me the project?

If so, would you be able to send your project file to with a subject of “FAO: Tom #3068

Project files can be quite large so using DropBox or WeTransfer might be necessary.


Also, could you try the following

Open up RapidWeaver’s preferences and select the General tab. Make sure the “Show Notifications” checkbox in the Alerts section is ticked. Then publish again.

Do you still experience a hang?

Tom there’s a link a couple posts up.

@teefers That’s just a link to the crash report

Hi Tom,

Did that change to preferences and the site published ok!
I’ll do some more work later today and keep trying… maybe, hopefully that has fixed it??

Thanks for your support.

Hi Tom,

I have emailed Dropbox share with the project file.

Thanks again,


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.