Foundation Forms - Contactform not working properly (does not send)

Hi everyone!

Anyone having troubles with Foundation Forms lately?
Due to circumstances I couldn’t work on my website since last summer 2018. Now I recently wanted to pick up my work on my website. First I updated my RW to version 8.0.3 and my website still worked fine. But forgot to check my contactform…

Last monday I started working on my website again and first was requested to update Foundation Theme to 1.8.1 to have my website work. I did so and republished all files, and after that first checked my live website.

My contactform doesn’t work anymore, as in: it looks are okay, I can fill in the fields normally, but the send-button “verstuur uw vraag” does not do anything. Nothing is being sent… while it worked before and I did not make any changes yet. How come?

I checked all the formbase settings, they look fine I believe…
I checked the tutorialvideo from Joe Workman how he made a contactform and with which settings…
I checked my PHP version on my server and set the latest stable version which my webhoster supports to PHP 7.3

Well, all without succes… :frowning_with_open_mouth:

I can’t think what I am doing wrong. Do I overlook something (simple)?

You can try my form at: oscarcreations | vragen staat vrij | contactformulier
Use button “contactformulier”

By the way, I also tried if the form works directly on page instead of in the Reveal lightbox… no difference.

Hope anyone has an idea, thanks for any help!

I see an error about recaptcha, I would start there

I have put the reCaptcha in quarentine, that should be enough don’t you think? Still makes no difference…

not sure what “quarantine” is but if its one of those stacks that doesn’t publish content, they usually don’t work with javascript. The JS part still gets published and breaks because it’s missing the html part.

I would just remove it all together until you get things figured out (you can always just copie it to a dummy page to preserve it)


I will try that in a minute and let you know :slight_smile:

Well, I removed recaptcha completely from website, removed old website from server to be sure no garbage is left, and republished my website again (all files)… but unfortunately no success.

Could it be the Reveal Box?

I will remove the reveal lightbox and try the form again

Well, problem solved!

Reveal box had nothing to do with it, nor the Foundation Theme update or the PHP version… Form Base settings were correct too.

Although I put the recaptcha stack in quarentine, a piece of recaptcha code still remained in the page source code (html head) for some reason :frowning_face:
As Scott also mentioned. No idea how it got there, but okay…

Removed that piece of code and voila, everything fine :slight_smile:

Thanks for all help!

Case closed.

1 Like
1 Like

Thanks for the info Joe!!

Although the problem caused by the left recaptcha script is solved now, it is again a lesson to clean up pages as much as possible, also when they are in a locker or quarentine. I wasn’t aware enough of that. And although I had little in quarentine, I’ve learned that even one little thing can cause a big problem. Which cost me hours of extra work as a bonus :frowning_face:

Apart from this: does the locker stack have extra benefits (f.i. less code) or can I stick to the quarentine stack from Doobox?

Thanks again!

You can actually no longer get Locker from my site. It caused more grief that benefit in my opinion because of the issues described in that FAQ. I don’t know the code behind Quarantine. However, I am pretty sure that it was exactly what my free Locker stack did.

I have released a free stack called Pen that does exactly what the best parts of Locker were.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.