Foundation/Parallax and support issues

@joeworkman man, I’m not sure what Tav is smoking but a reinstall of Chrome or OS X has nothing to do with it…

I’m thinking it might be to do with Foundation being out of date (he’s running 1.6.4, and he’s using consolidation and hot linking to some CDN’s). I’ve told him to update, stop using the CDN’s and switch off consolidation.

What’s your take?

Turns out it was CloudFlare.

CloudFlare inserts this after the head…

Disabling CloudFlare fixes the Chrome issue.

Firstly, regarding the parallax issue, clearly the below description was not responsible. I did say originally that it looked like a similar problem which I accept was hasty conjecture for which I apologise.

Notwithstanding this, it wasn’t a glib suggestion off the top of my head but was a result of the strange events described here. I would love to have a reasoned explanation for this, which has so far remained elusive.


The site was not and had not been using cloudflare. (at least my test server described below)

The fixed backgrounds that displayed the problem in Chrome were CSS only background-attachment:fixed and used no JS.

The problem was the same regardless of the stack used - 3 developers stacks were tried.

People experienced this problem with various themes, not just Foundation.

The reported problem:

Anything published from machine a produced a page where the fixed background image failed to display properly when not in the initial viewport.


It became apparent as more people reported, that the only commonality was that they had a lot of Chrome extensions installed.

I therefore installed the same extensions as one of the reporters on one machine (a) and not on another (b).

Immediately, anything published from machine a produced a page where the fixed background image failed to display properly in Chrome when not in the initial viewport. On occasions but no exclusively, it would also fail to fix and behave as a static background.

The same project published to the same server from machine (b) worked perfectly every time.

This is the point where Joe & I repeated the experiment with the same project file on my machine (a) and his machine - same result as above, his worked, mine didn’t.

Given the that the problem had occurred when I installed the extensions, I therefore removed them. - Same result, still broken output.

I therefore completely removed Chrome and re-installed (the exact same version number) from a fresh download after which all publishing worked correctly again from machine (a).

Not believing what I had seen I repeated the experiment on a third machine with the same results and also got the guy who had listed his extensions to me to do the same.

Re-installing Chrome immediately fixed his problems as it had done for me. He was obviously reluctant to repeat the process as he had a site to publish.

Reports kept coming in about the problem and so I shared what I had done.

Almost everyone who tried the same found that it fixed their problems. A couple of people found that this didn’t work and re-installed OSX which then fixed it.


As a scientist I know that this fits absolutely no reasonable explanation but empirically it happened time and time again. I wish I was smoking something as this lot may make more sense. None the less, there were over 30 happy users whose published sites were working again a result.

No offence meant, It was just this part got me:

The webkit installation on your machine seems to get broken by certain plugins added to Chrome. The result is that anything you publish from that machine will do as you describe with fixed backgrounds.

I must stress that this problem occurs due to the installation on the machine from which the page is published but is manifested for all viewers… The same project file will work when published from another, unaffected machine.

The above is false. I wouldn’t recommend giving this out as support advice. There’s definitely something else going on at play here…


None taken,it would take a lot more than that :slight_smile:

I agree webkit is irrelevant but the second paragraph is exactly as we saw the problem. I was just trying to highlight as described above that the problem was at source. This came as a result of many people worrying that their pages would not work when viewed by others with the “problem”, which was not the case. It was merely down to the originating machine - whatever the problem may have been.

@nikf Better here than in the public forum but see the chronology of what we saw on multiple occasions above. I fully appreciate that it makes no sense but it was reproducible time after time.

I am quite happy for either you or me to delete the public posts as I certainly don’t want to mislead any one. The “mischievous plugins” line was used by @ben but seemed to describe fully the above course of events.

Just to be clear, I understand how the local chrome installation should have zero impact on the generated output from a project file as it is unrelated - but something was affecting it. The problem occurred immediately when the plugins were installed and disappeared when chrome was wiped. Obviously something odd was going on that is beyond simple explanation but it was reproducible on different machines used to export and different servers.

I will certainly not issue this recommendation again I apologise for causing problems, that was obviously never my intention.

There’s no question or doubt here. It’s not that this should have zero impact, it’s that it absolutely does not have any impact.



Tav acknowledged that his solution was unorthodox and should not have worked. I agree 100% that it makes zero sense. However, the evidence that this has fixed many users issues is irrefutable. This “bug” plagued a handful of users with a few different stacks. We spent weeks troubleshooting this. Not all of the users were using Cloudflare. And the ones that were using Cloudflare were not having the issue any longer when Chrome was re-installed. How do you explain that?

Its possible that reinstalling chrome fixed something that was the real problem. I don’t know. This particular user’s issue could have been Cloudflare. But his symptoms looked similar to the Chrome issue that plagued us last year.

We are all adults and pretty smart people. No one likes being treated like a noob… Now let’s have a group hug!