🌟 Foundation v6.10 has arrived

This release is all about Animations. Foundation 6 has has an Animation In stack for a while and it’s… worked. We deserve better though! I have been working a lot on animations in some new stacks and it has inspired me to revamp the animations that we get out of the box with Foundation 6.

3 New Animate Stacks + New Animate Timing Swatch

There are 3 new Animate stacks that allow you to configure preset animations on click, hover, on page load and when scrolled into the viewport. The Animate Timing swatch allows you to centralize the animation timing so that you can keep times in sync across multiple animation stacks. However, you can also provide local overrides if needed.

3 New Animate ⊕ Swatches (Swatch Pack)

There are 3 new animate swatches inside of the Swatch Pack. These swatches allow you to create predefined animations that you can apply to as many elements as you want through a simple class. these swatches are similar to the Animate stack but have more flexibility and additional controls.

New Toggler on Scroll ⊕ Swatch (Swatch Pack)

Another new addition to the Swatch Pack is a new Toggler on Scroll swatch. This swatch is based on the existing Toggler swatch but now also allows you to add a class to any elements when it scrolls into / out of the viewport. While I was at it, I also spruced up the original Toggler swatch with some new features. Both of the Toggler swatches are very powerful swatches.

New Transitions Swatch Tutorial

While I was recording videos on the new features I decided to record a few more. This one in particular has nothing to do with this release however, it’s a good tutorial on how to use the Transition swatch in order to create styles on hover. The same exact concept can be used in conjunction with the Toggler stacks to create great animations only limited by your imagination.

Sneak Peak at things to come

As I said earlier, I have been busy working on a lot a animation stacks lately. I should start releasing these soon. My goal is to get them out before the Weaver’s Space Summit next month. Keep your eyes peeled!


Wow! Yet more reasons to use Foundation 6.

1 Like

Hi hope this is the spot to add my question…

F6 working well, no issues. Love it.

Was using the original animate stack on my pages.

Got an update for the new animates. (love the distinctive edit mode highlighting!) So, I changed all my animations to just basic slide in.

Then, got update for F6.1 Yep, I did that also. All was well & updated my site.

Today, went to make some edits & getting the " Foundation Version Warning" and an update for backwards 6.1 that I didn’t do because I have used the new animate stacks.

Did a reboot, reopen, no change in warning.

Saw a hint on this forum to delete the F6 theme & tried that. No luck. Now F6 theme does not show in the THEMES Lightbox.

So, I reinstalled the theme update that I bought in Jan 2021. Still no luck. The F6 theme does not show to assign it. image

Tried starting a new project after reboot, F6 theme does not show up. The Add-ons window does not show F6, just the other F6 themes.

I tried restoring the project from time-machine. Still no F6 theme.

I’m at a loss what to do.

So appreciate any help & thanks in advance.


You can download the latest version of the F6 theme here

If you want/need the right to left here

The stacks version and the theme version number must match in F6.

Make sure you have installed the theme (right-click and select open with RapidWeaver 8, don’t just double-click to install) and relaunch RapidWeaver.

1 Like

Nope - I get this error message. My permissions are Read & Write

After changing the permissions, I have F6 (L-R) working, but the Foundation Version Warning" again, even after a reboot. And a update note for the version that isn’t supposed to be used with yesterday’s animate stacks.

So, I’m back to the place I was when I opened RW this am. Sigh…
But thanks for offering ideas.

“not having permission”

That’s a really strange message.

Are you running off your local Drive?

here is your addons folder? (Rapidweaver8 menu> Reveal Addons Folder)2021-09-24_14-16-46

You need to have permission to parent folder(s) as well.

The stacks version and the theme version number must match.

Go to the site styles (any f6 stack should do and check the version number in the library:

Then go to Addons and check the version number of the Foundation 6 Theme(s):

Those numbers have to match (6.10.2 as of today). If they don’t match then something isn’t updating.

You should have never gotten a “permission” error when doing updates.

1 Like

Thanks! I’d been checking those versions. Somehow the 10.2 F6 update wasn’t installing. It was still in the “to install” folder after many tries. Finally used folder utility to delete the old F themes, moved 10.2 to the “Themes” folder, reboot, etc, got update notice & finally all was in sync.

Phew! But I’m now back to normal. Again, many thanks!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.