Gästebuch mit Foundation - Gelöst


(Andreas Kolisko) #1

Ich versuche eine art Gästebuch mit Foundation zu erstellen.
Unter http://test.profiband.de/guestbook/ habe ich das ganze versucht mit Frame zu bewerkstelligen. Leider hat das Offset stack wohl einen Bug, in Safari scrollt es nicht und schneidet unten ab.

Dann habe ich versucht das ganze mit Tabs zu machen, leider sind die Tabs (links dann aber nur oben) wenn man unten auf der Seite angekommen ist muss man, um zur nächsten Seite zu kommen, wieder hochscrollen.

Hat vielleicht einer eine Idee wie man das umsetzen könnte? Ich hätte gern oben und unten ein Navigation um im Gästebuch die einzelnen Seiten anzuspringen.

btw. Schön das es ein deutsches Forum gibt, es ist doch etwas einfach alles zu Formulieren.

LG
Andreas


(Oscar Schmid) #2

Hallo Andreas

Dein iFrame lässt sich wirklich nicht scrollen.
Nachdem ich aber den Code anzeigen liess, und “width” deaktiviert hatte, klappt alles.

Wieso hast du dort max-width und width drin mit 100%? Vielleicht beisst sich das.

#stacks_in_16309_page1 iframe.responsive { display: block; max-width: 100%; width: 100%; }


(Andreas Kolisko) #3

Ich hab keine Ahnung warum das 2 mal drin ist. Darf ich dir vielleicht das RW Projekt schicken und Du schaust mal rein? In Chrome und Firefox gibts kein Problem …


(Oscar Schmid) #4

Kannst du gerne machen. Schick es mir kompriniert als Message.


(Andreas Kolisko) #5

Ich suche gerade eine Möglichkeit dir etwas zu senden, eine PN oder so finde aber nichts …


(Michael M.) #6

Bist du sicher, dass das nicht scrollt? Ich habe hier Safari und alles ist gut (mal abgesehen von dem vagabundierenden PHP-Code). Aber vielleicht hast du zwischenzeitlich ja auch schon eine Lösung implementiert…

-Michael


(Andreas Kolisko) #7

Wenn das richtig scrollt dann hast du ganz unten auch wieder die 3 Links 1 - 2 - 3.
Der Php Code unten ist klar warum der da ist, ist beim Endresultat nachher weg :slight_smile:

Weiss den einer wie man hier im Forum eine PN schicken kann?


(Oscar Schmid) #8

In meinem Profil sollte dieser Button zu finden sein.
Bei mir sehe ich aber keinen. Ich weiss nicht, ob man selber keinen hat, wäre auch logisch.

Schau doch bitte mal, ob du bei mir diesen Button findest.
Icon anklicken, Message Button klicken, schon geht’s los.

@apfelpuree
Bei mir lässt sich nichts scrollen.


(Oscar Schmid) #9

Hab grad noch gesehen, dass es scrollbar wird, wenn ich Seite 1, 2 oder 3 anklicke.
Sind also Startschwierigkeiten von Safari.


(Andreas Kolisko) #10

Ich hab kein message button in deinem Profil. (Dein Profil erreich ich wenn ich auf dein Logo klicke richtig?)


(Michael M.) #11

Ja, auch diese Links am unteren Ende sind doch alle da. Scrollt einwandfrei in Safari.

Vielleicht mal den Cache löschen


(Oscar Schmid) #12

Seltsam, sollte aber da sein.
Ich sprech dich an per Message.


(Andreas Kolisko) #13

Welche Safari Version nutzt Du denn? Ich nutze 9.03 am Mac.


(Michael M.) #14

Muss ich nachher oder morgen exakt schauen, hab gerade keinen Zugriff auf den Desktop. Sollte aber die aktuellste Version sein.

Hier auf dem iPhone auch kein Problem. Scrollt einwandfrei (nur halt elend lang)


(Oscar Schmid) #15

So. Da hab ich gesehen, dass der Offsite Foundation Stack nicht funktioniert (nur in Safari nicht), weder direkt in der Seite, noch als PlusKit @Import(()) auf einer Stacks-Seite.

Nimmst du das Offsite Plugin funktioniert alles und bindest du es mit PlusKit @import(() )in der Seite ein (auch in der Stacksseite), klappt alles, auch in Safari.


(Andreas Kolisko) #16

Danke Oscar, ich werde das mal probieren.
Hat vielleicht einer eine andere Idee wie man das in Foundation umsetzen kann ohne frames …


(Oscar Schmid) #17

… eben mit dem offsite plugin, dann mit pluskit importiert, wohin du willst, kein iframe.


(Andreas Kolisko) #18

Ich dachte an was komplett anderes so wie tags von Joe … aber das geht nicht weil dann die untere Navigation fehlt…


(Michael M.) #19

Ich hab nochmal auf deine Seite geschaut: MacBook mit Trackpad: Scrollen im Frame möglich. Desktop mit Maus nicht. iPhone/iPad: Einwandfrei. Safari-Version ist übrigens auf beiden Rechnern 9.0.3

Dann habe ich ein rudimentäres Projekt mit dem (originalen) Offsite-Stack erstellt: Funktioniert einwandfrei - ohne PlusKit etc:
Test Offsite Stack


(Andreas Kolisko) #20

Ich bin ab Montag wieder da, dann schau ich noch mal.