Blog posts are set with incorrect URL


(David) #1

I’m using TotalCMS, and I’m new to creating blogs. I’ve worked through Joe’s Blog videos but I’m still doing somethings wrong.

The URL that I see when I tap a saved blog post is:

https://bohtech.com/beatriceCMS/(null)/(null)?permalink=test-post-1-1543593673

What have I messed up creating the (null)/(null) fields?

Help please.


(scott williams) #2

HI David,
Some how you have no post link set. (in your admin blog list hover over the news paper icon and click the little chain-link icon to see all of the links)

Maybe you were messing with the pretty url settings?

I would first try going to the public blog post page in RW and checking the default option for post URL.
You will most likley get a pop up window where you can submit the new setting.

Get it working that way first, then if you want pretty url’s go down that road afterwards.
right now it is blank:


(David) #3

Hi Scott, I am a bit lost… On my public blog page, I select the post > show more. and it works. In the Admin page, I can see the the Post Link is blank. I’m not sure how to fix it…

Thanks for all the help, I’ll only have another 1000 questions…

David


(scott williams) #4

Try This:
Open your RW project
Go to the page that holds the public Blog Post (not the list)
Preview the page
Do you get a popup box with a to submit button? (screenshot - I blanked out data in image)

IF YES, hit the submit button
IF NO, try changing the Post URL setting to get the popup (screenshot)

Previewing the blog post page in RW is how the paths get set.

If that doesn’t work, reply back


(David) #5

Great! Working… So I won’t answer back… David