Help needed; Formloom3 failure


(Tapio Laakkonen) #1

I keep getting this contact page error
Have tried with SSL Mode and without.

I am using RWML stack to ‘translate’ contact form menu text.

Could some one please check code… ?
http://qmea.fi/sites/tapsa/WaldeGroup_Live/Yhteystiedot/?lang=FI


(Oliver) #2

Hey @TapioMichael,
the rwml contact form stack ONLY works with the RW’s built-in contact form, NOT with formloom.

Using formloom inside stacks:
formloom 3 comes with a stack to use a form loom-form inside a stacks page

I really should use this instead of pluskit.
Don’t forget to set the no-theme option in formloom!

Happy weaving,
~N


(Tapio Laakkonen) #3

Hi @Noridge, thanks for your help!
It seems these settings was as you suggested, right?

Can it be that problem could be that RWML stack requires to use original RW contact form and thus gives me that @import((rwml-contact-form)) ? Here’s what RWML contat form stack says:

Thanks again for the help


(Oliver) #4

Well, the problem is, that formloom cannot be localised with the rwml contact form stack, I’m not sure wether it can be localised at all.

The rwml contact form stack can only be used with rapidweaver’s default contact form.


(Tapio Laakkonen) #5

If I understand you correctly I should use only Formloom3 stacks and not to mix them with stack that comes with RW, right?

I am using only Formloom3 stack (contact form) + YourHead Software’s Stack with Formloom3 Remote stack. (page where contact form should show up and one that is visible at menu)

Still I get that @import((rwml-contact-form)) error :confounded:


(Lisa Sandler) #6

Take a look at how I set up my forms… You shouldn’t need to @import anything. Download this file: https://www.dropbox.com/sh/0cnfu4q9xy9zz0q/AADYL_cH3rWDQBleBFXFavtOa?dl=0

I’ll delete it at some point, so get it now. I’m using Foundation, but you should be able to use my pages regardless of what theme you are using. Check the settings.


(Tapio Laakkonen) #7

Thank you!
At first glance I didn’t find anything different except your page named Contact is index.html and page named ContactForm is php.index - while mine are both php.index. Matter of fact I can’t change it to html.index even I would want to (at least not by remaning folder by it).


(Lisa Sandler) #8

So there is a stacks page that is index. The contact page is php. But you might have something else on the stacks page that makes it php?


(Tapio Laakkonen) #9

Hi there,
Yes that is correct, I am making site bilingual so I am using RWML stacks and that makes it .php. I decided to go for PlusKit to see if I can get rid of that @import message. Any pro-tips how to use that?

Many thanks for your help!


(Lisa Sandler) #10

I don’t think there is anything wrong with having that page as php.

I got rid of Plus kit. Plus Kit is the way if you use @import.

If not, do it the way I have it set up in my file. I gave you the screenshot in the previous post. Literally, copy that Formloom remote stack and make sure your settings are the same as mine, only with your correct info.


(Tapio Laakkonen) #11

I did as you suggested with remote stack and got page working but still got that @import message. :expressionless:


(Lisa Sandler) #12

What does the edit stack page look like…can you screenshot it?


(Tapio Laakkonen) #13

If you mean page that Formloom3 contact page is importerd… unfortenately I can’t for I do not hold rights to share it. :worried:

Anyway, at the bottom of page I got either Formloom3 remote stack or text stack for Pluskit import and both seem to give same @import message on top of text. See it below from RW preview mode.

Other than that I need to fix two other things: 1) Get rid of extra ‘Home’ translation 2) Get ‘topic’ selection menu / pop up me traslation working


(Lisa Sandler) #14

No, I wanted to see your edit page with the formloom remote stack + settings and name of the contact page. I don’t need to see what’s on the rest of the page.

Did you look at the settings in my file?

The formloom page needs to look like this (the same exact name as your contact page, including caps:


(Oliver) #15

@LSPhoto regarding PlusKit, it actually is needed by RWML to localise the contact form. This works only with RW’s built in form by importing it into a stacks page, where a special contact-form-localization stack takes it over.

But, @TapioMichael , as I said before, RWML and Formloom won’t work together. RWML is not compatible with Formloom.
In fact, there are only 3 ways to localise a contact form:

  1. By using RapidWeaver’s default contact form plugin. This is compatible with RWML and can be localised.
  2. Using a stacks-based contact form (like in foundation, formsnap, etc.) Those can delocalised by filing the input fields within the stacks setting with strings like these:
<span lang="DE">Senden</span>```
This would be a 'Send' button for both, english and german. RWML would toggle the translation as needed. You may copy this snippet and replace the language strings to your ones.

1. If there is no way around  Formloom, then add Formloom **twice** (or more, depending on whatever you want) to your project. Use those forms to create your localised ones. In your stacks page: add two formloom remote stacks to your page and link them to your forms. Put those stacks in RWML Content Stacks and link them to a language. I'm not that sure whether this setup will work, but its actually the only way to use formloom with rwml (and its not the nice one).

~N

(Tapio Laakkonen) #16

Thank you @LSPhoto, @Noridge, and others for your kind help!

At the end, even I had remote stack correctly, I had to give it up using Formloom3 for it wasn’t totally compatible at the end with RWML. I opted for Doobox Html Contact Form and I got easily rid of import((rwml.-contact-form)))-text, though I have to admit that I had to compromise by leaving two languages on the form page. Later I can try Noridge’s advice and try to apply contact form twice.

The site is now visible at waldegroup.fi or I you wish you may take a look English version of contact form page directly here.

Many thanks!


(Lisa Sandler) #18

That works :slight_smile: blahbity blah