Hilfe bei nervigen Weiterleitungen auf Werbeseiten


(Kunstmaler) #1

Hallo,
seit einiger Zeit bemerke ich auf mobilen Geräten unfreiwillige Weiterleitungen von meiner Website auf Werbeseiten. Nun habe ich das Problem auch auf einer anderen mit RW erstellten Website erlebt. Ich habe nun versucht, mich im Netz Schlau zu machen: Das Problem scheint allgemein bekannt zu sein. Soweit ich verstanden habe, soll das Problem von Werbeanzeigen/ Werbebannern ausgehen!? Aber auf meinen betroffenen Seiten ist keine Werbung geschaltet. Ich arbeite grundsätzlich nicht mit Anzeigen und dergleichen.

Ich finde auf den RW Seiten auch keinen Code, der sich dort eingeschlichen habe könnte. Bin da etwas ratlos … habt Ihr ähnliche Erfahrungen und ist das “Problem” in den Griff zu bekommen?
Hat es etwas mit den RW Seiten zu tun, kann ich da Einfluss nehmen, neben den Einstellungen an den Browsern?

Würde mich über Infos und Erfahrungsberichte freuen.


(Michael M.) #2

Geh mal in die Safari-Einstellungen und lösche sämtliche Website-Daten.

Das hat auch nichts mit deiner Webseite zu tun, das ist (im Regelfall) ein Browserproblem


(Kunstmaler) #3

Ja Danke Michael.

Die Weiterleitungen finden nur auf mobilen Geräten statt. Zuletzt zB auf einem Fire von Amazon.
Oder auch im Browser Blisk. (https://blisk.io/) Da kann ich alles löschen, was möglich ist, die Weiterleitungen kommen da immer wieder … nicht regelmäßig, aber wieder. Und bei meiner Seite nur wenn man auf eine bestimmte Seite (Kontakt) gehen möchte. Meine Seite habe ich mit allen möglichen Tools checken lassen. Alles sauber. Vor einigen Wochen sogar die komplette URL auf der Website geändert. Half nichts, möchte eigentlich nur verstehen, wie das möglich ist … und natürlich, ob man dagegen etwas unternehmen kann. Hatte nun eine Nachricht von einer Bekannten, die hatte das gleiche Problem auf Ihrer Website … mobil. Und da ich die Website erstellt habe, soll ich sie mal überprüfen … wie erklärt man nun seinen Kunden, das man da nichts für kann!?

Nicht das so etwas zur neuen “Seuche” wird. Es nervt und ist ja total unseriös, jemand surft auf Deiner Website und auf einmal kommt eine fremde URL. Man kommt von da auch nicht mehr zurück … zurück ist blockiert.

Immer mal wieder etwas Neues :sleepy:


(Jan Fuellemann) #4

Hi, nutzt Du auf Deiner Kontaktseite einen Stack, der php braucht? Und bei welchem Hoster bist Du?


(Michael M.) #5

Hast du in diesen Seiten irgendwelche Werbebanner, Affiliate-Code etc. integriert?


(Kunstmaler) #6

Hallo Jan,

die Kontaktseite kommt ohne PHP aus. Kontaktformulare etc. (mit PHP) liegen auf “Unterseiten”.
Hosting mache ich bei Strato.

Danke und Gruß.


(Kunstmaler) #7

Werbebanner, Affiliate-Code etc. integriert?

Nee, gar nichts dergleichen.

Viele Grüße.


(Kunstmaler) #8

Zwischendurch zur Info:

Ich hatte heute mit dem Browser Blisk einmal eine unerwünschte Weiterleitung auf meiner Website…
Aber nur einmal, bis jetzt nicht wieder.

Nun habe ich mir die Adresse der Weiterleitung mal genauer angesehen.
Ist die Adresse tlgram Punkt me. Wird im Web (nur wenig Infos) unter “Browser Virus” und Malware gelistet.
Habe meinen Mac noch einmal komplett mit Malwarebytes gecheckt. Nix.
Auf dem Fire von Amazon war ja dasselbe Problem … aber nur auf meiner Website und nur auf einer bestimmten Seite (Kontakt) Echt merkwürdig.
Auf der Seite habe ich einen Wetter Stack von Joe Workman … sollte ich vielleicht mal entfernen.

Ansonsten keine Idee, außer die “Spam-Seite” auf meine Blockliste zu setzen. Per htaccess Datei. Ob es hilft?
Ich werde berichten :smile:


(Michael M.) #9

Um was für eine URL geht es denn?


(Kunstmaler) #10

Steht in meinem Text: tlgram Punkt me
Wollte die URL hier nicht erscheinen lassen … ohne SSL: http://www

Gruß


(Michael Doepke) #11

Ich kann zumindest bestätigen, dass man auf sehr unseriöse Seiten weitergeleitet wird.

Als Sofortmaßnahme würde ich das www-Verzeichnis per ftp einmal leeren und eine einfache index.html hochladen.
Dann kann man den alten Quelltext analysieren und die Weiterleitung isolieren.
Kann ja auch sein, dass direkt auf dem Server eine (unpassende) Weiterleitung drin ist.


(Kunstmaler) #12

Danke für den Tipp.

Die Weiterleitung kommt innerhalb der Website, wenn man die Seite “Kontakt” aufruft. Kurz ist die Seite “Kontakt” zu sehen und schwups hat die Weiterleitung zugeschlagen … Habe schon vor Wochen die ganze URL “kontakt” geändert. In “kontaktdaten”. War ein bisschen Arbeit, die Verlinkungen auf der Website entsprechend anzupassen. Hatte aber nichts gebracht. Keine Ahnung, das ist ja auch gerade das Interessante dabei !?, wie das kommt … auf dem Server habe ich auch schon geschaut, nichts Verdächtiges gefunden. Aber bei tausenden von Dateien … die Indexdateien habe ich mir auch viele angeschaut. Ebenfalls nichts verdächtiges … naja, das alles zu durchforsten ist nur mit sehr viel Zeit zu schaffen. Da kann ich keine Garantie geben, mir alles 100% angeschaut zu haben.

Alles löschen und alles neu hochzuladen ist sicher mal einen Versuch Wert.
Mal schauen …

ABER erst einmal ist heute Ruhe mit den Weiterleitungen, seitdem ich die Spam URL auf die “htaccess Block Liste” gesetzt habe. Da diese Weiterleitungen aber bisher nie jedesmal kamen, nur unregelmäßig (wobei ich nicht gemessen habe, in welchem Abstand) …will ich mich nicht zu früh freuen. Ich mache morgen wieder den Test, ob es Weiterleitungen gibt …

Bis dahin vielen Dank


(Michael M.) #13

Wie @MiDoe schon schrieb: Schmeiss die ganze Seite inclusive .htaccess vom Server und veröffentliche eine (leere) index.html. Wenn das Problem jetzt noch auftritt, ist es ein serverseitiges Problem - dann ist dein Hoster gefragt.

Wenn nicht, lege die .htaccess zurück. Tritt das Problem jetzt auf, hat die .htaccess einen Fehler (fragt sich nur, wer den da rein. geschrieben hat)

Wenn die beiden Punkte keine Aufklärung brachten, liegt das Problem an der Webseite. Dann hat irgendjemand deine Seite gehackt. RapidWeaver selbst produziert “saubere” Seiten - ausgenommen, du hast irgendwelche externen Skripte eingearbeitet, die natürlich auch verseucht sein können. Das erneute Hochladen des Projektes sollte das Problem dann eigentlich lösen können (wenn nicht, bin ich auch ratlos…)

Grundsätzlich würde ich als erstes allerdings die Zugangsdaten zu deinem Server ändern


(Michael Doepke) #14

Soweit komme ich gar nicht.
Schon beim ersten Aufruf der Domain wird die Weiterleitung aktiv.

Wieso tausende?
Eigentlich dürfte exakt nur eine Index Datei vorhanden sein.
Sollten zwei drin sein (häufiger Fehler: Eine index.html und eine index.php im gleichen Verzeichnis), hängt es von den Einstellungen ab, wie der Server reagiert.

Das verstehe ich nicht.
Was genau hast Du gemacht?

Für mich sieht es nicht nach Ruhe aus, sondern entweder nach einem Hack (dann kommst Du um umfassende Maßnahmen nicht herum) oder um einen Fehler in der Konfiguration.

Ich glaube nicht, dass es an RapidWeaver liegt, dann hätten wir hier mehr ähnliche Meldungen.


(Kunstmaler) #15

Ja danke Michael,

die htaccess Datei kann ich ja lesen. Das ist alles von mir geschrieben. Da gibt es keine Veränderungen … werde aber wirklich alles mal löschen und neu hochladen. Die Zugangsdaten werde ich auch mal ändern …

Heute habe ich noch keine Weiterleitungen feststellen können, an den Stellen (und mit den Geräten) wo es bisher die Weiterleitungen gab. Sollte das Blockieren per htaccess Datei geholfen haben? So recht kann ich da nicht dran glauben …


(Kunstmaler) #16

Ist klar: Die Indexdatei.
Meinte auch alle anderen Index Dateien.

Die Indexdatei: Habe ich mir natürlich schon genauer angeschaut. Da gibt es nichts auffälliges.

Soweit komme ich gar nicht.
Schon beim ersten Aufruf der Domain wird die Weiterleitung aktiv.

Du meinst aber jetzt nicht meine Website?
Das würde mich doch stark beunruhigen.

Die Domain tlgram Punkt me ist die böse Domain. Das ist nicht meine Domain.

Das verstehe ich nicht.
Was genau hast Du gemacht?

Was ich gemacht habe? Siehe Screenshot.

Heute ist bis jetzt Ruhe mit den Weiterleitungen.

Ich bilde mir aber ein, das ich im Browser sehe, wie die meine Seite “Kontakt” nach dem Aufrufen noch einmal geladen wird (kleiner blauer Ladebalken kommt 2x) … der Hack ist wohl noch aktiv, aber durch die Blockierung per htaccess … werde erst einmal alles löschen und neu hochladen …

Danke und Gruß


(Michael M.) #17

Die Weiterleitungen sind immer noch da. Das Blockieren in der .htaccess ist, ehrlich gesagt, Murks. Außerdem weiß ich nicht genau, was du da blockierst - IP-Adressen, Referer, Bots…?


(Kunstmaler) #18

:smiley: Ja, das kann sein. Habe ich vor Ewigkeiten mal eingesetzt. Mit anderen Urls

Wie auch immer, warum hast Du noch Weiterleitungen und ich nicht?
Hast Du mobil geguckt?

Jetzt ist erst einmal alles gelöscht … lade alles neu hoch. Dauert eine Weile.


(Michael M.) #19

Wenn alles gelöscht ist und das Problem von der Website stammt, müssten sie jetzt weg sein. Die Umleitungen sind aber immer noch da.

Vermutung: Der Server ist gehackt. Was auch immer da passiert ist, kann ich natürlich auch nicht sagen, aber vielleicht solltest du den Hoster kontaktieren. Hast du mal die Weiterleitungen in den Account-Verwaltung gecheckt?


(Kunstmaler) #20

Die Umleitungen sind aber immer noch da.

Wie?
Nicht das wir uns mißverstehen: Die URL tlgram Punkt me ist nicht meine URL. Ja, die leitet um auf verschiedene Spam Seiten.

Die URL tlgram Punkt me sorgt dafür, das auf meiner Seite (wenn man “Kontakt” aufruft) Weiterleitungen auf verschiedene Seiten stattfinden. Aber nicht auf dem Desktop, ich habe es bisher nur im Browser Blisk, wenn man mobile Geräte ausprobiert und auf meinem Fire Tablett. Aber seitdem ich die htaccess Datei wie oben zu sehen, beschrieben habe, nicht mehr. Ich denke auch, es ist eher Zufall.

Schaue mal, wenn alles wieder hochgeladen ist (10163 Dateien), was dann ist. Da aber zuletzt nichts war, ist es alles irgendwie etwas nervig und schwer Zusammenhänge festzumachen … nehme dann den Eintrag aus der htaccess Datei wieder raus … und schaue mal. Ist das Problem weiterhin da, werde ich Rücksprache mit Strato halten. Die Weiterleitungen im Strato Account sind alle OK. Und neues Server Passwort vergeben …

Danke und Gruß