Does anyone know what _rwObsfuscatedHref0 = "mai";var means?


(Ginger Hanson) #1

It appears there is something wrong with many of my index.html files when they hit the cPanel. Not all the files appear corrupted but only two or three subfiles within a site are not. The indexes for each website as well as many files in the individual web pages all appear to have this code at the end.

I offered to delete my files off the cPanel since I can easily republish in RW. The server tech suggested I only delete my main sites and republish it which I did (leaving two addons alone) but that doesn’t seem to fix the problem.

When he showed me how to view the actual code (I was downloading the index which didn’t give me much info!), I noticed that at the bottom of each site index was the following information. (I may be jumping on the wrong horse, but I think the rw refers to Rapidweaver.)

_rwObsfuscatedHref0 = “mai”;var _rwObsfuscatedHref1 = “lto”;var _rwObsfuscatedHref2 = “:pu”;var _rwObsfuscatedHref3 = “bli”;var _rwObsfuscatedHref4 = “she”;var _rwObsfuscatedHref5 = “r@s”;var _rwObsfuscatedHref6 = “ade”;var _rwObsfuscatedHref7 = “rra”;var _rwObsfuscatedHref8 = “pub”;var _rwObsfuscatedHref9 = “lis”;var _rwObsfuscatedHref10 = “hin”;var _rwObsfuscatedHref11 = “g”;var _rwObsfuscatedHref = _rwObsfuscatedHref0+_rwObsfuscatedHref1+_rwObsfuscatedHref2+_rwObsfuscatedHref3+_rwObsfuscatedHref4+_rwObsfuscatedHref5+_rwObsfuscatedHref6+_rwObsfuscatedHref7+_rwObsfuscatedHref8+_rwObsfuscatedHref9+_rwObsfuscatedHref10+_rwObsfuscatedHref11; document.getElementById(“rw_email_contact”).href = _rwObsfuscatedHref;<

Since the word obfuscate means to render obscure or unclear, I may be making a big jump, but I felt like it wasn’t a good thing to have this in my index file.

It has been suggested I rebuild my main website. As a test, I deleted the home page of a smaller site, and partially rebuilt it and then republished it. While it published the redo, the site index reveals the same type message at the bottom.

I would greatly appreciate any insights into why this code is there and how to eradicate it.

thank you!

ginger


(Jannis from inStacks Software) #2

That’s nothing to worry about.

The contact email information you enter for the footer should be SPAM save. RW “obfuscates” this by using the above listed JavaScript code.


(David) #3

Hi Ginger,

When I checked your site at http://www.gingerhanson.com from your Forum profile, i see the directory which looks like this:

Index of /

cgi-bin/
friendsofenterpriselibrary.org/
gingerhanson.com/
saderrapublishing.com/

I’m assuming that is not intentional.

If I click on those links, the sites do open but the url’s are appended to www.gingerhanson.com and look like this:

http://www.gingerhanson.com/gingerhanson.com/

http://www.gingerhanson.com/friendsofenterpriselibrary.org/

http://www.gingerhanson.com/saderrapublishing.com/

So it seems like something is wrong with either how those URLs are configured or a problem with where the files have been uploaded to.

Maybe a screenshot of you folders on your sever would help to figure out the problem?


(Ginger Hanson) #4

SPAM save? I’m hoping that’s not something I have to, that if I understand correctly, contact in the footer automatically generates this phrase.

thank you for easing my mind. One less thing to worry about!!

ginger


(Ginger Hanson) #5

I didn’t even notice that web address. I keep asking the MacHighway techs (and I’ve spoken to five and had emails from 3 higher tier in the past 48 hrs. if the hierarchy of my files is correct. Once I get it established and everything lined up I plan to take screen shots to ensure this hopefully doesn’t happen again.

Here’s the screen shot of my ePanel file manager with public open.

Hoping you can see the problem!

thank you,

ginger


(Ginger Hanson) #6

It looks a little blurry, but seems to clear up when you enlarge. Let me know if you need me to send anything else.

thank you!

ginger


(Isaiah Carew) #7

Normally @instacks’s English is perfect :ok_hand: so I’m going to guess he got caught with an iPhone autocorrect or was just tired, because I don’t know what he’s talking about either. :stuck_out_tongue_closed_eyes: (Sorry, just teasing Jannis)

But the short answer is right: You don’t need to worry about this. It’s a good thing.

And here’s the long answer:

Spammers are always looking for email addresses anywhere they can find them. If you put a “contact email” address on your site then the spammers will pick it up and you’ll get a ton of unwanted junk mail.

RapidWeaver provides some basic protection from that sort of thing by hiding the email address inside a purposefully complicated little bit of javascript code. In this way real humans will still be able to use the contact me link, but spammer-bots will have a harder time finding the email address in all that complicated Javascript.

Neato, right!?

As for the weird URLs, I dunno. I’m going to defer to others. But I’d definitely check all the site settings (in the lower part of the left-hand sidebar in RapidWeaver). Make sure the site URLs are set correctly.


(Ginger Hanson) #8

Thank you, Isaiah. Putting protection on the contact list makes sense. Makes me lean toward there being a problem with the way the files are ordered in the cpanel. The server guys are blaming the main site index, but I beginning to wonder if its more the way the files are listed.

I keep trying to find a chart or something that shows exactly where the main domain and add-on domains are placed in the public-html file. Right now they are in alphabetical order and it appears as if when I load the main site, it goes to a subdomain first.

If I understand correctly, the path has to be in a certain order and I think that’s the problem. Somehow things have gotten mixed up.


(scott williams) #9

You need to ask your hosting provider what the default folder should be for your website. It is usually something like: /Public_html or www.

So it would be something like:
YourSite/Public_html— files & folders go here for YourSite.com
If you have subdomains such as: SubdomainX.YourSite.com
Each one of those should show up under YourSite.

My folder structure looks something like this:
/Public_html - where my main site is
/Sandbox1.mysite.com/public_html - where the sandbox1.MySite subdomain files are
/Sandbox2.MySite.com/public_html - where the sandbox2.MySite subdomain files are
etc…

If you have multiple Domains (not Subdomains) then you should probably have a Cpanel log in for each.


(Ginger Hanson) #10

Scott,
It looks like mine is backwards, then. Where do you go to see the actual path? Right now all my sites are on the same level at public_html. Arranged alphabetically. I asked if that was correct and was told it was.

I’ve talked to about 5 techs at MacHighway and 4 upper tier techs have emailed me. Right now “they’ll get back to me when they have a solution” which from my FTP problems in June means 3 weeks later to apologize for not getting back to me!

So far, I’ve renamed all the folders in the Inspector and republished b/c I had used an older method to name them. Then I read the path publishing problem where Doug told this guy in AU to clear out his path on the publishing tab and then browse which I did. The cpanel files came up and I clicked on public_html to gingerhansond.com to the index.

Still no luck. Instead of going to my home page, I get the list of the three sites. Here’s what’s odd. If you manually type in the site addresses for the two addons, the URL addresses are correct. If you type in my main site, you get the list of cgi-bin and three links. Using those links, as David noticed, you get my main site/addon address or main site/main site.

The hosting techs have messed around in there. One apparently moved something and lost all the email (which another restored) and someone moved something and now the file goes to that list of links. Makes me reluctant to call them again. The upper tier guys no longer use the phone, they just email. Basically, I call someone on the bottom rung, they fiddle around with the problem, and then they put in a ticket and somebody higher up emails me. Eventually.

I’m wondering if I should just delete all the add-on domains’ files. Republish my main site. See if it works, and if it does, republish the other two sites.

Any suggestions on how to get the path to my home page will be greatly appreciated.

ginger


(scott williams) #11

Makes me wonder how Mac Highway has things set up and where the actual DOC_Root is That’s what you really need to know.

You would probably be much better off with a more “User Friendly” host like @barchard at Chillidog


(Doug Bennett) #12

From Mac highways instructions the primary domains publishing path should be: public_html. There’s complete RapidWeaver instructions here:
https://customers.machighway.com/index.php?rp=/knowledgebase/98/RapidWeaver-Publishing-Instructions.html

As for the addon domains you’ll need to go into your cPanel, select addon domains, and you should see a setting for Document Root:. That should be the path for the addon domain.
I don’t now or ever have hosted with them so I’m going by what’s in their knowledge base.
For information on the addon domains take a look at this page (step 4):
https://customers.machighway.com/index.php?rp=/knowledgebase/6/Adding-hosting-for-an-additional-site-VIDEO.html


(Gregory Barchard) #13

Hi Ginger,

Your main site, gingerhanson.com, is being published into public_html/gingerhanson.com which is why you see a directory listing when you visit gingerhanson.com. There are two ways to fix this:

  1. If you use your cpanel username and password, set the publishing path in RW to exactly public_html/ or
  2. Use symlinks and Terminal. I wouldn’t recommend this unless you really know what you’re doing.

You will have to republish all files in RW.

I hope that helps. Let me know if you’d like to like to give Chillidog a whirl! Migration is done by yours truly (for free, of course) :slight_smile:

-Greg


(Ginger Hanson) #14

Thank you Doug and Scott for your help. MacHighway has actually been around a long time. They’re one of the first Mac hosting services. I’ve been with them since 2004 when the owners answered the support lines!! Usually between reading lots of RW forum info and calling them, I’ve been able to solve any issues. They have techs available 24/7 but as with any other computer support, they’re lower level and aren’t allowed to do some things. It’s the Tier 2 guys who aren’t as supportive for some reason.

On to the suggestions. Thank you, Doug. I was at their knowledge base, but I keep asking about cPanels. I read about using public_html in an earlier forum discussion and have put that in. It seems that RW automatically updates it to the public_html/gingerhanson.com. I checked the add-on domain docroots and they are correct in RW.

Greg, I’ve attached some screen shots. I put public_html in there but the “change the path choice” menu comes up and once I tell it to change the path, RW put the whole address in there. I seldom go into Terminal unless an Apple tech is on the phone! I do know how to check my ePubs there, but that’s about it.

Okay, I’ve taken some screen shots that I hope will show what’s what on the cPanel. The first one is the RW FTP panel. The rest are cPanel shots. #1- the public_html left menu
#2 info exposed when I click on the public_html in left menu.
#3 is main website opened. I’m getting duplicates of the index and site map for some reason. But they aren’t true duplicates. I’ve attached copies, too.

Then, I read somewhere that www.gingerhanson.com in the left hand menu should be a mirror of my web site. An alias if I got it correctly. That you could link from it in the cPanel to your website. #4 shows mine only holds a test and the directory is empty when you click on it.

FileManager1

FileManager4

With luck, I did that correctly! Oh, and thank you for suggesting other hosting options. I hate to blame MacHighway if it’s something I’ve done, or something in RW. I’m going to partially redo the home page and see if it is the index that is causing problems. One tech was trying to clear up the problem and moved the index somewhere (I didn’t catch what he was doing exactly) and we lost the site entirely. He then moved it back but now it only shows the cPanel choices as in the first screen shot.

The suggestion was to rebuild and republish the home page as something there could be throwing things off. I plan to rebuild it enough to link everything and have a simple home page to see if that clears up the issue.

Hoping someone notices something that’s going wrong! And from what I understand the path on the cPanel is home/gingerha/public_html/gingerhanson.com. I checked the two add ons on the cPanel domain area and they are public_html/friends or /saderrapublishing.

Okay, I’m going to spend another day trying to get my website back online!


(Doug Bennett) #15

Never seen RapidWeaver change the path automatically.

Can you give a screenshot of that? You should be able to put anything you want into the path in the publishing settings. You need to get the path to the primary account set to public_html, or your URL will not work. You can try this:

  • Clear the path in RapidWeaver publishing settings
  • Select the browse button
  • Choose public_html

Your add-on domains seem to be working fine:

It’s the Primary domain that is broken:

2018-08-01_09-54-41


(scott williams) #16

Your main site is at: http://www.gingerhanson.com/gingerhanson.com/

in RW Publishing set up, set the publishing folder to /html_public
in RW general settings (spanner wrench) make sure web address is set correctly


(Ginger Hanson) #17

MacHighway got back to me about the “obfuscated” question I hit them with before I asked on the forum. They had no idea what it was! Now they do thanks to your response.

Scott, it comes back there was an error and access is denied by the cPanel when I switched the folder address to /html_public.

Doug, I made some screen shots. For information’s sake, these websites have been operating with no problems for four years. I am absolutely stumped as to why it decided to stop publishing correctly. It all started in May with the FTP failing to connect.

Okay, when I tell it to Browse while the path is empty, I get this window

If I click on public I get this window.

I wasn’t sure if I should then click on an index file or which one now that I have two

Here’s what comes up about the path
PathChange

Plus, there seems to be two ways to find my websites. My Safari is set to load that window first and that’s when I get the whole cgi-bin list. If I link from my Index web page, it goes to my home page but the address is gh.com/gh.com. As Doug noticed, the add-on addresses are also preceded by the domain name. But, if I use the links in my Safari bookmark, it goes directly to the web site with the regular URL, no extra gh.com added to the address.

Yes, the primary domain is not playing correctly. I’ve been putting together a sample website of two pages. I’m going to delete my current files and publish this abbreviated site to see if it’s the Index file which two techs have said didn’t look right. Since I have no idea how they are supposed to look, I figured last resort, try this.

Look forward to any more thoughts on this mess.

thank you so much for your help!

ginger


(David) #18

Try uploading the gingerhanson.com site only to public_html, rather than into the gingerhanson.com folder. Your main domain should not be in a folder as far as I’ve ever seen on any hosting.

That should clear up the url issue with that domain.
If that works you can also then delete the gingerhanson.com folder.


(Ginger Hanson) #19

David, I just reloaded everything (before I read your suggestion) and RW send me the multiple index message. I searched the forum and one problem may be that my sites are all stacks pages except for the contact and site map pages. It was recommended that the default extension be php for stacks pages rather than html.

Since it says the change only applies to new pages, I guess that would mean rebuilding at least my main site from scratch with php as default. Which is due an update. Question being, could this affect the route? I know Stacks had an update about the time all my problems began and kept showing up in the RW support log.

Okay, I’m going to try your suggestion although it may not work b/c now I have two indexes (or maybe more, they multiple like rabbits and I haven’t been to the cPanel for an hour or two).

thanks!

ginger


(Ginger Hanson) #20

David,

SUCCESS!!
It worked!! Thank you, thank you. Not only did it work, but this time the path stayed /public_html instead of defaulting to adding my web address. I have put dozens of combinations of information into the FTP publishing page since June b/c of the FTP failure to connect issue, but the suggestion of using public-html by itself was not one of them until you guys suggested it.

Also, the double address is gone. Since it was there a few weeks ago and a tech removed it, there may have been a publishing issue that dates back awhile. Finally, the whole path concept is working. One good result, I’m no longer awed by the thought of going onto my cPanel page. It’s become quite familiar!

Thank you, again. David, Jannis, Isaiah, Scott, Doug, and Greg–I’ve read a lot of the discussion forums and you are absolutely the best with advice and being patient with RW users. I sure hope the RW guys in England appreciate what a great job you do for them.

And Isaiah, I love, love, love Stacks as do countless RW developers since they use them in everything!

Now that I have my website back, I can actually plan the launch of my next book which has been delayed for weeks due to these problems.

Hopefully, I won’t bother you again for a while, but it is reassuring to know you’re there.

ginger