Webpages not displaying changes when published


(Cynthia Taylor) #1

Hello,

I have some pages that do not show changes when published. They are correct in RW7, but when I publish them, they are not displaying the information correctly. It’s hard to explain, but I’ll try to put a link here as an example of one of the pages that is having this problem. http://www.educationoasis.com/printables/graphic-organizers/main-idea/. On the bottom left of this page, there is a link that should lead to a Herringbone graphic organizer which is graphic organizer number 37. However, when clicked, it leads back to the same page, the Main Idea graphic organizer, which is graphic organizer number 39. Everything seems fine in RW, but when I publish it, the links aren’t working correctly. This is just one example of the pages that are having similar problems. When everything seems normal in RW, it is not working on the site once published. I even tried publishing with Transmit, and it didn’t correct the problem. This is getting really frustrating! :dizzy_face: Does anyone know how I might fix this problem?


(Mark Sealey) #2

Have you tried ‘Mark as Changed’ in the File menu; then republishing, Cynthia?


(Rittmann) #3

Hi
Try the “Republish-Button”. If this does not help - delete the corresponding folder on the server and republish again. Should work…

Best


(Matthias Ficht) #4

Maybe you could also check if you have both .html and .php files of your pages on the ftp-server. If so you should delete the wrong one (or when in doubt simply delete both and re-publish all files).


(Jochen Abitz) #5

The first thing i would do is to look into the folder on your server. Sometimes the ending of the index file change from html to php if you put a stack into the page. Then there are two files in the folder on the server, because the old index file still exists. Delete the old one is the solution for this.
Jochen


(Cynthia Taylor) #6

Thank you all very much for your suggestions! I tried and checked for all of them, but it’s still doing the same thing. When I checked the source code of my page, if I’m reading it correctly, it appears that some of the a href links are not pointing to the correct pages. As I mentioned earlier, even when it’s correct in RW, when I republish, no corrections are made on the server. Also, even some of the small images are incorrect. Again, they seem OK in RW, but when I publish, it’s like some of them are getting scrambled or something, and some incorrect images are displaying in the wrong places. Anyway, I was wondering, is there a way that I can manually correct the source code and publish that? I don’t understand why when I republish nothing gets changed, but maybe I could go in the html code and edit the links to point to the correct page. Do you know if there is a way for me to do that? Thank you so much!


(scott williams) #7

Hi @cynthia,

You can export the page and edit the html with text edit, text wrangler, etc. but it’s not advisable because RW won’t know about your edits and the next time you make changes in RW it will get overridden.

I’m on mobile right now, when I get home I will have a look and see if I I can tell what’s wrong.


(Matthias Ficht) #8

Hm, maybe you’re publishing to the wrong path (Publishing Setup -> Path)?
At least that would be an explanation for most of the issues you’re experiencing…

I think you’ve already tried choosing “Mark all pages as changed” and then “Re-Publish all files”, right?

Anyway, as Scott just said: forget about editing the exported html files! All these changes will get overwritten again as soon as you’re republishing your pages.


(scott williams) #9

@cynthia,

The left photo AND caption are indeed linked to …/main-idea in the html.

Here is what I would try to see if it is a publishing problem or something else.

  1. Remove the image link and the caption link
  2. save
  3. republish that page
  4. is the file still linked?
  5. if yes - its not publishing the page
  6. If no, it is publishing, relink the image and caption Save and publish again

If it is not publishing see if it is exporting the correct code

export the page and open the html in your fav editor
search for character_mapsm.jpg (your image file name) and have a look at the html, Is the link correct there?

BTW the image on the left links to …/main-idea the one on the right links to …/main-idea-2
It’s not just that you have a dup page with two different names is it?

What is the name of the page that the left image should link to?


(Cynthia Taylor) #10

I believe the path and everything is OK, and I tried republishing. I guess I won’t edit the html as you said so they won’t get overwritten. Anyway, I’ll try what Scott outlined below. Thank you!


(Cynthia Taylor) #11

I did the steps that you numbered. It did make changes, so I guess it’s publishing. I tried to remove the links and rebuilt them, but now the page is all messed-up when I click the links. I didn’t have time to check all the code because I have to leave now, but I’ll check it when I return. No, I don’t have a duplicate page, but I have 3 pages with different numbers at the end. I wonder if that’s a problem? The name of the page that the left image should link to is …/main-idea-3. I also have a main-idea and main-idea-2 page. I was thinking of trying to rebuild these pages that are messing up and give them different names or something and see if that helps. I don’t know what is causing this. I wonder if it has to do with the related CSS files or something? I don’t understand it, but I am not an expert in all of this. I wish RW would let you edit the html in the program the way Dreamweaver does. Anyway, I’ll keep working with it later, and I really appreciate your help!! :slight_smile:


(Matthias Ficht) #12

Hm, one last try from me: maybe the “Copper” theme you are using (as far as I remember it’s quite old) doesn’t play well with RapidWeavers feature(s) “Consolidate CSS files” and/or “Minify CSS and Javascript” (in the “Settings” at “General” -> “Advanced”). Try turning these features off (or on) and see if s.th. changes.


(scott williams) #13

Hi @cynthia
I Just had a peek,

The one on the left now links to …/main-idea-3
The one on the right to main-idea-2

Is that correct?

You may need to clear your browser cache…
The folderName-2, folderName-3 should not be a problem although I favor: folderName_number (underscores)

BTW, I noticed there are lots of error warnings on the pages in web inspector. looks like most are protocol mis-match http -vs- https


(Cynthia Taylor) #14

Yes, you’re right, the Copper theme is quite old. I do like the look of the theme however; plus, I wouldn’t really want to rebuild the site with another theme. I remember in the past I turned-off the Consolidate CSS files in RW6. I don’t see the Settings area now in RW7 to check these.


(Mark Sealey) #15

In RW 7 those settings are in General > Advanced (bottom right)


(Cynthia Taylor) #16

I’m sorry, but I don’t see that in my copy. I only see General Settings in the Inspector, and a General tab under Preferences.


(Brian LaPan) #17


(Cynthia Taylor) #18

Yes, that is correct, but when I click the links on the bottom left, it still takes me to the main idea page and the formatting is messed-up on it. I tried clearing my cache in Chrome, and I tried it in Safari, and it did the same thing.

I did get a notification a while back from Google about the http vs https. They wanted me to choose one, so I chose the http, but I don’t think that helped because I believe the notification is still there. I don’t understand that, or what caused it. As far as I know, I just created the site using http, so I don’t know how this conflict started. Anyway, I also don’t know how to fix it, so I guess I have another big mess to worry about.

I did notice one thing in my RW, but I don’t know if it matters or not. When I go to the Publish down arrow, Manage Bookmarks, I have one on top called My Server, then I have Export Location, and then I have one called Main. The settings in My Server and Main are identical. The name of my project is Main.rw. I don’t know if I need both, but I don’t see a way to delete one. Do you think that makes a difference?

Anyway, I think most of the other graphic organizer pages on the site are working correctly, but I still have to finish checking them one by one. The 3 main idea pages are the ones I found so far that are acting funky. I think I will have to delete them and try to rebuild them and rename them and see if that helps. I don’t know what else to try at this point. I was trying to make a nice, simple site, but I always seem to run into all of these problems. Oh well, I guess I’ll just keep on plugging along with it. I don’t want to throw in the towel at this point. Thank you so much for checking all that you did!


(Cynthia Taylor) #19

Oh, thank you! I had so many pages in that left side panel that I didn’t see the Settings down at the bottom. When I go to the advanced, all of mine are checked except for Consolidate CSS files and Minify CSS and Javascript.


(scott williams) #20

Maybe I am misunderstanding.

When I look at left link it is …/main-idea-3. When I click it it goes to that page according to the URL in my address bar.

Right links to and goes to …/main-idea-2

So the URL is changing in the browser so the link is working. Are you saying that the page that loads from …/main-idea-3 is actually the wrong page?

If so, then you need to check with your FTP app and make sure that there is only one index file in that folder.

Are you using cloud flair by any chance? That could possibly still be serving the old page if you didn’t force it to update.