How can I delete/deactivate the RW Crash Reporter


(Ian Sinclair) #1

The damned rapid weaver crash reporter keeps crashing every time rapid weaver crashes.
Then I have to force quit rapid weaver in order to restart rapidweaver. This has happened dozens of times in the past 2 hours, ever since I started trying to delete some pages from a website that is obviously too big for rapid weaver to handle.
It is one thing to have to delete one page at a time since more than one will guarantee a crash, and then to have to save after every page deletion (200 to go), and still it crashes after a few deletions. But it is exponentially more annoying to have to force quit rapidweaver after it crashes just because the rapidweaver crash reporter crashes. Then I sit and curse as I wait for the whole process to repeat 200 more times.
There should be “delete this piece-of-crap-function from this app.” button.

Perhaps I should use my video camera to record the screen, and then I can mail the video to realmac by post. That would be less time consuming. However, the video would be R-rated due to language and violence.


(Gary) #2

I had this problem with RW6 and it drove me crazy and after many many emails to RM, Nik (at RM but now with Rapha) sent me this:

If you enter the following into Terminal.app, you can disable the crash handling in RapidWeaver:

defaults write com.realmacsoftware.rapidweaver6 RWEnableExceptionHandling -bool NO


I used it and it stopped the crash reporter.

I eventually solved the crashing by never using the built in FTP.


(Ian Sinclair) #3

But it seems to have followed me to RW7.


(Patrick Trzcienski) #4

Please flush Crash Reporter down the toilet.


(tim parsons) #5

Hi all, i say that sounds good, disabling the Crash Reporter it never seems to report anything anyway, i have lost count of the times my RW6 and RW7 have crashed.

The Crash Reports cant be getting through to there intended destination BECAUSE it still keeps crashing, therefore Disabling it seems a dammed good idea.

I have RW7 7.1.1 Please what do i type into Terminal to disable Crash Reporter in RW7.1.1 ?
and would i have to type it in again every-time there is another update ?

Tim


(Dan) #6

We’ve fixed the crash reporter in RapidWeaver 7.1.2 — Please re-enable it (if you did disable it).

Check for updates to get this latest release.


(tim parsons) #7

What is the terminal command to re-enabling ?
Perhaps that terminal command wouldnt have worked anyway with RW7 ?

Tim


(LJ) #8

Not fixed for me and I’m now on 7.1.7