How do I get a page to use the master style?

I have a “styled text” page, it is selected in the left sidebar, and I’m looking at the inspector.

Problem: text color should be white (in the preview), but is not. According to the “circle with a point” menu (what does that stand for?) the “Use Master Style” is checked, but the page clearly isn’t using it. Ok, so I click the “Edit” button next to the “Use Master Style” checkbox. And then it says “No page selected”.

Yo! It was selected before you unselected it. Bizarre product.

Anyway, how do I get a page to obey the master style?

Why do you think it should be white?

What theme are you using?

Are you sure you have selected the correct theme?

  1. It should be white because that’s what the “Content Text Colour” shows.

  2. I’m using the Bravo theme. I think. Is there a “Project settings” menu item somewhere?

  3. And yes I’m sure that I’ve selected that theme.

I’m attaching a screen shot, in case this help system accepts that.

It works okay for me,
Styled text with Bravo theme in preview:

Of course, you can change the color with styled text:

2020-02-09_15-23-21
And get this:
2020-02-09_15-23-46

  1. Where do you find that rainbow wheel?

  2. Ok, so I unselected “Master Style” and then edited the text color. How do I get that color to apply? I’m pretty sure I’m using ordinary text because there is an item list that gets correctly formatted.

(Can I use the inspector to inspect what style is being applied to a specific element?)

Are you typing the text in RW or are you pasting it from another application? If you are pasting it, make sure you are using Paste as Plain Text from the Edit menu. If you don’t, you end up also included hidden formatting from the other app which can prevent styling from RW showing. I’ve not see it affect color as much as text size, but I did want to rule that out.

Also, if you have a link to a text page on your site and post it, we can tell better what’s going on.

Good point. I was typing the text directly.

This page: the item list above the “Original compositions” header stubbornly refuses to be formatted according to the master style.

What? I thought I included the URL here. Forum software broken apparently.

Why is the item list not in the page style?

All of that text in enclosed in HTML <span> elements setting the color to black (hex #000000).

18%20PM

I’d highlight the text in RW and go to the format menu and select “Clear Formatting”.

1 Like