How to get rid of buggy "Smart Quotes" function?


(Robert M. Münch) #1

Hi, I need to use some HMTL stacks and while editing the code, the “smart quotes” option always comes back. The bad thing is that the code is totally screwed up by this. It looks ok in the HTML stack, but not in the code.

How can I disable “Smart Quotes” once and for all. This is driving me nuts…


(Brian LaPan) #2

Disable Smart Quotes in the Format menu item.


(DeFliGra) #3

Agree… Smart Quotes are invented by the devil. Gets me every now and then too.
Really think they should be turned off by default – instead of the other way around.


(Robert M. Münch) #4

I did, and the thing is always coming back. I can disable it, do something, get to my HTML code and it’s re-enabled again.

The worst is, that it totally screws up the content. Things look like correct HMTL in the stack but the HTML code is totally broken.

I just want to disable it once and for all. It should never ever come back.

I would be so happy if I could only use an external texteditor to edit my HTML code.


(Michael M.) #5

There is an option in system preferences > keyboard you can uncheck


(Brian LaPan) #6

If you remember to always select the code and just format “Ignore Formatting” that will do it, also.


(Robert M. Münch) #7

Great! It was turned on, so let’s see if this helps.


(Robert M. Münch) #8

I did that but it always came back as soon as I started to edit the code.


(Aaron Marquez) #9

Hey @robert_muench - Ignore Formatting will ignore any formatting (differences). You can also highlight the code and go to Format > Clear Formatting. This is something that would be best done after any code changes, etc.

Does this work for you?


(Nik Fletcher) #10

Smart quotes should be turned off by default in the latest versions of RapidWeaver. We’ll look into this and see if there’s anything else we can do to prevent it - though, the system may take over!


(Robert M. Münch) #11

How about adding a check for the system setting, when I turn off the feature and showing a note. You can save a lot of support requests.


(Robert M. Münch) #12

Yes, the thing was, it always came back. The clear formatting is not a property for future entries but only for the existing text. So, starting to add things, got formatting stuff back again.


(Paul Russam) #13

You need to turn them off in OSX preferences like @apfelpuree said.
System Preferences > Keyboard > Text > Use smart quotes and dashes (off)


(Nik Fletcher) #14

We already override it by default, but this isn’t necessarily a preference we can read in.


(Robert Ziebol 🖖🏼) #15

@nikf Had this happen to me last night, could not figure out for the life of me why copying and pasting code from one project to another did not work. Ended up copying the entire stack it was in and that worked, but I am running 6.2.3 and I was still getting the smart quote issue, so the OS must override that.


(DeFliGra) #16

Problem with turning it off in the OS… if you – as I believe many of us do – work with both webdesign & layout for print… lots of text for booklets > it’s a turn on/off hell.

For coders the smart quote feature is annoying.
For RapidWeavers not dealing with code - but maybe writing a log of blog posts, the smart quote feature is probably a good thing.

So… for this feature to be really smart it would have to be up to each user to decide what suits their purpose best. At setting for either RapidWeaver or maybe the project… cause I have both projects where I never touch a single line of code – and projects where I do.


(Lisa Sandler) #17

I emailed RealMac about this back in May and they responded saying they didn’t see any issues. I have problems with this all the time. Looks fine in RW, then when published doesn’t work, have to go back and reset the smart quotes.
Just make the default OFF, PLEASE!!!


(Mathew Mitchell) #18

I also ran into this problem today. I’m really expecting an HTML stack to not transform quotes to smart quotes. I finally figured out what was happening, but not right away! Could this bug be fixed?


(Nik Fletcher) #19

As noted above, the default is set to Off. The system overrides this, and we cannot work around it. You’ll need to turn off the Smart Quotes feature in System Preferences.

—Nik


(Mathew Mitchell) #20

@nikf: The problem is it IS turned off in System Prefs.