Quotation marks in code problem


#1

Hello

I have been having problems with writing code in rapid weaver using an HTML stack and I finally figured out WHY its been happening. Every time I write code such as

test 1 2 3

the colour does not work. Now here’s the problem my " mark is not correct I guess you could say and the colour won’t come up. When i go over to w3 schools and use there try it editor the " marks are correct and the code gets the colour. I tried switching my keyboard language to US but still my “” marks don’t work in html code.

Can someone help me fix this issue?

I use a mac mini 2012 and a microsoft keyboard and i am running mavericks

many thanks for any assistance

No need for assistance I solved the problem. if anyone else has this problem click on the rapid weaver format menu and take off smart quotes and the problem is solved.


(Adam Shiver) #2

Give this a try… go to System Preferences and Choose Keyboard. From there select the Text tab and turn off Smart Quotes (http://d.pr/i/1gesH). Then delete your code in your HTML stack and re-type it. Should clear up your problem.


#3

thanks for the help, your solution worked


(Peter Danckwerts) #4

Better still, turn it off in Rapidweaver Format>Smart Quotes.


(Robert Ziebol 🖖🏼) #5

@peterdanckwerts this solution does not always work, it is better to follow @Elixir’s advice as it will always work.


(Adam Shiver) #6

As @zeebe mentioned, you’re going straight to the source by turning it off in the System Preferences. Feel free to do it either way, but if you continue to see problems when you’ve disabled it only in RapidWeaver, know that you can nip it in the bud in the System Prefs.


(Peter Danckwerts) #7

That’s fine as long as you’re happy to have them switched off for everything else, or remember to switch them back on every time. Frankly, it isn’t acceptable to have to turn them off at a system level, and I haven’t had any problems turning therm off in the program (yet!).