How to prevent double submissions

Hi. Once in awhile I receive several identical copies of a form submitted on my website with the same time stamp. I was going in circles between my host provider, Rapidweaver support and the maker of the theme and the one who made the add-in form.

Just today I discovered that if I double click (or more than that) the form gets sent everytime there is a click. I thought just one click and successive clicks after that would be ignored. At least I finally narrowed it down to why that was happening.

I’m not a programmer, but have enjoyed building my Rapidweaver site (https://terryiversonphotography.com). Is there a way in Rapidweaver that only the first click on the Submit button would be recognized and any subsequent clicks be ignored?

I have no idea why you are experiencing the problem you describe.

I thought I could guess, but when I took at look at your contact form I found I was wrong. … here’s what happens with several forms: you get a message on the same page as the form that it has been submitted successfully. In general that’s fine, but with some longer forms the “success” message appears at the top of the form, often above the viewable area of the user. So it can be ambiguous to users the form was successfully sent. Thus multiple clicking at times.

I assume you are talking about your regular “contact” page and not something else. At any rate when I tested it the form very nicely goes to a new page signaling success. That’s great as it’s super clear to the user the form has been submitted.

So either you are asking about another form or your users are very uncoordinated. :slight_smile:

Thanks for the response Mathew. I was not referring to the simple Contact form that came built in with the theme, but my custom ‘Request Photo Shoot’ form (Formloom 4), which incidentally is rather long as I need quite a bit of info to help me schedule the shoot.

If the user fills out the form and clicks the Submit button just once, there is a small delay before going to the next page telling them that the form has been sent.

I now suspect (thanks for your suggestion) that the long form when submitted takes just long enough to process before moving to the next page that my users are clicking more than once. It might even be worse for those on a slow Internet connection.

I guess immediately switching to another page after clicking on Submit with a message “processing or submitting” then resolving to “Sent” would do it. I just don’t know how to do that.

@tip.com For me there was a 5 second delay between clicking submit and something happening. That’s a long time. Pretty understandable that some folks would click more than once. Once it gets into gear one goes to a new page confirming submission: so that’s very clear.

I’m not sure why this is taking so long to process: should be much faster. It’s worth asking YabDab about this. However, I doubt it has much to do with FormLoom. My guess would be either things are slow on your server end OR somehow the image on the contact page for some reason slows down the submission process. Obviously I’m just guessing. But your form is shorter than many: so I doubt it has anything to do with form length.

If you can’t figure out the cause of this delay via FormLoom support, your host, etc. then you might want to add some explanatory text right above the submit button: “It may take up to 6 seconds for this form to process. Don’t worry!”

Maybe @yabdab could disable the submit button after clicking but before submitting/processing the form. That should prevent anyone from being able to click on the button a second time while it’s doing it’s thing.

Great thoughts. I’ve added text for now asking for just one click and have reached out to @yabdab for his thoughts.