HTML Code page doesn’t show media query correctly on published?

Hi guys I add an HTML Code page to my Foundry website. Simulate and Manual Adjustment shows everything correctly but when I published it does not show media query correctly. On the phone, everything shows as a desktop version. Could you please somebody look at my files. What am I doing wrong?

HTML Code Page name is 404. This page is an HTML page. I am looking help for on this page.

This could just be your browser showing a cached version of the page. Have you tried clearing it’s cache or another web browser?

Since it’s working in RW, do you have a link to the live page where it’s not showing the mobile breakpoint correctly?

Hi, the page is already published 3 weeks ago. I tried clean cache but didn’t work. This is the link for the page;

And looks like this on the iPhone 8; but actually RW simulator shows correctly with iPhone 8. I really don’t get it why doesn’t show on when I published.

Not sure what you are expecting it to look like.

Also not sure why you wouldn’t want to have the sites navigation on a 404 page? when someone get’s a 404 (not found) then they have probably have an old link to a page that doesn’t exist any longer (you didn’t do proper redirects) or they mis-typed the URL.

Having a page without navigation doesn’t make it easier for them to find where they want to be.

So I guess what I’m saying is why don’t you just create the 404 page with your standard Foundry stuff instead of using native HTML?

Just make a page that says the “oops” message and put two buttons on it. On that would go back to the home page, and the other "report a problem” with the link set as the email address:


Cause I want to using native HTML feature of RW. Of course I can make it this with foundry. But I want to implemented the native HTML page to my site.

Also mobile looks shows correct on RW and RW simulation but does not show when I published.

Your page is made up of hand coded CSS and custom Javascript code. The published page looks fine in Safari’s ‘Responsive Developer Mode’, but incorrect on an actual iPhone. The issue does not appear to be with RW. With custom code, a lot of times you still need to test your code on an actual device.

Did you write this yourself or was it provided from someone or a website? If you didn’t write it yourself, you will probably have to check with whoever did.


This link: doesn’t exist. When you click on it you get a 404 error. The actual URL is : There is no 404 in the file name, and the folder name starts with a capital `E (bad practice to mix cases in folder names).

URL’s are case sensitive is a different URL than this:

1 Like

Yes, I deliberately misspelled this. Isn’t that what the 404 is about? Redirecting the misspelled URL to 404. In this case, we can say that the code works correctly, right?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.