Hi, I am using RW 6.4 - one page does not publish changes, others do


(Robert Wait) #1

Have ‘marked all pages and resources as changed’ and ‘republished all’ several times, and combed through the forum. Does this ring a bell for anyone ?
The page not publishing has a form on it - the form is working.
Cheers


(Jason Bostick) #2

Is it marked as “Draft” by any chance?


(Doug Bennett) #3

Is the page PHP or HTML? If it changed to PHP from HTML you may still have the old HTML file on your server. Check with an FTP program or if your host has a file manager (maybe in the cPanel) check and delete it.


(Robert Wait) #4

Thanks for the suggestion Jason - but the page was marked ‘show in navigation’ as you suggest.


(Robert Wait) #5

Thanks for your help Doug, It is a .php page - I went to cpanel and found an old .html version of the page and deleted it. I ‘marked all pages and resources as changed’ and ‘republished all’ - but there is still no change to the website page.

I made a quick change to the page’s text then clicked on another page and then published again - but still no change to the website page. I have hit the refresh button on the web browser after each publishing attempt.

Any more suggestions welcome : )


(David) #6

Usually i have to refresh 3-4 times to see the new version, or clear the browser cache. Might be worth a try.


(Robert Wait) #7

Thanks David, I cleared the browser cache and refreshed the page ten times - the changes don’t appear when I view the site on my cell phone either.

I re -checked and of the 12 pages on the website only one page does not publish the changes, the .php page, all others are .html ?

Any other ideas?


(Doug Bennett) #8

Humm,
Are you using cloud flare or similar cache product?
If so you will need to log onto it a update the cache.
Have you tried typing the full URL with file and extension?
Http://example.com/pagename/index.php


(Robert Wait) #9

Thanks Doug, you are onto something. I typed in the full URL with file and extension and I could see my page with changes. When I refreshed the page it was still there with changes, but when I clicked on another page and went back to the page in question, the changes weren’t there. I refreshed the page and the changes still weren’t there.

I am not using cloud fare or similar cache product that I am aware of - not sure how to check if I am.

When I googled “how to clear browser cache mac” I followed instructions - Safari/preferences/privacy/manage website data/remove all/done.

Any more suggestions?


(scott williams) #10

Do the same test as above.
look at the full url when changes are there and when there not.
Is it the same? - including filename and extension

Sounds like the changes are probably indfex.php and the old is probably index.html
The server will serve .html if it exists and you don’t include the file name in the url.

If this is the case, You need to use an ftp app or your file manager on the host to delete the .html file. RW does NOT delete files from your server.

-or- you are looking in two different folders


(Doug Bennett) #11

This sounds like the PHP and HTML problem for sure. When you deleted the HTML file with the cPanel were you in the right directory?
Double check that the file in the directory(folder) for that page is gone.


(Robert Wait) #12

Thanks Guys! problem solved. I went to cpanel and clicked on file manager, then found public-html clicked on that, and found my page’s title and clicked that, and found two files one index.php and one index.html. I sent the .html to the trash and checked my website again and the changes where there.
Heading up into file manager is scary territory for me, I had previously found and deleted other files that appeared to be relevant index.html pages under old page headings … things need tidying up in my file manager, can some one point me (and others wanting to know) to a tutorial for that please?

Thanks again!
Rob