Page doesn't publish

theme

(Harold Appel) #1

I am using the Split theme and added a photo gallery page which appears in the preview in RW and seems to publish but does not appear on the website. I tried different browsers and cleared their caches. The page should appear in a submenu of Paris, Europe, Nordic next to Finland, etc 2012. What am I doing wrong. Mac OS 10.13, RW 7.5.1

http://www.haroldappel.net


(Lisa Sandler) #2

Check to make sure your new page is not now php. You might have an html version that needs to be deleted from your server.


(Harold Appel) #3

Not sure what you mean but I’ll check my server control panel. What shoul I be looking for. (I’m a newbie, I think).


(Lisa Sandler) #4

Go in to your file manager, then into the public.html folder, then into that specific page’s folder. You should see either or both the name of the page… one ends in .html, one may end in .php. Delete the older one, which I suspect may be the html file.


(Harold Appel) #5

All I see there is page-19, no name, but see that it contains my jpg photos and the index is html. I see no php anywhere.


(Lisa Sandler) #6

What is the name of your page and do you have a link to your website? Sorry, I didn’t see you added it to your OP. Yes, you need to republish all when you add a page, as Doug says.


(Doug Bennett) #7

Did you republish all pages or just the one you added? I did a quick look at what I think is the page that has the Paris, Europe, Nordic page (called page1.html) and it has not been updated since April 10th:

2017-10-10_13-34-04


(Harold Appel) #8

I just did “publish site” and there was no change. I’m now doing “republish all files” which I thought I had done the first time. All the pages have the blue dots and it’s working as before. I did notice my new page Marseilles, Provence, Middelburg was being uploaded. I really appreciate your help! Hope it works this time.


(Harold Appel) #9

Aiaiai. The new page still doesn’t show up! The blue dot is gone next to all pages in RW. I’m sure i’m doing something particularly dumb but don’t know what it is. I’m a refugee from Freeway and wanted to make a responsive site so tried RW. It was all good until now.


(Doug Bennett) #10

is this the page that should have the link to the new page?


If so it is still showing April 10 as the last update. Might want to check your publishing settings, in particular, the path.
Might want to look at your host file manager, and give us a screenshot of what you see.


(Harold Appel) #11

Yes. That’s it. Even though when I test my settings and It passes, I am now getting a message that it couldn’t connect to the server right at the end of publishing. At least I know what the problem is but I’m not sure how to fix it. The only thing that changes was the server name as the site was migrated from crab.arvixe.com to shared19.arvixe.com

the path didn’t change:


(Harold Appel) #12

Still no joy. 28 PM
Photos 19 contains the images in question:


(Makrinus) #13

I have the same problem with Safari and Google Chrome, for example when changing margins or padding and publish. If I reload the entire page or delete the browser history, everything is OK. Firefox does not have this problem. In my opinion it’s not RW, but the browsers since the last Apple and Google updates in September.


(Harold Appel) #14

Problem fixed. The problem had nothing to do with RapidWeaver and everything to do with my hosting company. They migrated the main domain but not my subdomain to the new server. I thank you for all your help and sorry for the unnecessary diversion as this was not a RW problem at all.


(Harold Appel) #15

Makrinus, I do think it’s normal for all browsers to display a cached page first and need to be refreshed to display changes. I just tried this in Firefox and it was true there as well. Not my problem exactly which was due to nameserver information being incorrect.


(Doug Bennett) #16

Harold (@nerval) is right, it’s normal for browsers to read from cache first. You can control this, look at the screenshot above, there’s a expire date, and an http max-age that’s being set somewhere.

Reading cached pages is great for your users as it greatly speeds up your page rendering.


(Makrinus) #17

Hello Harold, hello Doug, I didn’t express myself properly. Of course, the page must be reloaded for the changes to appear. Nevertheless, since the last browser updates of Apple and Google this is not possible anymore. I must explicitly delete the history. With Firefox everything works the same as before–> Upload the changes and reload them in the browser. In the German RW Forum there are further contributions from affected users.
Because Harold’s problem is/was different, we can certainly end the exchange at this point. Thanks until the next time.


(gille) #18

If it’s a dns caching problem, there is a quick fix for that. Just go to the internet connection on your mac and add 8.8.8.8 and 8.8.4.4 in the DNS server list along with what’s in it. It will use the google DNS and update the site like it should.