Html stack error OR user error ( the user being me )


(Phillip Noury) #1

hello …my first time asking for help here - so thank you for even taking a look :wink:

I have a basic RW site for my photobooth business, a vendor offers a service for my business and provides a html script to apply in my site. I figured this should be simple , make a new page, add a html stack, paste the supplied code in the stack, save & preview … but, the code is not working as expected ( nothing appears )

What I have tried ; html stack, html page, looked at both in RW preview, safari preview & actually publishing the site live to view. The results were the same ( it show up in the source code only )

I can not find any real useful info on the snippet tool(?) should I be reaching for this as a solution ?

Im not asking for help to fix the code ( im assuming the vendor has it right) , just hoping to learn that im missing or overlooking a simple step on my end

im running RW 5.3.1
my site is www.thebetterbooth.photo

i can paste the script here too ( or a pic of it ) if helpful - or I can make that page live again

again thanx for looking and for any help

-phil


(Jason Bostick) #2

Not saying that this is the issue but one thing to double check is after you paste the code in, highlight all of the text and in the Rapidweaver menu go Format and then select Clear Formatting


(John Higgins) #3

Does the code have php tags? If so, make sure that your page is set to index.php and not index.html.


(Doug Bennett) #4

If the above doesn’t work we will need to see the code and/or the page live again in order to see what’s going on.

As Jason points out, it maybe something as simple as formatting of characters from were you copied and pasted from.

It is always best practice to paste as plan text (option + command + v).


(Phillip Noury) #5

thank you guys !

( i forgot about the reformatting thing )

I will give each of those a try in a hr or so and post my results :slight_smile:


(Phillip Noury) #6

update, I did try the suggestions with no luck

heres the live page link http://www.thebetterbooth.photo/page6/index.html

as Im sure you could see the pasted code , it starts with

"< script>var _pbt=_pbt||[];_pbt.push….


(Doug Bennett) #7

It looks like you’re inserting (or trying) inline Javascript.

< script >
    var _pbt = _pbt || [];
_pbt.push(['_setAccount', 'PBO-hXpaS2uFH0eXHYstrFvG3g', 'version', 'V3']);
_pbt.push(['_trackPageview']);
(function() {
    var e = document.createElement('script');
    e.type = 'text/javascript';
    e.async = true;
    e.src = 'https://widget.photoboothtemplates.com/Scripts/PbtWidgetV3.js';
    var t = document.body.getElementsByTagName('script')[0];
    t.parentNode.insertBefore(e, t)
})() < /script>

It appears your opening and closing script tags have a space between the opening angle bracket < and the tag.

< script >
Should be:
<script>

< /script>
should be:
</script>


(Doug Bennett) #8

When I run that script alone all I get is a blank screen with a search box (upper right):


(Phillip Noury) #9

thank you for your time and help…

I will go back to the vendor and see wassup with his script I checked RW source view and see the script is as the vendor supplied…im now thinking RW and or myself may not be to blame ( guessing )


(Doug Bennett) #10

It appears to be working now vary slow to load perhaps the java script 'https://widget.photoboothtemplates.com/Scripts/PbtWidgetV3.jst
was not available:


(Phillip Noury) #11

Once again THANK YOU for your help…problem is resolved. there was an issue on the backend with preferences settings for my account with the vendor.


(Phillip Noury) #12

yes ! although in my site it doesnt populate or fill the page as well as here ( im only getting 2 columns ) Ill try to adjust the fill settings


(Mark Harradine) #13

Also, if his code is pasted into a Styled Text container, he should select the text and choose “Ignore Formatting”, right?
This will highlight the code (pink) in RW and ensure it is treated as code.