Problem after re-installing RapidWeaver and all plugins and stacks, after fresh reinstall of operating system (sans migration as advised by good old Apple Care)... PLEASE HELP!

Hi all - fresh install of everything… when viewing the EDIT tab, I can see everything and it appears like its all there - stacks, content in said stacks, etc… just like I had it before… however when I click the PREVIEW tab - it renders my site with a plain white background and all the content down the left hand side of the screen and just in order of appearance but not formatted where I want it / expect it, etc. I can’t for the life of me work it out. I have urgent updates and amendments needing publishing, but I’m scared to click publish because it’ll presumably push up this broken version of my site. Thanks in advance for assistance. Steve.

I’d check and make sure the theme hasn’t been changed, or try changing theme and then switch it back to the theme you want.
Most of the styling (CSS) usually comes from the theme.

1 Like

Thank you Doug - tried that, and did nothing different… showed the same in other themes actually - slightly different but the same issue. I’m using Foundry btw.

Well Foundry requires the foundry theme so you definitely need to set it that way.
Foundry also requires a styling stack(don’t remember the name and not at my Mac right now) on each page. I would check to make sure that is still in place.
Other than that perhaps Adam @Elixir might have a look.

Sounds strange for sure. Not sure this is Foundry related though. I’d be happy to load up your project file here and take a look @steveburden if you can send me a ZIP file that contains your project file. You can email it to adam at elixirgraphics dot com

If it is larger than about 5mb or so send it over vis something like Dropbox.

Thanks mate - yes thought so… defiantly have the stack installed too but thanks again for your suggestions… below this, Elixr has replied and offered to look through it, so I’ll get a project file to him and see what is happening there. Cheers so much.

Thank you Adam! Just trying to work out how to extract the project file and I’ll do that… is it export? I did that and have a folder with many sub folders that look to contain the site but not one file?

Ignore that! Worked it out. Sending now… Cheers!

Just took a look at your project file. The file shows in Edit Mode here, but it is not displaying properly because you have two javascript errors due to code you’ve inserted into the page in the Code settings in both the main RW settings as well as in your Page Inspector.

When I open your project file and preview it this is what I get:

Is this what you see when you preview your project?

When I correct your two javascript problems this is what I see:

I only made corrections on the Home page, as you didn’t specify which page was the problem page. I corrected the script tags in these two locations:

The first one is in the Code section of the main RapidWeaver settings under the HEAD tab. You’ve got two opening script tags there in a row instead of an opening script tag followed by a closing one. The one I indicate in the screenshot should be a closing script tag.

As for the second screenshot – that is found in the Page Inspector on the Home page. It is also under the HEAD tab. I’ve indicated the tag there that should be a closing tag as well.

When I correct these two problems where you’ve made a typo on the Home page the page previews fine here.

If after fixing those problems you’re still having issues, then something else may be awry with your setup. But I’m pretty positive none of it has to do with Foundry itself.

You’ll want to check your custom code on all pages in the Page Inspector since you may have copied and pasted that trouble code from page to page.


Wow! Adam I can’t thank you enough for this fix - total cube here - no idea of coding… amazing what a single / can do! Ok so I removed ALL SCRIPT from each individual page, and entered only corrected script )just added that one / where you said to add it), and it appears to have worked. I’m hoping now the google and facebook tracking pixels in question work site wide now, but believe they will - and more to the point, they won’t keen breaking my site! Very impressed with your level of support here mate. Ta.

1 Like

Not a problem. Glad it is all sorted out for you now. :+1:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.