Https, images and SSL

I have set up my page to be SSL secured. All pages are now directed to https:// sites, except for the images. As can be seen in the firefox inspector in the media tab, all used media (favicon etc.) are directed to an https:// page, except for images embedded by an image-Stack (Stacks 3) and changes to background images embedded in my Lander-pro theme via css. I have changed the web address in the general settings to my https:// address, and of course the ssl certificate is confirmed and working.

Anybody with a similar problem? I thought that maybe the Stacks settings might need adjustment but couldn’t find anything. This would af course not help altered background resources via css.

Any help appreciated!

URL would help?

Did you republish all files?

Thanks for the replies!

Yes all files were republished.

URL would help? I don’t quite follow. I read somewhere that one might have to manually change the URL for resources (I have stored all images in rw resources), but could not find where to make this change.

That would mean for you to post a URL to the site here on the forum for folks to see what’s going wrong and help you out.

There’s people here that probably can help but can’t really tell what’s happening without seeing the page and images on the site themselves. Other wise they’ll just be guessing.

1 Like

Oh I see, sorry for my misconception.

The URL is:

Not sure if I understand you, when you say “directed” with the link you gave it doesn’t goto https.
If I type in
It goes there but you don’t have a redirect yet forcing all http to https.

I don’t see it? What page or image are giving you an Error? I’m not getting any errors on the home page.
Perhaps a screenshot of what you are seeing.

I ran the page above through WhyNoPadlock and the only error was Not`Forcing HTTPS.


Ok, now I got it. I had not used the setting to force all http to https. Found it and fixed it.

Thanks a lot for all the very helpful comments!! Much appreciated! :sunglasses:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.