HTTPS on a website

My current website starts with http but not the S. How do I make the site start with HTTPS and be secure?

Thanks Bill

First you have to have a security certificate (mosts host have them for free these days) installed.
Then you change the siteURL in RW to the https version
Make sure any content that you may be pulling in from somewhere else is coming from a secure site.
make the redirect changes in your .htaccess file to force the https version to load no matter what the visitor may type as the url


You can also go the CloudFlare route:


Okay, thanks.

BTW if I set up a new website on RW and enter the URL as HTTPS://new Website is that all I need to do to make it secure?

Thanks again

That’s one thing you need to do, you also have to have a security certificate


These might helpful:


Thanks everyone for your help.

I have gone through the Cloudflare route. My hosting service is Bluehost and the cpanel has an icon for Cloudflare. I setup an account for Cloudflare through Bluehost. I assumed that was all I needed to do to get a certificate and the HTTPS capability. But I do not see that happening. Is it just a matter of waiting 24 hours for a certificate to be issued? Second question: is there a youtube tutorial for how to do this on a step by step basis?

Thanks again


CloudFlare doesn’t automatically do anything, did you watch the video above? Did you read the kB article posted above? CloudFlare does a lot more than https. You need to configure the settings once you’ve got CloudFlare account.

Thanks - I think I have it.

Hi guys, I have also used this thread to update my site to https. I am having a problem with Google ads not showing up now. I have updated the links to https and republished in RW. Anyone have a solution for getting ads to show again? The site is Thanks!

Looks like you have mixed content.

If that’s the code you added for ads then you need to change to https as well.


I’ll give that a try!


Thanks to Joe Workman - I listened to your podcast. You made a statement about mixed content but not how to fix that mixed content. What I mean to say is, I know how to use stacks and some very basic code but not how to go into the content and change any http references to https. So I am a basic RW user not a coder

I did look at the source code for my site in RW and the only http references were in the meta tags area and a tag titled http-equiv.

The website I am working on is at

Again being a basic user trying to do the right things, I wonder if the Health Check in RW could locate these http problem areas?

Thanks for all of your time and help


Your home page uses an image for the background:

It is being loaded from a folder called warehouse? Looks like it’s being loaded by jQuery. Didn’t dig deep enough to find what stack is loading it, but however, you set the background image to load check to make user you are using https.


No, it doesn’t. there is a site (free to use) that you can check one page at a time:

Thank you for your help! After brunch and the Super Bowl, I will look into these!

Much appreciated!


You will need to update any resources that use http to be https. This is a good resource to help you identify issues.


A Very Large Thank you! As an interim solution I removed the image and replaced it with a color and I got a lock symbol meaning that your find was the problem and the website is good and secure!

Going forward I will look for or avoid the level of warehousing that caused this issue.

Thank you and everyone for your help!


https is easy tio get nowadays but you should try to get a SSL certificate. Cloudflare is also a good way to secure your website.

1 Like