Ssl certificate


(Marcoen Hopstaken) #1

I installed SSL certificates on my websites. In the general settings I changed the web-adress in https. When I go to the website using the www. adres, I’m nog redirected to the https adress. What’s missing?


(Doug Bennett) #2

Going to HTTPS (SSL) is a multi-step process.

  1. Get your cert
  2. Check and fix any references to HTTP:
  3. Redirect any HTTP request to HTTPS.
    Here are a couple of post that will help you.
    SSL - Will old full links with "http" work in the new ssl environment?

(Brandon Scott Corlett) #3

@Marcoen are you using Cloudflare or did you buy an SSL?


(robertreinink) #4

This did helpt me get it done.


(Joseph Acevedo) #5

The July 2018 update by Google displaying unsecured website messages has pushed my web host to offer Let’s Encrypt SSL for Free. I am not a vendor though I do link to a 3rd party online store which has SSL. Most of my webpages are just informational.

So I just want to be clear on the required steps.

  1. Get the SSL certificate
  2. Redirect HTTP to HTTPS in htaccess file
  3. In Rapidweaver, fix any absolute URLs to my webpages or warehoused image files.
  4. In Rapidweaver, change my web address in the general settings to use HTTPS
  5. Re-upload website to server.

Aside from steps 3 and 4, are there any other steps needed to be done in Rapidweaver?


(Doug Bennett) #6

This should be the last step, make sure everything works okay prior to redirecting.

Also might want to use whynopadlock.com to test for mixed content prior to the redirects.


(Joseph Acevedo) #7

Thanks, I’ll do that step last.

I got the SSL certificate working. I just watched Dreamweaver update my domain URL from http to https 121,067 times on 5,792 documents in my website folder. This included the rw6 and rw7 site project files that I had there as well. So now all of my Rapidweaver html pages have been updated as well by Dreamweaver. I have thousands of broken images now and I’m hoping they get fixed when I re-upload my html pages.