Ich möchte totalCMS nutzen, um eine einfache Bildergalerie zu erstellen

Ich möchte auf einer Portfolioseite Bilder in einem Raster bestehend aus Quadraten (3 Bilder je Reihe auf Desktops) anordnen.
Da dieses Portfolio stetig wächst, möchte ich es mit total CMS mit immer wieder neuen Bildern füttern.
Allerdings … und jetzt kommt das Problem … möchte ich keinen Lightbox-Effekt bei den Bildern haben, sondern lediglich die Bilder dort platzieren.
Ja, ich könnte wahrscheinlich TCMS Bilder-Stacks einzeln mit IDs auf der Admin-Seite versehen und auf der Zielseite verknüpfen, aber ich denke mir, dass das eindeutig zu aufwändig ist und es bestimmt eine einfachere Version gibt. Die fällt mir aber partout nicht ein.
Habt ihr eventuell eine Idee, wie ich das Problem angehen/lösen könnte?

Zum besseren Verständnis habe ich mal eine Skizze meiner Wunsch-Konfiguration gemacht.

Gruß
Jan

Gallery Stack hat eine TCMS Integration und unerlaubt, keine Lightbox zu öffnen.

Discount code BLACKFRIDAY20 gibt 20% Rabatt

2 Likes

Der Gallery-Stacks ist gut. Eine Alternative ist vielleicht der Photo Stack von Nick Cates. Funktioniert ebenfalls mit TCMS. Oder eine Lösung mit TotalBlog

den habe ich sogar! :wink:
Werde ich mir mal ansehen und ausprobieren.
Nehme ich denn als Admin-stack den TCMS Gallerystack?

den Photostack habe ich auch … und wie soll das mit dem TotalBlog gehen? Kann ich das vielleicht sogar mit meinem Blog verknüpfen, den ich auf die Seite einsetzen möchte?
Ich habe noch nie einen Blog erstellt und möchte das das erste Mal auf meiner Website ausprobieren.

Gruß
Jan

Genau.

Im Testprojekt Download ist ein Beispiel.

1 Like

Das ist kein Hexenwerk. Sowohl für den Gallery- wie auch im Photo-Stack benötigst du einen CMS-Stack (Gallery, Image, etc.) im Admin-bereich. Dem gibts du eine ID und verknüpft dem Gallery-3- oder Photo-Stack mit dieser ID. Vom Prinzip nicht viel anders wie z.B. bei Textfeldern.

Das TotalBlog ist eine andere Sache, aber das hier zu erklären, ist aufwändig - die Möglichkeiten sind schlicht zu vielfältig. Lade dir einfach eine Demo dazu und experimentiere damit in einer Ecke deines FTP-Servers

1 Like

Auch das unterstützt Gallery Stack. Blog Gallery. Ist im Test Projekt auch gezeigt.

super, danke. Schaue ich mir gleich mal an …

gut, da werde ich mich mal in die Thematik reingraben und mir die aktuellen Tutorials von Joe ansehen.

Wenn du kein Demoprojekt für TCMS findest, schicke mir eine PN

Hi Jannis,
ich habe das mit dem Gallery3 Stack ausprobiert. Allerdings habe ich ein Problem damit. Ich habe einen Testordner in meinem Rootordner angelegt und lasse dort die Daten für die neue Testseite hochladen. Soweit so gut. Leider wird der cms-data Ordner nicht dort sondern im Rootverzeichnis angelegt. Wenn ich aber mit TCMS Einzelbildern und entsprechenden Verknüpfungen arbeite, wrid der Ordner im Testordner angelegt.
Kann es sein, dass der Gallery3 Stack den cms-data Ordner immer im Rootverzeichnis anlegt, egal ob ich ihn auf ein Unterverzeichnis zeigen lasse?

Gruß
Jan

Der cm/s-data Ordner liegt immer auf der Root-Ebene. Das gehört so. Der wird auch nicht vom Gallery-Stack dort hingelegt, sondern von TCMS beim ersten Aufruf der Adminoberfläche angelegt

1 Like

hmm, ist bei mir aber nicht so?
Meine Hauptseite liegt im Rootverzeichnis. Die Testseite liegt im Rootverzeichnis unter /testseite Den ftp-Uploadpfad habe ich im Rootverzeichnis unter /testseite gesetzt.
Die TCMS Adminseite habe ich in RW bei den Seiteneinstellungen unter /admin als index.php abgelegt. Sie liegt also in /testseite/admin
Setze ich die reinen TCMS Stacks ein (sowohl auf der Adminseite als auch auf der Userseite), dann wird der TCMS cms-data Ordner tatsächlich im /testseite/admin angelegt.
Das klappt mit Gallery3 nicht.
Ich habe es mehrfach ausprobiert, indem ich vorher manuell die Daten aus dem Testfolder gelöscht habe und per republish all in beiden Varianten wieder aufgespielt habe.

Gruß Jan

Noch mal zur Klarstellung: „Root-Verzeichnis“ meint nicht Root des Servers, sondern Root der jeweiligen Webseite, in diesem Fall der Testwebseite. Das ist die, wo auch die index.html bzw. index.php der Startseite liegt.

Hier wird der Ordner für das CM/S angelegt. Aus dessen Eingeweiden solltest Du nach Möglichkeit die Finger lassen (nur so als Warnung)

1 Like

ja, das ist vom Prinzip her auch klar, daher kann ich mir das ja auch nicht erklären.
Im Server-Root habe ich den Publish-Pfad von RW auf “/meine_website” (meine aktuelle Website) in den Uploadeinstellungen gesetzt. Die Testseite habe ich in den Uploadeinstellungen auf “/meine_website/testseite” gesetzt. Trotzdem wird der cms-data Ordner beim Einsetzen des Grafik3-Stacks in dem Ordner “/meine_website” erstellt und bei den “Original”-TCMS Stacks im “richtigen” Unterordner “/meine_website/testseite”.
Ich verstehe es einfach nicht?!

Das verstehe ich dann auch nicht. Ich denke, das ist ein Fall für den Support

Der Pfad im Projekt unter „General“ (nicht nur in den Publishingeinstellungen) stimmt…?

1 Like

ja, der ist identisch.

Passiert das mit der unveränderten TCMS-Demo auch?

Hast du noch einen Zugriff auf einen anderen Server. Passiert das auch, wenn du dort veröffentlichst?

1 Like

nein, habe ich leider nicht. Ich werde jetzt noch einmal ganz neu aufbauen, einen anderen Zielordner nehmen und prüfen - kann doch nicht sein, dass das so holprig ist.