Impossible to install banner images RW7, any theme


(Johannes Osenberg) #1

Actually not a single theme does accept Banner images, neither site wide nor page specific.
No realmac theme, no nick cates theme.
Can somebody advise?

Thanks very much in advance

Jo


(Jannis from inStacks Software) #2

https://rapidweavercommunity.com/tutorials/series/new-features-in-rapidweaver-7/episode/banner-images


(Johannes Osenberg) #3

Thanks or your info: I´m sorry- this is not my first rw project and your link showed me how to use banner images in general.
But: this feature does not work.
In any theme I opened it says: “the theme you have selected does not support banner images” either in “General” section and in page specific section.

The forum doesn´t already have a solution for that as far as I could find out.


(NeilUK) #4

I’ve used a Nick Cates theme before that uses banner images. They are added by overwriting the main banner image.

If you let us know which theme you’re trying to use, we might be able to point you in the right direction.

Saying that no theme accepts banner images is just not true. I’ve used banner images in over 10 RapidWeaver projects using different themes.

Each theme might implement them differently, so without knowing which theme you’re using, it would be almost impossible to help you.


(Johannes Osenberg) #5

Thanks Neil,

I can only write what actually happens. I cannot use any banner image on any theme - that´s a fact.
Right now I´m using N Spire Deux by Nick Cates but all original RW-Themes deny banner images as well.
I don´t think that I have to proved screenshots as a proof?

Thanks very much for further investigations!


(NeilUK) #6

Unfortunately, I don’t have that theme. I have “Writer” by Nick Cates and I can add banner images into that theme using RW7.

I would contact Nick if I were you. I have looked at the theme’s instructions and you can add background images using the banner override function, apparently.

Good luck


(Doug Bennett) #7

The banner image is new in RW7, and the theme must support this feature. Old RW6 themes that have not been modified to use this will not support it.


(Robert Ziebol 🖖🏼) #8

There are two for sure that will work with this option that you have installed as they come with RW 7. Offroad and Lander. Try it on those themes and see if it works for you.


(Johannes Osenberg) #9

Thanks for your support.
I already tried every theme. I contacted Nick also. He suggested to start from scratch with that theme but that did´nt work either.

Summary:

  • not a single theme accepts general site banners
    -not a single theme accepts overridden site banners
  • it always shows “the theme you have selected does not support banner images” wether I start from scratch or when I move a setup to a different theme.
    -I have all actual versions (from rw7: 7.2.2 and all actual plugin versions.)
    -I restarted RW several times
    -I rebooted my mac

So nothing seems to work…


(e.g.,) #10

Wondering:
Did you try a fresh new RW project using that theme & try to overwrite the default image to look for outcome?

I’ve had weird issues with RW content that has been experimented on at length when things don’t work - not work until I reboot the machine the next day. I think it just gets tired & throws in the towel & goes to its “safe place” for a few hours!

(Joking, of course - but it is a phenomenon I’ve bumped up against).


(Johannes Osenberg) #11

Yes I tried, but there is no way placing an image in the banner container.
Too bad.
I´ll now try Realmac support.

Thanks for all your suggestions!


(tim parsons) #12

Is this problem still ongoing @joos @Runamok ??

I was told by a member yesterday, that it is often the most obvious things that get overlooked ??

I am wondering if a suggestion or two from a novice might help ?, are you sure you are using RW version 7 ?

Is it a genuine JPG file you are trying to use ?

Is the JPG file the correct size ?

Do you have the latest RW 7 version of the Theme you are using ?

Are you using Stacks version 3 ?

In fact the theme mentioned above “N Spire Deux” I believe, there is a “paid for” upgrade to make it MORE compatible with RW7 and Stack 3’s new features ?

Tim


(e.g.,) #13

Why, yes. Could be…


(Johannes Osenberg) #14

The problem is not solved by now:

I have all actual versions (from rw7: 7.2.2 and all actual plugin versions.)
Since there is no way to drop an image in the banner fields because of the message I don´t know if different types of Pictures (.jpeg or else) would matter.

I already contacted Nick Cates but I have all actuals versions of themes, too.


(Doug Bennett) #15

Just followed @ben’s video with a new project using the voyager theme and it works.

http://rapidweavercommunity.com/tutorials/series/new-features-in-rapidweaver-7/episode/banner-images


(Johannes Osenberg) #16

That´s nice but it doesn´t work on my machine.
I wouldn´t have asked the forum if it was a “how to”-question instead of a bug.

Again:

I already tried every theme. I contacted Nick also. He suggested to start from scratch with that theme but that did´nt work either.

Summary:

not a single theme accepts general site banners
-not a single theme accepts overridden site banners
it always shows “the theme you have selected does not support banner images” wether I start from scratch or when I move a setup to a different theme.
-I have all actual versions (from rw7: 7.2.2 and all actual plugin versions.)
-I restarted RW several times
-I rebooted my mac


(Will Woodgate) #17

A long shot I know, but do you have any specialist software or drivers installed that modify the behavior of your mouse?

I only mention this because I recall a discussion a long time ago on these same forums where an individual could not drag and drop stacks from their library into a page or drag new photos into RapidWeaver. After an exhaustive amount of troubleshooting, a rogue piece of software connected to a mouse / pen tablet driver was found to be the culprit.

Additionally if you double click the dropzone for the theme banner image (in the Page Inspector), you should see a Finder window open with the option to manually select a suitable image from your computer. This is an alternative to dragging and dropping an image in.


(tim parsons) #18

Additionally if you double click the dropzone for the theme banner image (in the Page Inspector), you should see a Finder window open with the option to manually select a suitable image from your computer. This is an alternative to dragging and dropping an image in.

@willwood Thank you so much for that Tip Will, that is absolutely brilliant, i wonder how many other fantastic time savers there are like that one that i dont know about ?

I saw on a Video on here somewhere, one of the developers Copied a Stack on an Edit page, but it happened so dammed quick i didnt see how it was done, i think it involved pressing the ALT key and one other key, but i cant be sure, can someone please point me to the official “short cut” for copying Stacks, thanks.

Tim


(Will Woodgate) #19

To duplicate a stack, select it in edit mode (so it has a blue highlighted border). Hold down the ALT key while dragging the stack by its title. This action will clone the stack and let you drag it to a new position.


(tim parsons) #20

@willwood Thanks Will that is just what i wanted, spot on thanks. I should be able to remember that :slight_smile:

Tim