In an awkward place - suggestions please

Although I haven’t changed anything apart from a few words and pix in this particular RW project, I’m now getting the attached message popping up from time to time in preview mode. It is a fact that I’m using PHP 5.6 because the project makes use of Kuler Solutions MYSql Stack Set, which doesn’t work with anything higher than 5.6 - and sadly Kuler are not around any more. My questions are - I’m I likely to experience the problems the warning window suggests - and is there another stack for displaying SQL data in a webpage as elegantly as MYSql (and work with PHP 7.X)?


1 Like

There is something in the pipeline from the maker of platform.
CRUD with SQL data and fit with PHP7.2 +
I am also using Kuler and running out of PHP-version.…

1 Like

Thanks but I guess I’d need to migrate over to Platform and I’ve invested heavily in Foundry.

You’ll have to wait and see what they release. My guess is that a stack like this will not require a specific framework like Platform. That would limit the market for a stack like this. You’ll like be able to use it with any theme or platform, like Foundry.

I’ve never used it but there is this -

Have you got a Joe Workman stack on the page? Looks like a warning that he’s added in.

Yes, seen this Rob. I suppose I could give it a try. Any thoughts on the PHP message?

Oh really? I’ll have a look. Not a native RW warning then?

I’m using JW’s PageSafe stack - that’s it. Thanks very much.

It’s implying that you’er using something else which requires PHP 7.2.0 - maybe another stack, maybe even PageSafe itself?

Must be PageSafe but the product page says works with PHP 5.6 and I’ve been using it for at least three years without trouble. Have put a support request into JW.

Think it was a decision to set nearly all of his stacks to php 7.2 minimum because of a high number of support tickets being to do with the wrong php version being used.

A more definitive answer on if page safe works ok with 5.6 I’m sure will come from Joe

You can definitely use Kuler SQL beyond PHP 5.6. I’m running php 7.1.16 and getting a similar message.
Screen Shot 2021-02-19 at 9.55.33 AM

Tried it with PHP7x and lost some functionality, which is why we reverted to 5x. But thanks. I asked JW about it and they/he kindly sent me this bit of css, which will hide the warning message:

They way I read it is as stated above - ideally we should be on 7x to avoid potential issues - but in most cases all is well with 5x (although the opposite is the case with us!).

1 Like

This stack will be framework independent. It’s still in the early stages but what I can tell you is that it will support MySQL/MariaDB, SQLite3 and PostgreSQL. And it will be ready for PHP 8, btw.


Great news! When do you think it will be launched?

Not sure yet. I hope that I can release it towards the end of March (2021 :slight_smile:)… I want to deliver proper quality, so take this with a grain of salt, please!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.