Php html error message


(Eric davis) #1

Hello Community.

I published my rapidweaver page and got this notice:

Multiple index files found on your server
RapidWeaver noticed that you have the following files on your server: index.html, and index.php

Having multiple index files can causes issues when loading your website. We recommend using an FTP application to remove redundant index files.

What should I do to fix this?

I notice in my page inspector in general settings that there are 2 pages whose filenames are “index.php”

I also noticed that those pages have stacks with structure data.

What should I do to correct this?

Best,
E


(scott williams) #2

You need to delete the .html one off your server. Using ftp or your server file manager.

To avoid these issues in the future, you can set the preferences to .php and pages after you do that will default to .php

Some pages need PHP, forms and some stacks, if it isn’t needed, it won’t have any downside if you use it anyway, so just setting PHP as default is the easy way to not have issues going forward.


(Eric davis) #3

Thanks for this advice. when you say set preferences to .php , where do I do that? On Rapidweaver?


(Eric davis) #4

Thanks for this advice. when you say set preferences to .php , where do I do that? On Rapidweaver?


(Eric davis) #5

Thanks for this advice. when you say set preferences to .php , where do I do that? On Rapidweaver?


(Greg Schneck) #6

Settings (in left panel) “Advanced” at bottom… Set Default Extension “php”


(Eric davis) #7

THANKS!! I appreciate it :slight_smile:


(system) #8

This topic was automatically closed 6 days after the last reply. New replies are no longer allowed.