iPhone Favicon not updating!

This is really frustrating me …
I used RW web icons setting to upload fav icons and all works correctly on my Mac and iPad but refuses to update ‘fully’ on my iPhone.
It is literally only my home page that refuses to update in my iPhone as all other pages load the fav icon correctly.
Also if I add /index.html to my domain it updates fav icon on the home page correctly. But when I click on the ‘Home’ link in my navigation bar the fav icon is changed.
Even more strange is the fact that the fav icon showing on my home page when visited on my iPhone is iMore’s fav icon!!!
I have no idea how this has happened, I’ve cleared cache and safari website data and also deleted cache through the go to folder ~/Library/Safari/

Attached are iPhone screenshot to show problem fav icon (iMore)and iPad screenshot which shows correct fav icon (football)

Thanks in advance


image image

Can you post a pic of your top level web server directory? That is the files on the top level of your public server directory?

Also what theme or framework are you using?

Lastly…can you share a link to page?

Lander theme

My personal view is it appears to be an iOS problem, or at least my iPhone 8 running latest iOS seems to be caching from somewhere!


Can you drill down to your uploaded rapidweaver html files in the pic? Imo it’s worth confirming you have a clean upload that only consists of a single index.html.

Also what should the fav icon be? In my end I see a soccer ball (or as you likely call it a football :slightly_smiling_face:).

Imo another thing worth trying is deleting all of your posted RW files (emptying your server) and re-publishing all.

Make a complete back up before deleting your server.

Did that already, with no luck.
As I said on my iPad all shows correctly so I know the info from server is correct, I don’t want to reset my iPhone just because of one fav icon!

Yes only one index.html

Hmm that is odd. On my iPhone 8 the fav icon appears correct. Have you had anyone else with a similar iPhone duplicate the issue? Maybe it’s an iOS glitch with the build that’s installed on your phone?

One suggestion I just read online is to visit the domain in private mode, let the site load, then switch back to regular browsing mode. Worth a shot.

You shouldn’t have to “reset” your iPhone just to clear the browsers data.

If you don’t want to clear all browsers data you can do it by a single website.

Go into settings>safari > advanced

At the top there’s an option for website data, select that.

You’ll see a list of URL’s, find yours, you might have to select “Show All Sites”.

Slide from right to left on the site you want to clear, a red Delete button should appear.


This makes no sense… Lander is a theme and so is Foundry… Are you using Foundry stacks with the Lander theme?? This should not be done. I doubt it has anything to do with your Favicon issue, but if what you stated is true, you have more issues than your Favicon icon. Lander is made by Multithemes and Foundry is a framework made by Elixirgraphics.

Edit - Oh wow, you are doing that!!!

This is a BIG no no. You should not be using Foundry stacks with the non Foundry theme.


Tried that several times, still loads wrong fav icon!

Why is this so bad?

Have you tried to rename the icon file, insert, and republish? For instance…”myfavicon_v2.png”

Yes tried that too, I think I need to reset phone to sort it out

Frameworks like Foundry use stacks that are made to only work with the theme that comes with the Framework.

There are things like JavaScript and CSS that the stacks will assume are there because they are part of the Theme.

You can ask Adam @Elixir the developer of Foundry if you want.

1 Like

@DazFisher Every framework needs a theme to work with it, a dedicated theme. So this is not a Foundry thing, but a framework thing.

For “geting started” documentation at Foundry you’ll find this info:

As two others have already pointed out you NEED to use the relevant theme for a specific framework.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.