ISP, home wiring, or cable-modem problem... Help please

I have a problem either with my ISP (Spectrum cable) , my home cable wiring, or something on my cable-modem/router has changed. How do I know it’s not server or computer related? Same problem shows up going to 3 different servers (w/ different hosts) and with two differeent computers and e different “ftp” (sftp) apps including RW. I’ve not experienced connection problems for a long, long time. (Years)

I’m currently traveling and connection is rock solid from hotels. Thus, I conclude it has to be my home wiring, cable modem, or router causing the problems.

Can anyone suggest how I can “debug” this? Perhaps an app, etc? Ping tests show no dropped packets but then file transfers will immediately timeout, disconnect, reconnect, etc. (from my home) Again, in traveling (hotels), connections are rock solid from RW and ftp/sftp apps both.

What problem are you having? Dropping connection, slow speed or something else?

If you can get it to fail by doing something (like downloading a large files), then the easiest and most reliable way would be process of elimination.

Since you know the computer seems to work fine from the hotel, try plugging the computer directly into the cable modem. If it “fails” the test, try swapping the cables from the wall to the cable modem then the cable modem to the computer.

If it passes the direct to cable modem test, the it’s somewhere upstream in your home network. Again process of elimination, swapping cable by cable switches and router until you find the point of failure.

I recently went through this process of elimination on my office network. I used an Apple macOS combo update file that would always stop downloading with the browser(showed a network error) before completing. After multiple test I found that my router was the issue.

Many times it’s a cable or something else. If it’s sporadic the hardest thing is usually to find something that always fails. In my example above, once in awhile the file would download okay. That just means you have to repeat the test until you’re sat that you’ve isolated the problem.

1 Like

Hi Doug. Getting ready to fly back home so I’ll see what happens this evening. In general, whether I ftp/sftp one smalll file or hundreds of files it may or may not complete the transfer. I get dropped connections. If I try the same small file repeatedly it may complete first time, may take 5 tries, maybe more. Then a 100 file upload may work fine or give same. It very very sporatic and intermittant. I was going to try all the items you suggest tonight/tomorrow but first thought I’d ask if anyone knew of diagnostic app that might help. As I said, exact same thing happens with different ftp/sftp apps, different computers, and destination server makes no difference (3 servers do same thing.) But I’m kind of at a loss why 30 sequential pings show no dropped packets. More later…

The hardest part of debugging intermittent networking issues is getting a constant failing condition. All the network protocols (ftp, tcp/ip, etc) attempt to be self correcting. They have error checking built in and will retransmit failed packets at each checkpoint along the route.

Good professional network admins do have tools they use to help like network/packet sniffers like Wireshark or Etherapp. Unfortunately the learning curve for any of these products I’ve seen is incredibly steep and can literally take months to learn.

That’s why for home and small business networks I’ve always had good success with simple process of elimination.

Well… I’m stumped. I returned home from traveling to find same issue. FTP/SFtP Connection worked flawlessly from a hotel. I come home and with same Mac to same server(s) I loose connection repeatedly.

Ethernet and/or Wifi from router to Mac give same result. I replaced my Cable Modem which was activated yesterday. Exact same result. However, my Time Warner service had been purchased by Spectrum and I discovered that I could double my speed for the same monthly rate. Duh! Why did they wait to tell me?? So I now have 400Mpbs service and speediest shows 451 down and 23 up. Apple Network Utility shows no send or receive error. Ping tests show no packet errors.

But uploading to 4 different servers gives exact same result. Repeated dropped connections when uploading from 3 different Macs and 3 different apps.

Spectrum also told me that they will supply a cable modem for free and guarantee speeds with it’s use. So I’m going to schedule them to do that. (Anyone need a brand new Ausus CM-16 Cable Modem?) Perhaps with the Spectrum installer here he can find something. My router/wifi is relatively new and has always worked flawlessly.

have you enabled the FTP logging of RW?
i don’t know where this log lives, but it would be my first stop in trying to figure this out.


this option is in the Publishing tab of the RW prefs.

Just to followup… I had already replace cable/modem. Yesterday I replaced Router. Same result.

@Isaiah… it’s just dropping connections. For example, with error reporting turned on in FileZilla (and with most detailed reporting on) the error reported is:

“Data Connection could not be established.” - File transfer then disconnects, log reporting states “Resolving address of (server)” then successfully connects again and file is successfully transferred.

I have software set for retries so after a pause software retries transfer and all goes fine. The same result is seen from RW, FileZilla, and Yummy FTP. I have now eliminated computer, software, router, and cable modem. Only thing left is my ISP service and even though they say everything is fine I’m calling them out again requesting a senior tech.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.