Joe Workman Printer Stack Issues

Has anyone had any printing problems with the Printer Stack by Joe Workman? Any images in the stack’s Print Section show fine on viewing site, but if I try to print them, the preview only shows small question marks where the images are supposed to be. The other issue that happens after the first attempt to print out the section, is instead of having the printer dialog box show up, a small dialog box comes up that says “This webpage is trying to print. Do you want to print this webpage?” If I click “Print”, then the printer dialog box comes up with a blank preview.

Just curious if anyone has used this stack and experienced these issues.Screen Shot 2021-05-15 at 5.52.47 PM

Out of frustrating curiosity, instead of using @elixir Foundry Image stack, I just dragged the images I used into the column stack. They show up and print out in the Print dialog box without any problems. Of course, I now don’t have control over the appearance of the image that I had with the Foundry Image stack.

Might be helpful if you provided a URL to at least a test page that illustrates the problem.

I have also been playing around with a different print stack. I created this test page with Joe Workman’s stack. Images show up in the preview. However, there is an issue that I do not understand.
click to print…the preview appears. Click cancel. Then click the Print button again and the small dialog box appears telling me that the webpage is trying to print. If “Print” is selected, the preview appears without anything in it.

Any ideas about why that may be happening?

I tried the same thing in Windows 10 Edge browser, clicking to print, then cancelling, then clicking again to print over and over, and there were no errors as noted above. Then I decided to try Firefox on my different machines, and the dialog box didn’t appear. It seems that this is a Safari issue and I use Safari as my main browser.
Not sure why this issue happens in Safari.

I just tried what you said.

On MS Edge (MacOS Version 92.0.873.1 (Official build) Dev (x86_64)) works fine, the normal printer dialog box pops up right away everytime.

On Safari Version 14.0.3 (14610., the first time it pops up the print dialog box.

The secondtime I get a popup:

If I hit “PRINT” the print dialog box comes up okay.

For what happens for you, Looking at the WebKit(Safari) Forum, it might be the additional pop-up is being blocked by an adBlocker or pop-up blocker.

Do you have any extensions running on Safari?

Not sure why Safari is doing this extra pop-up. My guess is it’s “Mommy Apple” trying to protect you from printing something. Kind of stupid since the next thing that pops up is the printer dialog.

The only extension I have is 1Password. It is odd that Safari allows me to print once, but on the 2nd try, that little popup happens, and if I try to print, the print preview box is now empty. There is also a Safari setting for websites about allowing popups. For my website, it allows popups.
That is frustrating and you’re probably right, it is probably something with the Apple security features in Safari. At least I now know that FireFox and Edge work, which are probably the two main browsers that the majority of folks are using. Thanks for all your input @teefers.

New Edge is chromium browser, so chrome (the most popular browser in use) will probably work.
Chromium is used by more browsers(Chrome, Edge, Opera, etc, etc).
Firefox has their users as well.

WebKit is Safari only, however WebKit is the only browser engine Apple allows on iOS. Even Firefox and chrome have to use WebKit for iOS.

Nice to know. I can always hide the Print buttons in tablets, phones I guess. Sometimes “too much of a good thing” by Apple is, well, just too much. haha

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.