Live Preview doesn't work

I’ve been using RW8 for about a year. In that time, the live preview feature has never worked for me (I didn’t even know that it was a feature until I stumbled across a mention of it somewhere). Every time I wish to preview a change that I’ve made, I have to CMD-P and wait for the page to load up in Chrome.

Am I missing a setting somewhere that would get this working, or is this a possible bug? I’m currently using RW8.6 and Stacks 4.04 on Mac OS 10.15.4. Chrome is up-to-date as well. I’m using Source framework at the moment, but have also used Foundry without any change.

If I understand correctly your projects will successfully preview in a browser (chrome in your case). What happens when you click on the live preview in RW? Is it just a blank/white screen? Do you get a spinning wheel etc?

By “click on the live preview in RW”, do you mean Preview Mode (the eyeball in the toolbar), using Chrome’s in-app page viewer? If so, that works fine.

To clarify: Changes that I make in RW aren’t reflected in real-time when previewing in Chrome. I have to CMD-P to push out the changes. It doesn’t work as I believe it should (see https://help.realmacsoftware.com/en/articles/1905324-live-preview for what I’m expecting to happen).

Got it. I misunderstood and thought you meant that the internal RW preview (the eyeball as you point out) was not working. I don’t have anything to offer regarding possible browser based live preview issues other than to wonder if your project perhaps requires php? Doubtful as it seems your initial preview is working just fine it’s the updates. I’ll chime in if I think of anything. Best of luck.

1 Like

Curious if you’ve tried this functionality using safari as your browser instead?

I don’t think that’s what RealMac means by ‘live preview’. I think what they’re talking about is the ability to preview your entire website in a browser, navigating round the different pages, etc. and not being able to somehow ‘push’ edits made in RW to your local browser preview.

Rob

Did you try refreshing the browser?

That’s always worked for me.

Yes, refreshing the browser works. But based on RW’s documentation, it sure sounds like the browser should refresh itself in real-time. This screenshot is from https://help.realmacsoftware.com/en/articles/1905324-live-preview

I guess not. Their documentation at https://help.realmacsoftware.com/en/articles/1905324-live-previewdefinitely makes it sound like it does work that way though (unless I’m misinterpreting it!).